Tab Control and Combo Box Issue

Hi Experts,

I have created a tab control on a form with a subform on the tab control and a combo box the subform (please see frmMenuCreator on attached db).  I have three issues that are probably related to not selecting the correct control to change, but I just don't have a clue at this point.  Any help would be greatly appreciated!

1.  The combo box in form view doesn't display the formatting I've designated

2.  The combo box shows filtering options in each column's heading.  I'm assuming this is being "inherited" somehow from the query but can't seem to find a solution to disabling it

3.  All the pages of the tab control display the subform and combo box.  How do I create different controls on the separate pages?

Thank you!
Skip SleeperIT ManagerAsked:
Who is Participating?
PatHartmanConnect With a Mentor Commented:
You can't format the headings in the datasheet view using the interface.  You might be able to format at run time with VBA but I doubt it.  I had a list of properties that you could reference in datasheet view from VBA but I don't have it with me so couldn't post until tonight or over the weekend assuming I can find it.

If you change the view to continuous, you will be able to format the headers but you'll probably need to rebuild the form since the two form types are built differently.  The datasheet form view wizard builds the form with the fields listed in the detail section vertically with labels attached.  To use continuous view, you would want the labels in the report header section organized horizontally and the textboxes in the detail section also organized horizontally.
1 & 2:  Which combo box(es)?  It might help to post a screen shot or two to clarify the issue you are having.

3.  The problem is that your subform is on top of the tabcontrol, not "in" any of the tab pages.  Correct placement is a little tricky.  You have to
    - Click on the tab page you want the control(s) on
    - Click the edge of the page to select it (so that the page, not the whole tab control is outlined showing that it is in selection)
    - Click your heels together three times
    - Paste or place your controls onto the tab page.

I've done it here... just for demonstration I've placed it on the lunch tab (you can move it as needed)
Skip SleeperIT ManagerAuthor Commented:
Hi Mbizup-

Thank you for responding so quickly!  Attached please find the requested screen shot.  Also, is the heel clicking a special utility I can download? :)

Also I've got the tab control now--knew it must have been something "easy"!
Get 10% Off Your First Squarespace Website

Ready to showcase your work, publish content or promote your business online? With Squarespace’s award-winning templates and 24/7 customer service, getting started is simple. Head to and use offer code ‘EXPERTS’ to get 10% off your first purchase.

Also, is the heel clicking a special utility I can download? :)

I wish!

<<  Attached please find the requested screen shot. >>

I see what you mean... looking into it now, and scratching my head along with you at the moment.  It doesn't seem to be controlled by the properties I would normally use for this.
Hmm... Actually it is working as I would expect I was just looking at it wrong.

Open your subform in Design View, select one of the checkboxes, and change its  Data Sheet Caption property,

Datasheet Caption
<< 2.  The combo box shows filtering options in each column's heading.  >>

I missed this earlier.  

To get rid of the sorting/filtering options drop-down in the column headers,

- Open the form in design view
- Open the form's property sheet
- Under the "Other" tab, set the Shortcut Menu Property to NO
- Save the changes (the change wont be apparent if you immediately switch back to Form View)

Change this to NO
Skip SleeperIT ManagerAuthor Commented:

How do I format those headings and have the formatting for the combobox take affect (e.g. font/size/weight)?  Am I looking at the wrong control?

Also, do you know of a source that defines/explains what the various properties are?

Skip SleeperIT ManagerAuthor Commented:
Thank you so much--I really appreciate it!
Skip SleeperIT ManagerAuthor Commented:
I've requested that this question be closed as follows:

Accepted answer: 0 points for fargus47's comment #a39877776

for the following reason:

Quick, Very thorough and precise!
Glad to help out!

Check the way you are closing the question though, it looks like you are accidentally accepting your own comment as the solution.  :-)
Posting an Objection to stop the pending closure and to get a Mod to help you out with this.
Skip SleeperIT ManagerAuthor Commented:
Very thorough, timely and precise as well extremely gracious when I awarded myself 500 points for accepting the solution!
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.