Want to win a PS4? Go Premium and enter to win our High-Tech Treats giveaway. Enter to Win

x
?
Solved

IIS 6 http

Posted on 2014-02-21
3
Medium Priority
?
187 Views
Last Modified: 2014-03-14
Hi,

I have a win 2008 std sp2 box with iis6.0 on.

I have created a virtual directory under default website i.e test

I have added a local account I want to use to access this directory. If I leave windows anonymous authentication then fine I get in the directory, but I want to set it so it prompts for a password?

http:\\subdomain.domain.com/path  If I turn anonymous auth off it does not prompt me for a password box and says 401 - Unauthorized: Access is denied due to invalid credentials

how do I get it to prompt for a username and password
0
Comment
Question by:monarchit
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
3 Comments
 
LVL 11

Expert Comment

by:Manjunath Sullad
ID: 39877292
have you configured appropriate permissions to the folder ? Seems to be Permission issue,

Also try resetting Internet explorer settings,
0
 
LVL 29

Accepted Solution

by:
becraig earned 1500 total points
ID: 39877594
You need to configure windows authentication on this folder.

To configure authentication for a virtual directory
    In IIS Manager, select the virtual directory that you want to configure.
    In Features View, double-click Authentication.
    Select the authentication type to configure, and in the Actions pane make sure Enable is selected in order to enable the authentication type.
    If the authentication type is already enabled, the Actions pane enables you to disable or edit authentication configuration.
    In the Actions pane, click Edit or Advanced Settings to configure additional properties for the authentication type you selected.

    More info:
http://msdn.microsoft.com/en-us/library/bb763173.aspx
0
 
LVL 7

Expert Comment

by:Sivaraj E
ID: 39882080
Are you sure that you are running IIS version 6 on your 2008 Server ?

I believe it must be IIS 7, have a look at the link and it will help you.

http://www.youtube.com/watch?v=DDBFEi2Yk0c

Regards, Shiva
0

Featured Post

Tech or Treat!

Submit an article about your scariest tech experience—and the solution—and you’ll be automatically entered to win one of 4 fantastic tech gadgets.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Running classic asp applications under Windows Server 2008 R2 (x64) and IIS 7 is not as easy as one may think. It took me a while to figure it out while getting error 8002801d a few times. After you install the OS you will need to install the fol…
If you don't have the right permissions set for your WordPress location in IIS, you won't be able to perform automatic updates. Here's how to fix the problem.
In this video, Percona Director of Solution Engineering Jon Tobin discusses the function and features of Percona Server for MongoDB. How Percona can help Percona can help you determine if Percona Server for MongoDB is the right solution for …
In this video, Percona Solution Engineer Rick Golba discuss how (and why) you implement high availability in a database environment. To discuss how Percona Consulting can help with your design and architecture needs for your database and infrastr…

609 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question