Solved

IIS - Default Website and Exchange Server email problem

Posted on 2014-02-21
4
311 Views
Last Modified: 2014-02-22
Microsoft 2011 server and IIS 7.
Implementing a local asp.net website on server in wwwroot.
Website has a web.config file.
The presence of the config file in the wwwroot folder is causing remote email to stop working. for example... "https://remote.xxxxx.com/OWA"
Once the file is removed, the remote email works fine.
Have tried several things but nothing has worked.
Need help! Thanks!
0
Comment
Question by:Cubbybulin
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
4 Comments
 
LVL 8

Assisted Solution

by:Jeff Perry
Jeff Perry earned 167 total points
ID: 39877826
Is this the only IIS/web server you have?  

Do you get an error for the remote email stoppage? Is it a port in use error?

If so just change the TCP port assignment and the SSL port assignment on the properties page of the new website.  You may have to edit the web.config file directly and look for what ports it is setting the new site up on.

If it is not a port in use error then we will need more information to help you further.
0
 
LVL 16

Accepted Solution

by:
R. Andrew Koffron earned 167 total points
ID: 39877856
here's an article on how to install OWA outside of the default website, so the config might not cascade to the exchange app.

Not positive it'd work, but it's the second(or 20th) thing I'd try.  First thing I'd try is leaving the default web the heck alone, and installing the new application in a different site(different server even better, I also wouldn't try installing the Hyper-V service on my exchange server to run a 2008web system, but it might be an option, just opens a slew of complexity issues if tracking down future issues or network changes).  either the company selling the new application, or the In-house developers can make their product work in a different spot, I just personally wouldn't mess with my exchange server.

http://forums.msexchange.org/m_170142600/tm.htm
0
 
LVL 11

Assisted Solution

by:hecgomrec
hecgomrec earned 166 total points
ID: 39879774
Unless you are closing the ports in that file or using them for other services your OWA site should work.

Now, when you say its stops, you get to the IIS and the website has the stop status or just users from outside are not able to load the website?

If you are changing settings or folder permissions on the file then you should definitely should move your OWA site out of there if permissions can't be managed.

Finally, you can't have both sites using the same ports (80, 443, etc)
0
 

Author Closing Comment

by:Cubbybulin
ID: 39879914
Thanks for all your replies. It turned out to be something simple for me but allot of time spent researching.
I simply put the below statement in the New local website (default) web.config file and it worked great.

<location inheritInChildApplications="false">
...other config parameters within
</location>

I found this in the web.config of the OWA and tried it.

Thanks again for your help and quick responses!
0

Featured Post

Online Training Solution

Drastically shorten your training time with WalkMe's advanced online training solution that Guides your trainees to action. Forget about retraining and skyrocket knowledge retention rates.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Explore the encryption capabilities built into Google Apps and how these features can help you meet privacy policy and regulatory compliance, but are not a full solution. Understand and compare the most popular email encryption services for Google A…
It’s a strangely common occurrence that when you send someone their login details for a system, they can’t get in. This article will help you understand why it happens, and what you can do about it.
The purpose of this video is to demonstrate how to set up a Mailchimp campaign. This will include styling and adding elements to a newsletter/email. This will be demonstrated using a Windows 8 PC. Mailchimp will be used. Log into your Mailchim…
Sending a Secure fax is easy with eFax Corporate (http://www.enterprise.efax.com). First, Just open a new email message.  In the To field, type your recipient's fax number @efaxsend.com. You can even send a secure international fax — just include t…
Suggested Courses

636 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question