• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 3599
  • Last Modified:

Cannot change default program for tif/tiff files.

Hi there,

We installed a program called Imaging 4.0.  It allows us to view .tif and .tiff files in a special viewing way, which is very helpful.  The default program to open .tif and .tiff files should be this program, but it appears there is something wrong with the name of the current default program.  When we select Open with -> Choose Default Program, we specify the program "imaging.exe", which is the right program.  Even though we select it, all .tif and .tiff files open in Microsoft Photo Viewer, which is wrong.  If we switched it to say, Paint, it will open in Paint, but then we choose Imaging again and it goes back to Windows Photo Viewer.  My guess is that somehow the name of the Microsoft Photo Viewer in the list of application to choose from when selecting what application to open it by default, is the same as the Imaging program.  This would make Windows 7 think it has to open it in Photo Viewer instead of looking at the .exe file location.

Any suggestions?

Thanks,
- Christian
0
Christian Palacios
Asked:
Christian Palacios
  • 5
  • 3
  • 2
  • +1
1 Solution
 
Joe Winograd, EE MVE 2015&2016DeveloperCommented:
Hi Christian,
Instead of typing in the file name <imaging.exe>, click the Browse button and navigate to the <imaging.exe> file where it was installed by Imaging 4.0 — that is, browse to its actual location and then select it. Btw, your problem is not because Windows Photo Viewer is a file called <imaging.exe>. In fact, Windows Photo Viewer has no EXE at all — it is just a DLL (PhotoViewer.dll).

One other idea. Instead of changing the default via [Open with>Choose default program], try to do it via Control Panel>Default Programs. In that applet, you'll see "Set your default programs" and "Associate a file type or protocol with a program". Perhaps one of them will work. Regards, Joe
0
 
jcimarronCommented:
FDSCI--
There are many ways to set the default program to open a file.
One is
Control Panel\Default Programs\"Associate a file type or protocol with a program"\Scroll to .tif (and then separately to .tiff)\highlight\ and set Imaging 4.0 as the Default Program using the Change Program button at top right.

Another is to go in the Registry to
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts\.tif \UserChoice.  (And similar for .tiff).  In the ProgID line you would enter Imaging4.0 in the Data column.
0
 
Christian PalaciosAuthor Commented:
Thank you for your answers.  

Jcimarron: I looked at my computer first to check out the registry, but my .tif entry did not have a subfolder \UserChoice.  Do I need to create it?
0
VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

 
jcimarronCommented:
FDSCI--
That would be one way.  Create it as a New Key in the left panel and then create a key in the right panel called ProgID with a Data value of Imaging4.0.
The Control Panel procedure might be simpler and might create the keys for you.
0
 
MereteCommented:
It sounds as if this program is not really being identified within windows as being installed.
With my Tiff when I look in the regestry the default program opens in my Nero photo editor as per my choice, but when I look in the Start All Programs Deafult programs >associate a file type it shows windows photo viewer.
Maybe you need to look in both and change them?
Remove Tiff from  Windows Photo Viewer
associate a file typeMake a new string
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts\tif
reg key for tif
Maybe it cant using these methods since  Alliance Imager is a document management system which uses document imaging and scanning software to transform paper documents and faxes into electronic documents that can be viewed, edited and distributed within a PC environment.
When you installed it is there any settings for preference and to associate tiff with it.
Maybe this tool requires that you open it first then add your images
0
 
Christian PalaciosAuthor Commented:
Hi everyone;

I have tried to change the default program in different ways, but nothing has worked.

Here is what I have tried:

I tried to change the UserChoice -> ProgID for both .tif and .tiff but it didn't work.
Changing it using the Default Program tool in Control Panel didn't work.
I tried removing the PhotoViewer.dll from the OpenWithList in Regedit for both .tif and .tiff
Imaging doesn't allow you to set the default program for .tif and .tiff

I have attached the OpenWithList registry key for both .tif and .tiff to see if that will help someone figure out this problem.  If you need to see anything from this computer, please let me know.

Thanks,
- Christian
tif-openwithlist.JPG
tiff-openwithlist.JPG
0
 
jcimarronCommented:
FDSCI--
Perhaps a little more work, but if you open  Imaging 4.0 can't you then direct it to open the .tif and .tiff files, or maybe you can drag the .tif and .tiff files into  Imaging 4.0.
0
 
Christian PalaciosAuthor Commented:
Hi jcimarron,

Thanks, but this used to work with Imaging 2.8 so we're confused why this isn't working with 4.0 and why Windows is having a problem recognizing that Imaging is a different program with a different path.

- Christian
0
 
Christian PalaciosAuthor Commented:
Thank you all for your suggestions.  I was able to get some help from the company who manages this software now.  Their fix was to rename the .exe from imaging.exe to imaging1.exe.  Somehow that name was conflicting with something regarding Windows Photo Viewer.  Once I did that, I was able to go into Default Programs and change the default program for TIF and TIFF images by selecting this new file.
0
 
Joe Winograd, EE MVE 2015&2016DeveloperCommented:
Hi FDSCI,
Thanks for posting what worked for you — very helpful! Two comments:

(1) It may be that renaming the file from <imaging.exe> to <imaging1.exe> fixed the problem, but I don't think it's because the name conflicts with something regarding Windows Photo Viewer. As I stated in an earlier post, Windows Photo Viewer has no EXE at all — it is just a DLL (PhotoViewer.dll). In fact, I just searched my entire hard drive and I do not have an <imaging.exe> file anywhere, but I can run Windows Photo Viewer just fine.

(2) You may want to consider giving points to the folks who tried to help you. Of course, you don't have to...it's entirely up to you. In my case, even when I accept my own post as the answer, I always give points to the experts who tried to help...but that's just me...do whatever you think is the right thing to do. Either way, I was happy to try to help you.

Regards, Joe
0
 
Christian PalaciosAuthor Commented:
Solution obtained from the software vendor.
0

Featured Post

Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

  • 5
  • 3
  • 2
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now