• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 434
  • Last Modified:

Avoiding App Store signin when updating purchased apps.

With both my iPhone 4s and 5s I have the latest IOS upgrade as of 2/22/14.

On the 4s I don't need to enter my App Store password when updating purchased Apps.

But I do on the 5s.

How do I make the 5s update Apps without having to enter the password each time?
But, please don't tell me to "Update All."  I never update all Apps at once, because I need to consider the reviews for the each new version before I decide to update the App.  -- some have problems that I want to avoidl

Thanks
0
WaterStreet
Asked:
WaterStreet
  • 4
  • 3
2 Solutions
 
Dave GouldOnsite SupportCommented:
If you are signed in under the settings/iTunes & App Store, you shouldnt need to re-authenticate each time.
I am on an iPhone 5 and it never asks me to login for updates.
0
 
WaterStreetAuthor Commented:
Did what you said.
Logged off first.
Then signed in without a problem.
Waited for an updated app. to try.
Tried the update.

The solution did not work. I had to sign in again.
Is your experience on an iPhone 5s?
0
 
Dave GouldOnsite SupportCommented:
iPhone 5 (not s)
I'll try to "break" it to understand why you need to authenticate.
0
Free Tool: Subnet Calculator

The subnet calculator helps you design networks by taking an IP address and network mask and returning information such as network, broadcast address, and host range.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

 
WaterStreetAuthor Commented:
Thanks
0
 
Dave GouldOnsite SupportCommented:
I been looking around and found 2 pointers that might help. Unfortunately I dont have any updates pending to test but check these out. As soon as someone updates one of my installed apps, I'll test again.

They are just quotes from other forums but morth a try :

In Settings, go into General -> Restrictions -> Enable Restrictions
Under Require Password, set it to 15 minutes instead of Immediately

Check Settings > Safari > Block Cookies. If it is set to "Always", change it to either "From third parties and advertisers" (the default) or "Never".
0
 
Dave GouldOnsite SupportCommented:
I had restrictions enabled and was prompted for my password when I tried to update an app. I hit cancel then went into settings, disabled restrictions and retried the update.
This time I was not asked for my password.
Hope this helps.
0
 
WaterStreetAuthor Commented:
One difference between my problem-free iPhone 4s and the 5s is that password was required after 15 min on the 4s, but was set for Immediately on the 5s.   I'm keeping them that way for better security, because the 5s travels with me when I'm out, while the 4s is just wi-fi and is only used at home.

So, for the 5s...

In Settings - iTunes & App Store, I tried turning on Automatic Downloads for Apps and for Updates, which had both been off.

I waited for the next Update and tried it.

It worked without entering a password.

Per your above comments, I changed my 4s from requesting a password after 15 min to immediately.  It the required a password for an App update, which it would not before that change.

Thanks.  Your response should also help others at EE.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Get your problem seen by more experts

Be seen. Boost your question’s priority for more expert views and faster solutions

  • 4
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now