Go Premium for a chance to win a PS4. Enter to Win

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 461
  • Last Modified:

reattach personal.xlsb

I'm using Excel 2010. I've created and used a set of macros that are saved in personal.xlsb. The file is located in the correct location:
   C:\Users\<<<username>>>\AppData\Roaming\Microsoft\Excel\XLSTART\
and worked for a while. Now when I start Excel, the personal workbook doesn't open and the macros are not available.

If I doubleclick the personal.xlsb file, the macros are still there...

How do i get Excel to recognize and open the personal.xlsb file again?
0
Scott Helmers
Asked:
Scott Helmers
  • 3
  • 3
2 Solutions
 
Patrick MatthewsCommented:
Check your Trusted Locations in Trust Center.  Is XLSTART listed as the User StartUp folder?
0
 
Scott HelmersVisio Consultant, Trainer, Author, and DeveloperAuthor Commented:
Yes it istrusted locations
0
 
Patrick MatthewsCommented:
Strange, I've never seen this happen.

I would try this:
Back up the old Personal.xlsb to a safe place
Export all modules, userforms, and class modules from the Personal.xlsb
Delete it
Use "record macro" to record a silly little macro stored in the Personal file, thus recreating it
Import the VBA objects back in
0
Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

 
Scott HelmersVisio Consultant, Trainer, Author, and DeveloperAuthor Commented:
Thanks for the suggestion, Patrick. I created a new personal.xlsb, imported the single code module, and saved the .xlsb.

When I launch Excel the personal.xlsb does not open: it's not visible in the VBE nor do the macros appear if I click the Macros button on the Developer tab.

The XLSTART still shows correctly as a trusted location.

Some sort of weird permissions issue?? BTW, I'm running Windows 7 on this machine.
0
 
Patrick MatthewsCommented:
I'm stumped.  I'm running Windows 7 myself, and I've not seen this happen before.  I suggest you hit Request Attention and ask the Mods to send some alerts.
0
 
Harry LeeCommented:
scott,

beside the trusted locations, there is still one more place you need to check; Disabled Items.

In Excel, go to File menu, then Options.
Go the Add-Ins.
At the bottom-left, the Manage combo box, select Disabled Items, then press the Go button.
Check the popped up list to see if anything related to the Personal.xlsb is listed.
If there is, select the item and click the Enable button.
0
 
Scott HelmersVisio Consultant, Trainer, Author, and DeveloperAuthor Commented:
Brilliant! That was it. Thanks...
disabled add-ins
0

Featured Post

Important Lessons on Recovering from Petya

In their most recent webinar, Skyport Systems explores ways to isolate and protect critical databases to keep the core of your company safe from harm.

  • 3
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now