Solved

Joomla 2.5 template not rendering as expected

Posted on 2014-02-24
7
340 Views
Last Modified: 2014-03-10
Hello,

I am working on upgrading a Joomla 1.5.26 site to 2.5.14 and I am stumped:

1.      I cannot figure out why the modules in the 2.5 site are not white and rounded (I am using the rhuk_milkyway template, modified for 2.5, white version); the modules are not colored or rounded when I change to other color schemes either. Note: There are a few modules that were built with the white rounded bits as part of the module such as the National Bike Challenge module in the left position on my home page.

2.      I cannot figure out why some formatting is missing from the middle column (for example there is no span.article_separator between articles in the Category/Blog layout though it is present in the 1.5 site).

I have the feeling that the two issues I’ve mentioned above are part of an overarching problem.

My 1.5 site is localmotion.org and the 2.5 site is localmotion.org/jupgrade; I ran the migration using SP Upgrade.

Thank you for any clues or insights you might be able to provide!

Best,

Marion
0
Comment
Question by:synergy_info
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 5
  • 2
7 Comments
 
LVL 8

Expert Comment

by:Mandeep Khalsa
ID: 39882953
Your version 1.5 site is applying the following CSS styles to the white boxes (I compared Major Sponsors on the left) ... .bannergroup_149 and .box_m_149

On version 2.5 .box_m_149 is missing. Maybe a style was applied to the module but is now renamed in the newer version?

Some templates do get the names of the styles updated/changed when a new version is created.
0
 

Author Comment

by:synergy_info
ID: 39883143
Hi KhalsaComputer,

Thanks for your quick response! I am using the rhuk_milkyway template.css which I've modified for 2.5 and these styles are still available there but, as you've noted, the styles are not applied in the 2.5 site. Any pointers as to where I might look for why this is happening?

Marion
0
 

Author Comment

by:synergy_info
ID: 39897300
Update: I am still working on this issue. I have used the CSS Usage extension in Firebug to have a look at the two websites (1.5 and 2.5). When I compare the two scan results template.css looks the same in both cases but the CSS selectors that are not rendering in the 2.5 site show as “Unseen” – I am trying to understand what could be causing these selectors to be unseen.

Any thoughts?

Thanks.
0
Secure Your WordPress Site: 5 Essential Approaches

WordPress is the web's most popular CMS, but its dominance also makes it a target for attackers. Our eBook will show you how to:

Prevent costly exploits of core and plugin vulnerabilities
Repel automated attacks
Lock down your dashboard, secure your code, and protect your users

 
LVL 8

Assisted Solution

by:Mandeep Khalsa
Mandeep Khalsa earned 125 total points
ID: 39898124
See the images below:

Joomla 1.5
Joomla 2.5
In 1.5 version your div's bannerheader_149 and banneritem_149 are wrapped inside another div whereas in the 2.5 version those div's are missing. Check your PHP file for the template layout and compare the two versions. Aside from the obvious 1.5 and 2.5 differences that section in particular should be different causing your issue.
0
 

Author Comment

by:synergy_info
ID: 39898640
Thanks KhalsaComputer! I'll do some comparing there and post back.

Best,

Marion
0
 

Accepted Solution

by:
synergy_info earned 0 total points
ID: 39906433
Hi,

I wanted to post the solution to my problem. The overarching problem turned out to be intense customization in unconventional ways. Module customization was done in templates/system/html/modules.php. There were many other .php files that were customized as well.

I'd like to thank KhalsaComputer for his help.

Thank you,

Marion
0
 

Author Closing Comment

by:synergy_info
ID: 39917004
I guess that I need a lesson in how to close my post correctly! ;)

KahlsaComputer confirmed the problem but the solution was the unconventional customization.

Thank you to all.
0

Featured Post

Transaction Monitoring Vs. Real User Monitoring

Synthetic Transaction Monitoring Vs. Real User Monitoring: When To Use Each Approach? In this article, we will discuss two major monitoring approaches: Synthetic Transaction and Real User Monitoring.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Introduction If you're like most people, you have occasionally made a typographical error when you're entering information into an online form.  And to your consternation, the browser remembers the error, and offers to autocomplete your future entr…
So you have coded your own WordPress plugin and now you want to allow users to upload images to a folder in the plugin folder rather than the default media location? Follow along and this article will show you how to do just that!
The purpose of this video is to demonstrate how to Import and export files in WordPress. This will be demonstrated using a Windows 8 PC. Go to your WordPress login page. This will look like the following: mywebsite.com/wp-login.php : Click on Too…
The purpose of this video is to demonstrate how to set up an RSS Feed on a WordPress Website. This will be demonstrated using a Windows 8 PC. Feedburner will be used for this demonstration. Go to your WordPress login page. This will look like the…

691 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question