Solved

Permission for a Virtual Directory

Posted on 2014-02-24
7
254 Views
Last Modified: 2014-02-27
Hello Experts,

on my dev machine, which I just re-formatted, I'm trying to re-setup my websites and I am having trouble with my virtual directories.

When I setup my virtual directory, and test its connection, I get the error message below. The physical path of the virtual directory is in another website under the same environment, and when I access it from that site as a physical directory it works, but when I access it virtually it says path not found.

This did work before I reformatted, and still works on my live machine, so my code should be fine.

Any help will be greatly appreciated.

The error I get is:
Test Connection
0
Comment
Question by:APD_Toronto
  • 4
  • 3
7 Comments
 
LVL 21

Expert Comment

by:RK
ID: 39885478
Hi,

As per the error, the physical path of the virtual directory is missing the domainname\servername$ permission. Try to add it and see it connects fine?. Also, have a look at this thread http://forums.iis.net/t/1148262.aspx?Cannot+verfy+access+to+path 

I hope this helps
0
 

Author Comment

by:APD_Toronto
ID: 39885986
How do I add the "domainname\servername$ permission"?

FYI I am not on an Active Directory environment.
0
 

Author Comment

by:APD_Toronto
ID: 39886008
As well, my IIS is on the same PC as where I am trying to browse. In other words, there is no multiple PCs as per your link.
0
Ransomware-A Revenue Bonanza for Service Providers

Ransomware – malware that gets on your customers’ computers, encrypts their data, and extorts a hefty ransom for the decryption keys – is a surging new threat.  The purpose of this eBook is to educate the reader about ransomware attacks.

 
LVL 21

Expert Comment

by:RK
ID: 39886021
Hi,

Locate the physical path (I.e - C:\inetpub\wwwroot)>>Right click and properties>>Security>>Edit>>Add>>Click on "Object type">>Tick "Computers" and OK>>Add the DomainName\servername$ and click check names. Select the appropriate permissions and click ok.
0
 

Author Comment

by:APD_Toronto
ID: 39886051
Under security, I do not have Object Type>>Computers.wwwroot properties
0
 
LVL 21

Accepted Solution

by:
RK earned 500 total points
ID: 39886059
Click "Add" you'll get the Object type button. Since you don't have a domain environment, just type servername$. Perform IISRESET and check the issue.
0
 

Author Comment

by:APD_Toronto
ID: 39886158
When I type "servername$" and <actual server name>$, both not found
0

Featured Post

Netscaler Common Configuration How To guides

If you use NetScaler you will want to see these guides. The NetScaler How To Guides show administrators how to get NetScaler up and configured by providing instructions for common scenarios and some not so common ones.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

When it comes to showing a 404 error page to your visitors, you do not want that generic page to show, and you especially do not want your hosting provider’s ad error page to show either. In this article, I will show you how to enable the custom 40…
By default the complete memory dump option is disabled in windows . If we want to enable the complete memory dump for a diagnostic purpose, we have a solution for it. here we are using the registry method to enable this.
This Micro Tutorial will teach you how to change your appearance and customize your Windows 7 interface to your unique preference. This will be demonstrated using Windows 7 operating system.
The viewer will learn how to successfully create a multiboot device using the SARDU utility on Windows 7. Start the SARDU utility: Change the image directory to wherever you store your ISOs, this will prevent you from having 2 copies of an ISO wit…

920 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

14 Experts available now in Live!

Get 1:1 Help Now