Access denied on system32 folder in windows 8.1

I am trying to copy some dll files from server 2012 over to my windows 8.1 system32 folder so that I can register the dll's necessary to bring back the dial in tab in RSAT.  I copied the necessary files but when I try to paste those files in the system32 folder of my windows 8.1 computer I get an access denied error.

1. I already tried taking ownership - failed - still get access denied.
2. I tried doing this with the local administrator account. - failed - still get access denied.
3. I tried xcopy to copy the files over through a elevated command. - failed - still get access denied.

there has to be a way to grant permissions to the system32 folder. I just can't figure it out. Does anyone on here know how to do this. Open to all suggestions. this question is worth 500 points. thanks.

- Mil
LVL 1
mildogzAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

JohnBusiness Consultant (Owner)Commented:
The easiest way for this (for me) is to make a neutral folder on the Windows 8 machine called c:\temp. Give "Everyone" permission to temp (and of course keep nothing important there).

Copy the files locally from System 32 to temp. Then move the files to your server. That should work just fine.
0
mildogzAuthor Commented:
I am trying to copy the files to the windows 8.1 system32 folder... not the server.
0
JohnBusiness Consultant (Owner)Commented:
Copy the files to c:\temp (permitted as above) and the copy locally to system32. I copy files there and into program files this way.
0
Newly released Acronis True Image 2019

In announcing the release of the 15th Anniversary Edition of Acronis True Image 2019, the company revealed that its artificial intelligence-based anti-ransomware technology – stopped more than 200,000 ransomware attacks on 150,000 customers last year.

mildogzAuthor Commented:
I was able to get it to work. I missed a step after taking ownership.

after you take ownership of the file or folder. you need to add your self permission. select a principal. add your account and select full control. I was then able to replace the files. I now have successfully added the dial in tab to RSAT.

Thanks for your suggestion John.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
mildogzAuthor Commented:
Selected my comment as the solution because this is what worked.
0
Alan TolCommented:
Actually the solution from John Hurst worked very well for me. For some reason even with full control rights you cannot copy file directly from network share to system32 folder. Copying to local temp folder and then copying to system32 works just fine.
0
Gabriel NavarroCommented:
John Hurst solution works! Thanks sir!
0
JohnBusiness Consultant (Owner)Commented:
You are very welcome and I was happy to help.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows 8

From novice to tech pro — start learning today.