Avatar of Snowington
Snowington asked on

email problems

Hi,

Just finished setting up exchange and clients on an old server (2003).  Mail seems to be coming through from other emailers, but did a test send to an outside email.  The outside email address received it, I replied to the mail but got a mailer daemon error message.

Things I noticed are that the email address received from the exchange client still had the:
xxx@xxxx.local.

Very odd as other mails are coming in?

Thanks,

Snowy
OutlookExchange

Avatar of undefined
Last Comment
Snowington

8/22/2022 - Mon
ASKER CERTIFIED SOLUTION
Frosty555

Log in or sign up to see answer
Become an EE member today7-DAY FREE TRIAL
Members can start a 7-Day Free trial then enjoy unlimited access to the platform
Sign up - Free for 7 days
or
Learn why we charge membership fees
We get it - no one likes a content blocker. Take one extra minute and find out why we block content.
See how we're fighting big data
Not exactly the question you had in mind?
Sign up for an EE membership and get your own personalized solution. With an EE membership, you can ask unlimited troubleshooting, research, or opinion questions.
ask a question
ASKER
Snowington

Under the user properties, there are various tabs.  Not sure if it's the general tab, account tab, etc.

They all say .local
ASKER
Snowington

Here's a screenshot for you..
servercapture.JPG
ASKER
Snowington

Can you still help me with this please?
I started with Experts Exchange in 2004 and it's been a mainstay of my professional computing life since. It helped me launch a career as a programmer / Oracle data analyst
William Peck
ASKER
Snowington

Hi.  Did as you suggested and changed the email address to the normal one in the general tab on the user properties on the server.  Comes up with the email address (domain address not the .local now, tried to send back, no complaint this time, but still not coming into the inbox on the client machine?
Frosty555

The screenshot you showed me does indeed prove that your problem is that your users do not have an external domain name as the default reply-to address for their mailbox.

You need to set up a recipient policy (or modify your existing one) so that the correct From address is set as the default for all of your users. Otherwise the changes you made will get reverted after a few minutes. Read here:

http://support.microsoft.com/kb/822447

A more detailed guide is here:

http://www.petri.co.il/configure_exchange_2000_2003_to_receive_email_for_other_domains.htm

Of course all of the rest of the networking and configuration needs to be correct, too - you need a static WAN IP address, you need MX records set for your external domain name's public nameservers so that outside servers know where to send the mail to, and you need appropriate rules and port forwarding on your router so that the traffic on port 25 reaches your Exchange server. Your ISP needs to not be blocking port 25, you need an appropriately configured SMTP connector in Exchange 2003 to receive the mail and port 25 on your Exchange server's firewall needs to be open. If communication on port 25 is not possible, you need an email gateway and a smarthost to receive and send the mail on your server's behalf. But I'm assuming all that stuff has already been done.
ASKER
Snowington

Everything seems to be in place ok as the server was originally working fine before upgrades.  I just attached the clients to the server, exchange wise and connected to the existing user.  
Firewall rules, policies and porting has not been messed with.  I did, however, have to repair the mail database, if that has anything to do with it?
Get an unlimited membership to EE for less than $4 a week.
Unlimited question asking, solutions, articles and more.
ASKER
Snowington

Also since changing the email in user properties, nothing coming down, though sending seems perfect
ASKER
Snowington

You still about?
ASKER
Snowington

Hello?
This is the best money I have ever spent. I cannot not tell you how many times these folks have saved my bacon. I learn so much from the contributors.
rwheeler23
arnold

Check the inbound smtp connector log to see whether connections from external sources are being recorded/reported.

Double check the DNS records nslookup -q=MX yourdomain.com
Pry to connect to the exchangers reported.
Attempt an smtp session.

Your issue might be that your configuration does not have a functional incoming receiver.
The messages are not bouncing which suggests that it is not getting to the rebuilt server, or the rebuilt server has a catch-all.

Internally try sending an email to a non existent internal user.  Do you get an NDR no such user?
ASKER
Snowington

Thanks.  I'll check out the settings and run some tests..
ASKER
Snowington

Just to let you know again.  It's inbound mail to the client that I'm having trouble with. POP and IMAP services are both started in services.  Mail can be sent out fine.  So not sure if SMTP is the problem here?

Thanks,

S
Get an unlimited membership to EE for less than $4 a week.
Unlimited question asking, solutions, articles and more.
arnold

SMTP is the outgoing/incoming message exchange protocol.
The default server to server exchange is using port 25

The sending out is an on demand process. I.e.
Run netstat -an | find /I ":25" | find /I "listen"

What mail server/port is your outgoing configuration uses?
Your internal sending out might use a different port. Secure 465 or an of port 587, etc.

Try connecting from outside your LAN to yourmailserver.yourdomain.com 25
ASKER
Snowington

I've requested that this question be deleted for the following reason:

sorted
ASKER
Snowington

thanks
Experts Exchange has (a) saved my job multiple times, (b) saved me hours, days, and even weeks of work, and often (c) makes me look like a superhero! This place is MAGIC!
Walt Forbes