Shadow Protect fails with error -31 A device attached to the system is not functioning

Trying to backup with Shadow Protect to a NAS I receive the above message.

I checked the NAS, everything seems ok. No issues or errors reported there. Backup folder is accessible via Windows Explorer. Can write to folder OK.

Any suggestions on how to troubleshoot this?

Shadow ProtectSP
cgruberAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

noxchoGlobal Support CoordinatorCommented:
Does it work when you backup to normal Windows share?
I have seen this problem with anothet software from different vendor and my hard researches showed to me that samba on NAS dropped the connection from Windows samba client. This is the fault of the NAS device. i was using iOmega 8TB device. Had to replace it with Lenovo EMC.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
noxchoGlobal Support CoordinatorCommented:
And yes, answer to the question - why did it drop the connection? - because the samba on NAS was designed so that it supported only defined number of connections. When the limit was reached then it simply dropped my backup data writing streams.
Restart the NAS and run backuo again. It will most possibly complete successfully.
0
N-WCommented:
Have you reboot the server since receiving this error? The error message is quite common when backup software is trying to use VSS to backup files and the service has stalled.

Trying rebooting the server and then running the backup, if you haven't already.
0
cgruberAuthor Commented:
NAS faulty
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Storage Software

From novice to tech pro — start learning today.