Solved

IIS 7.5: set up SMTP service, but cannot relay mail from external devices

Posted on 2014-02-25
3
2,416 Views
Last Modified: 2014-03-13
I've got a Windows Server 2008 R2 webserver running IIS 7.5. I've configured the SMTP service, and am able to send test messages from the server itself. However, I'm trying to configure a scanner on another network to use the SMTP server to send scanned documents, and that's where I'm running into trouble.

The SMTP service is configured to use the IP address of the server. For the qualified domain, I'm using smtp.[mydomain].com, which resolves to the server's IP. I'm using dedrelay.secureserver.net (GoDaddy dedicated server relay) as a Smart Host.

In the SMTP settings, I've authorized anonymous access in access control and outbound security. I've also authorized the router and firewall IPs of the printer's network in both Connection Control and Relay Restrictions. I don't think permissions are the problem, though, since the log at C:\Windows\System32\LogFiles\SMTPSVC1 doesn't show anything other than the test messages I sent from the server itself, but if there's somewhere else I can check this, please advise.

It could be that I'm putting the wrong settings into the printer. All I'm doing is entering smtp.[mydomain].com — I've pinged that domain from the printer's network, and it resolves to the correct IP. The printer claims to have successfully sent the file, but I don't see anything in the server's SMTP log or the mail queue.

Any suggestions? If there's any other information you need about my SMTP configuration, just ask. Thanks in advance for your help!
0
Comment
Question by:nettech4423
  • 2
3 Comments
 
LVL 34

Accepted Solution

by:
Shreedhar Ette earned 500 total points
ID: 39887622
On SMTP Properties. Under Access tab, click on the Connection button. Select Only the list below and then click Add. Enter Scanner IP addess and then click OK:
0
 

Author Comment

by:nettech4423
ID: 39887636
Shreedhar — thanks for the reply! Sadly, I've tried that; the scanner address appears to the SMTP server as the IP of the network's firewall, but I also added the router IP just to be safe. Again, I'm not seeing any requests to the SMTP service (allowed or denied) in the server logs.
0
 
LVL 34

Expert Comment

by:Shreedhar Ette
ID: 39892499
Add a desktop ip address to SMTP Settings and execute below command from command prompt

telnet servername 25

Report the output here.
0

Featured Post

Are your AD admin tools letting you down?

Managing Active Directory can get complicated.  Often, the native tools for managing AD are just not up to the task.  The largest Active Directory installations in the world have relied on one tool to manage their day-to-day administration tasks: Hyena. Start your trial today.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Resolve DNS query failed errors for Exchange
When you’re making plans to join the modern business race, you should analyze various details that may affect your results. Nowadays, millions of businesses are trying to grow into established and appreciated professional enterprises.
This tutorial will give a an overview on how to deploy remote agents in Backup Exec 2012 to new servers. Click on the Backup Exec button in the upper left corner. From here, are global settings for the application such as connecting to a remote Back…
The basic steps you have just learned will be implemented in this video. The basic steps are shown to configure an Exchange DAG in a live working Exchange Server Environment and manage the same (Exchange Server 2010 Software is used in a Windows Ser…

680 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question