• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1037
  • Last Modified:

exchange mailbox attribute modify

Hi Team,

Can any expert tell how to false the attribute that mention below :

ISpersontopersontextmessaging ....as this value is true..and i need to make it false. So that text sms notification will be disabled for the user..

I checked through Owa But text messaging is not showing there in phonr tab.

And i havr found this attribute through

Get-mailbox -Identity "xxx" | fl *text*

Please revert soon...as this is very urgent..

Thanks
0
Addy Nadia
Asked:
Addy Nadia
  • 10
  • 8
1 Solution
 
SreRajCommented:
Hi,

Please try the following exchange powershell cmdlet

Clear-TextMessagingAccount -Identity User1 -Confirm $True

Following article has more information regarding this cmdlet.

http://technet.microsoft.com/en-us/library/dd351232.aspx
0
 
Addy NadiaExpertAuthor Commented:
Is this command make the attribute to false ??
And also i unable to run clear-textmessagingaccount.

I also checked, i am having the organization management role..

Please suggest
I want to disable the text messaging feature from the mailbox..
0
 
SreRajCommented:
Please let me know the error message you have received after running the command.

You could also try the following option.

Clear-TextMessagingAccount -Identity User1 -Confirm $True -IgnoreDefaultScope
0
Fill in the form and get your FREE NFR key NOW!

Veeam is happy to provide a FREE NFR server license to certified engineers, trainers, and bloggers.  It allows for the non‑production use of Veeam Agent for Microsoft Windows. This license is valid for five workstations and two servers.

 
Addy NadiaExpertAuthor Commented:
I unable to type clear-Textmessaging
 While doing tab command is not coming in exchange power shell
0
 
Addy NadiaExpertAuthor Commented:
and also confirm, what it would clear.

My main issue is thaty, VIP user recieving Text message notification in his Mobile device, and for this we usually check the Text messaging is enabled in OWA or not. So i checked in OWA, settings-->phone and text messaging is not there.

But i can see in outlook Text messaging is enabled, How to Disable it.
In Exchange shell when i type command below :

Get-mailbox -Identity "xxx" | fl *text*

got below results

IsPersonToPersonTextMessagingEnabled  : True
IsMachineToPersonTextMessagingEnabled : True


Is persontopersontextmessaging need to be false, and i checked on other user it is set to false..

So how to set it false
0
 
SreRajCommented:
Are you running Exchange 2007?
0
 
SreRajCommented:
There should be an option to disabled SMS Sync in the phone. For Android devices, its available in the following location.

Settings -> Accounts and sync ->Manage Microsoft Exchange Activesync account -> Account Settings -> Server settings -> Uncheck SMS sync

Which phone VIP user is using?
0
 
Addy NadiaExpertAuthor Commented:
Hi,

From Phone i know, But the user didnt want to do this through phone, Is there any way we can do it from Exchange End, Like Exchange Management shell, Outlook..

And user is using Samsung Set

Thanks
0
 
Addy NadiaExpertAuthor Commented:
we are running with Exchange 2010 sp3 and outlook 2010
0
 
SreRajCommented:
Its a permission issue. To run Clear-TextMessagingAccount, you account should be added to the role MyTextMessaging. This is part of User Roles and Default Role Assignment has this Role. Please check if your account has Default Role Assignment added.

Role
Role Group
Role Assignment
0
 
Addy NadiaExpertAuthor Commented:
When i run the command you suggested, below is the result :

[PS] C:\Users\096744-s\Desktop>Get-ManagementRoleEntry *\clear-textmessagingaccount

Name                           Role                      Parameters
----                           ----                      ----------
Clear-TextMessagingAccount     MyTextMessaging           {Confirm, Debug, DomainController, ErrorAction, ErrorVariable, Identity, IgnoreDefaultSco.

Please confirm what i do so that we can run the Clear-textmessagingaccount command, and also confirm what this command will do. "i m not too sure if this not delete any data from user phone or mailbox "

Thanks,
0
 
SreRajCommented:
Clear-TextMessagingAccount cmdlet is used to remove the text messaging settings from a user's account. Please refer the following article for more information.

http://technet.microsoft.com/en-us/library/dd351232.aspx

You need to check if the account using which you have logged on to the Exchange Server has 'Default Role Assignment Policy' assigned to it. This can be verified from Exchange Management Console -> Recipients. Search for the account and open it properties. In Mailbox Settings tab you will be able to see 'Role Assignment Policy'. Please check if that account has 'Default Role Assignment Policy' assigned to it.
0
 
Addy NadiaExpertAuthor Commented:
Yes i have checked...roles assignment policy is assigned to the account

So what is next need to be done
0
 
SreRajCommented:
We could check to see if Text Messaging option in OWA is disabled thru policy in Segmentation. It can be configured in two places. Please check in both locations for Text Messaging and Enable it.

Organization Configuration -> Client Access -> OWA Mailbox Policies -> Policy Properties -> Segmentation Tab

Policy
Server Configuration -> Client Access -> Outlook Web App -> owa (Default Web Site) Properties -> Segmentation Tab

OWA Folder Properties
0
 
Addy NadiaExpertAuthor Commented:
Sre raj,

I will check this and update you..but still want to mentioned here i already checked in owa virtual directory...text messaging is already set to false..but i havent checked the other option you told in last post..i am not questioning on your effort...
i want to greatly appreciate your effort, as you are giving quick response and for giving new info to me..on this question...

Dont know as this is tricky one issue...the text messaging is already enabled on one user and i am u able to disable it from anywhere....i hope you will definately help me on this to resolve..


Thanks
0
 
SreRajCommented:
Hi,

If you are seeing Text Messaging disabled in any of the locations, then please enable it. This will make the Text Messaging tab appear in user's OWA session. From Text Messaging tab, you could disable Text Message Notifications for the user.

Text Messaging Tab
0
 
Addy NadiaExpertAuthor Commented:
Hello,

As can't enable the text messaging on global environment, As i have also checked as per your previous post, Text messaging is disabled.

But dont know it is enable for that particular user, when we click new text messaging in outlook, it open the new window to type the message and send it.
and when we tried the same thing on any other user including me, then configure text messaging is appears, that means Text messaging is not enabled..

This isssue is with single user only

Thanks
0
 
Addy NadiaExpertAuthor Commented:
NA
0

Featured Post

Veeam Disaster Recovery in Microsoft Azure

Veeam PN for Microsoft Azure is a FREE solution designed to simplify and automate the setup of a DR site in Microsoft Azure using lightweight software-defined networking. It reduces the complexity of VPN deployments and is designed for businesses of ALL sizes.

  • 10
  • 8
Tackle projects and never again get stuck behind a technical roadblock.
Join Now