Getting error an error has occured setting the element data the value is protected by secure boot policy

I have just built a Hper-v Server :

Hardware:

HP Proliant Dl380 G7 8 X 10k 300GB SAS drives, 128GB ram 12 core running at 2.9 ghz

I have created 2 volumes at the hardware level. 1 Mirror using 2 300GB drives where I installed the Hyper-V Controller. I then created a raid 5 volume with the other six drives.

Everything ok at this point I was able to create large volume which will house the Virtual machines on the raid partition and formated the volume with NTFS and created a large E: drive.

I have already created the 2  Virtual machines 1 is a Domain controller and the other a fileserver.

The problem is a support person for this accounting firm that I am doing the job firm needs to migrate data from the old server to the new file server.

he has attempted to do the following command on the fileserver:

bcdedit /set nx AlwaysOff

and is getting the following error:

an error has occured setting the element data the value is protected by secure boot policy and cannot be modified or deleted

All vm's are windows server 2012 r2

I hope someone can shed some light on this as the migration needs to start in 2 days.

Thanks in advance.
cdsausAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Sajid Shaik MSr. System AdminCommented:
Note  Before setting BCDEdit options you might need to disable or suspend BitLocker and Secure Boot on the computer.

http://msdn.microsoft.com/en-us/library/windows/hardware/ff542202%28v=vs.85%29.aspx
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Paul JacksonSoftware EngineerCommented:
You need to go into the BIOS and disable the Secure Boot option
0
cdsausAuthor Commented:
I cannot find any secure boot option in the HP Proliant DL380 G7 BIOS and the Bitlocker option is not installed in the particular VM where they are trying to do the command.
0
Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

Sajid Shaik MSr. System AdminCommented:
0
cdsausAuthor Commented:
Thanks for your reply, I don't think that is going to help me unless I have read it wrong.
We have setup a completely new environment, no migration required for roles or anything
everything is brand new.

The accounting software people want to transfer data from the old server to the new one. They do have access to the old server but they have tried to run the following

bcdedit /set nx AlwaysOff

and is getting the following error:

an error has occured setting the element data the value is protected by secure boot policy and cannot be modified or deleted

This is a virtualised machine running on Hyper-V and are running the command via dos prompt with admin rights.

I have looked at everything recommended but cannot find how to overcome this error.
0
cdsausAuthor Commented:
Have resolved the problem, it was the Secure_Boot option in the Hyper-V config file for the
virtual machine. I set the secure boot option to False. I had to shut down Hyper-V manager Service  in order to update the file. Once that was done, I restarted Hyper-V Manager Service and rebooted the machine. Once logged in I opened up a administrator elevated command prompt and entered 'bcdedit /set nx AlwaysOff ' this came back successful this time. After a reboot the DEP options in the windows tab were greyed out. This is what they were trying to achieve.

Thanks for all the suggestions.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Legacy OS

From novice to tech pro — start learning today.