Exchange 2013 sending email with authentication via 3rd part app internal

Hi All,

We have just migrated over to Exchange 2013 ..

We use a 3rd party application (Printbos) to send emails to local email accounts.

This worked fine when on Exchange 2010 but now after changing the SMTP address over we receive an error of :


501 5.1.7 invalid address


Having a quick look around it looks like our default receive connector has a blank default domain

The link below suggests this need to prefilled in with our Domain Name...

http://support.microsoft.com/kb/944302

Do you agree this could be the problem ?


If so, Is it possible to find out what our default receive connection for mail is?
We have 5 connectors when doing a Get-ReceiveConnector via power shell.
They are :

Client Frontend MSEX02
Client Proxy MSEX02
Default Frontend MSEX02
Default MSEX02
Outbound Proxy Frontend MSEX02


Cheers.
gbadminAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Adam BrownSr Solutions ArchitectCommented:
If it worked on 2010, it should work on 2013. The article you quote is an issue when migrating from Exchange 2003 to 2007. 2003 and 2007 were very different systems.
Make sure you are using the Primary SMTP address of the mailbox you are using to authenticate against the 2013 receive connector to send email. Each mailbox can only use a single email address to send email. All other addresses assigned to the mailbox will fail.

Also, do you have both CAS and MBX on the same server for 2013? If you don't, you'll need to make sure your third party app is pointed to the CAS server if you can only use port 25 with it. Otherwise you can point to the MBX server, but this only responds to SMTP requests on port 2525.
0
gbadminAuthor Commented:
Having a look at the 3rd party application, it does not appear that you can actually input a from address. Is this why it is failing ? Does 2013 require a From address by default ?

The settings of the application are very minimal to say the least, you can only specify SMTP server and port ...

I will try and dig further to see if I can find anything else.

Thanks,
Brad.
0
gbadminAuthor Commented:
We have managed to find an accounts tab within the 3rd party application and once filled out with an email address this then works.

Cheers.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
gbadminAuthor Commented:
Found solution upon further investigation of the application
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Email Servers

From novice to tech pro — start learning today.