red hat package error libXfont

Running into an issue when running yum update. On this redHat 6 server, this package is giving an error.

Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package libXfont.x86_64 0:1.4.5-2.el6 will be updated
--> Processing Dependency: libXfont = 1.4.5-2.el6 for package: libXfont-devel-1.4.5-2.el6.x86_64
---> Package libXfont.x86_64 0:1.4.5-3.el6_5 will be an update
--> Finished Dependency Resolution
Error: Package: libXfont-devel-1.4.5-2.el6.x86_64 (@ol6_latest)
           Requires: libXfont = 1.4.5-2.el6
           Removing: libXfont-1.4.5-2.el6.x86_64 (@anaconda-RedHatEnterpriseLinux-201301301459.x86_64/6.4)
               libXfont = 1.4.5-2.el6
           Updated By: libXfont-1.4.5-3.el6_5.x86_64 (rhel-6-server-rpms)
               libXfont = 1.4.5-3.el6_5
           Available: libXfont-1.4.1-1.el6.x86_64 (rhel-6-server-rpms)
               libXfont = 1.4.1-1.el6
           Available: libXfont-1.4.1-2.el6_1.x86_64 (rhel-6-server-rpms)
               libXfont = 1.4.1-2.el6_1
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

I then run the command with --skip-broken and get this:

Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package libXfont.x86_64 0:1.4.5-2.el6 will be updated
--> Processing Dependency: libXfont = 1.4.5-2.el6 for package: libXfont-devel-1.4.5-2.el6.x86_64
---> Package libXfont.x86_64 0:1.4.5-3.el6_5 will be an update

Packages skipped because of dependency problems:
    libXfont-1.4.5-3.el6_5.x86_64 from rhel-6-server-rpms


Appreciate the help.
jcuWMAsked:
Who is Participating?

Improve company productivity with a Business Account.Sign Up

x
 
Duncan RoeConnect With a Mentor Software DeveloperCommented:
You actually need to fetch the rpm file from  the Red Hat repository. Or at least you have to be cd'd to the directory containing it before issuing the command. (It's not like yum in that regard). Yum may have fetched the file for you: if so then locate ibXfont-devel-1.4.5-2.el6.x86_64.rpm will tell you where it is.
0
 
MazdajaiCommented:
What repos  do you have enabled? Have you try 'skin-broken'?

  yum update --skip-broken

Open in new window

0
 
Seth SimmonsSr. Systems AdministratorCommented:
what happens when you do yum update libXfont-devel ?
does it show it will update libXfont also under "updating for dependencies" ?
0
A proven path to a career in data science

At Springboard, we know how to get you a job in data science. With Springboard’s Data Science Career Track, you’ll master data science  with a curriculum built by industry experts. You’ll work on real projects, and get 1-on-1 mentorship from a data scientist.

 
Duncan RoeSoftware DeveloperCommented:
This looks like an error in the package dependencies:
Error: Package: libXfont-devel-1.4.5-2.el6.x86_64 (@ol6_latest)
           Requires: libXfont = 1.4.5-2.el6

The 64-bit devel package is claiming to require the 32-bit base package.
Re-install libXfont-1.4.5-2.el6.x86_64 , then fetch libXfont-devel-1.4.5-2.el6.x86_64.rpm and manually install it:
rpm -ivh --nodeps libXfont-devel-1.4.5-2.el6.x86_64.rpm
0
 
jcuWMAuthor Commented:
Mazdajai
the results of --skip-broken are in the initial question.

Seth Simmons
It says No Packages marked for Update

Duncan Roe
I ran yum remove libXfont-1.4.5-2.el6.x86_64
and it removed it:
 
I then reinstalled with no errors
yum install libXfont-1.4.5-2.el6.x86_64

Running the rpm command gave me this:
 error: open of libXfont-devel-1.4.5-2.el6.x86_64.rpm failed: No such file or directory
0
 
jcuWMAuthor Commented:
Duncan Roe - thanks for the assistance.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.