Solved

On-site users cannot authenticate to Exchange server after power-shell changes; OWA works fine?

Posted on 2014-02-26
2
1,177 Views
Last Modified: 2014-05-07
We have been having a ton of certificate errors, due to our internal domain being "domain.local", and only having a single Exchange server with a wildcard cert "*.domain.local". To ensure that all Outlook users would connect directly to the external address (which had the proper certificate), I changed all of the internal/external settings in these instructions (http://exchangeserverpro.com/avoiding-exchange-2013-server-names-ssl-certificates/) to https://external.domain.com/_____.

Tested it on a few machines, no problems. The next day (today), getting 50% of users internally reporting that they cannot connect - keeps popping up user/pass window... Try to authenticate (domain\user and applicable password), but only get this error: "The connection to Microsoft Exchange is unavailable.  Outlook must be online or connected to complete this action." So far, no issue configuring externally, and the "Remote Connectivity Analyzer" shows no issues in any category.

OWA works fine, and as I mentioned, about 50% of users work normally after reboot. Stumped - can anyone help?
0
Comment
Question by:ITAdvisors
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
2 Comments
 
LVL 63

Expert Comment

by:Simon Butler (Sembee)
ID: 39889317
Does the external name resolve internally?
If you run an Autodiscover test, do the correct host names come back?

Simon.
0
 
LVL 41

Accepted Solution

by:
Adam Brown earned 500 total points
ID: 39889556
More than likely the autodiscover settings are cached with the old name of autodiscover.domain.local, so computers are getting screwed up. Try running a repair on the Outlook profile for a user who has the issue to see if that fixes the problem. If it doesn't, remove any autodiscover.domain.local entries in DNS, Then create a SRV record in the domain.local DNS zone for the _autodiscover service that points clients to the autodiscover.domain.com address. http://acbrownit.wordpress.com/2012/12/20/internal-dns-and-exchange-autodiscover/ has info near the bottom on configuring a SRV record.
0

Featured Post

Problems using Powershell and Active Directory?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Phishing attempts can come in all forms, shapes and sizes. No matter how familiar you think you are with them, always remember to take extra precaution when opening an email with attachments or links.
A couple of months ago we ran into an issue that necessitated re-creating our Edge Subscriptions. However, when we attempted to execute the command: New-EdgeSubscription -filename C:\NewEdgeSub_01.xml we received an error indicating that the LDAP se…
Sending a Secure fax is easy with eFax Corporate (http://www.enterprise.efax.com). First, just open a new email message. In the To field, type your recipient's fax number @efaxsend.com. You can even send a secure international fax — just include t…
Internet Business Fax to Email Made Easy - With  eFax Corporate (http://www.enterprise.efax.com), you'll receive a dedicated online fax number, which is used the same way as a typical analog fax number. You'll receive secure faxes in your email, f…
Suggested Courses
Course of the Month5 days, 5 hours left to enroll

636 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question