Solved

SCCM2012 / MDT2012: Error while importing Microsoft Deployment Toolkit Task Sequence.

Posted on 2014-02-26
3
1,121 Views
Last Modified: 2014-03-07
Windows Server 2008 R2 Enterprise
Virtual Machine
8GB Ram
SCCM2012: ver 5.00.7804.1000
MDT2012 U1: ver 6.1.2373.0
ADK8: ver 8.59.25584

     Ok---so I am very new to the SCCM and MDT utilities-----just following along with some tutorials. I am trying to create a "MDT Task Sequence" while using the SCCM2012 console. Yes I have opened the console as an administrator (run as), ran the "configure configmgr integration" applet as an administrator (run as).
     I created a share in my deployment share called CMPackages----I defined the sequence to create all new items---not referencing anything previously made----except for the Win7x86 iso in the VM's CDRom. Inside CMPackages share---3 out of 5 folders get created:

1)  BootImagePackage
2)  MDTToolkitPackage
3)  SourceWin7Package
All of which I defined in the MDT Task Sequence

The 2 that don't get created are:
4)  USMTPackage
5)  SettingsPackage
Both of which I also defined in the MDT Task Sequence
And then I get the below error.

I have read much the past 2 days concerning "Error while importing Microsoft Deployment Toolkit Task Sequence"---but nothing quite like mine-----System.ComponentModel.Win32Exception (0x80004005): Incorrect function

     Most have to do with having proper permissions to your "share" and having the machine account and the system account with full permissions, yada, yada, yada-----I have all that----Hell I gave the guy down the street full permissions.....but still the error persists.
     I also uninstalled the anti-virus software and rebooted----just to make sure it wasn't getting in the way-----the error still persists..........
     Could really use some help...........See error below
Thanks,
Joe


Started processing.
Creating boot image.
Copying WIM file.
Mounting WIM file.
WIM file mounted.
Setting Windows PE system root.
Set Windows PE system root.
Set Windows PE scratch space.
Adding standard components.
Adding component: winpe-mdac
Adding extra content from: C:\Users\jbadmin\AppData\Local\Temp\2\tsvenkgc.t0n
Unmounting WIM.
Copying WIM to the package source directory.
Creating boot image package.
Updating boot image to enable lab shell.
Boot image created.
Creating MDT files package.
Microsoft Deployment Toolkit files package created.
Creating OS install package.
Error while importing Microsoft Deployment Toolkit Task Sequence.

System.ComponentModel.Win32Exception (0x80004005): Incorrect function
   at Microsoft.BDD.Core.DirectoryUtility.CopyFile(DEInfo sourceFile, DEInfo destFile, String destFullName)
   at Microsoft.BDD.Core.DirectoryUtility.CopyDirectory(String theSource, String theDest)
   at Microsoft.BDD.Core.DirectoryUtility.CopyDirectory(String theSource, String theDest)
   at Microsoft.BDD.Core.DirectoryUtility.CopyDirectory(String theSource, String theDest)
   at Microsoft.BDD.Core.DirectoryUtility.CopyDirectory(String theSource, String theDest)
   at Microsoft.BDD.Core.DirectoryUtility.BeginCopy()
   at Microsoft.BDD.Wizards.SCCM_ImportTaskSequenceTask.DoWork(SmsPageData smspageData, Dictionary`2 data)
0
Comment
Question by:JBenco
  • 2
3 Comments
 
LVL 16

Accepted Solution

by:
Mike T earned 500 total points
ID: 39897053
Hi,

First i would double-check that all the steps in the task-sequence have packages or settings assigned. SCCM does not create the USMT package itself - you give it the files to use.

Beyond that I would remove the MDT integration and try re-installing it. I've had problems before and re-installing sorted it. You only need to run the integration with admin - the console has permissions set within security/roles.

Maybe attach the XML task-sequence file here for us to have a look. Remove keys or anything sensitive :).

Mike
0
 

Author Comment

by:JBenco
ID: 39900415
Hi Mike-----it seems for what ever reason-----when the task sequence would be creating and it looks to the rom for the iso of win7-----it would only copy some of the files---and then error out.
So I took all of the fles from the win7 iso and put them in a share----then when creating the task sequence---I pointed it to look at the share instead of the rom----and it worked-----I have no idea why though. We are using a VM machine and with the iso mounted in the rom.
As far as uninstalling and reinstalling the MDT integration-----I did that----and still would error out.
Any thoughts on why the task creation would fail looking at the win7 iso????

Thanks,
Joe
0
 
LVL 16

Expert Comment

by:Mike T
ID: 39902095
Hi Joe,

The reason I mentioned double-checking the packages is because the task-sequence needs to use standalone packages for several parts:

sysprep (you can provide custom answer files)
MDT toolkit package (essential for scripting and "gather" steps
the OS

With the OS in particular you can't attach the ISO or even the CDROM during the build. You must provide the source files up front.

If you already have an existing image (in ISO format) that you want to use that's fine.
Take a look at step 3 on this blog: http://www.toolzz.com/?p=879

When you click "Add operating system" the wizard gives you the choice of using a DVD or providing a folder path with ALL the source files copied to it. SCCM then looks for a WIM file in that path and copies just that into it's package library. Then it distributes the OS to any distribution points. You can force this later if you forget.

This process is the same for all software - patches, drivers and apps.

So, it makes sense to get organised and create a software SOURCE library in Explorer before you even touch SCCM. Then when it asks for files you point it there. SCCM 2012 squirrels the files away into it's own obscure path but you can ignore that. Just remember the mantra "distribution points". When you first start out and sat waiting for an app to deploy it's often because you forgot the extra step of distribution points.

Building your OS in a VM is the best method by the way as there are no drivers to worry about.

Glad you worked it out.

Mike
0

Featured Post

Do You Know the 4 Main Threat Actor Types?

Do you know the main threat actor types? Most attackers fall into one of four categories, each with their own favored tactics, techniques, and procedures.

Join & Write a Comment

I wrote an article (http://www.experts-exchange.com/articles/2245/Anti-rootkit-software.html) some time ago with a reference to nLite  (http://www.nliteos.com/)slipstreaming software.  I recently changed that link to point to NTLite (https://www.ntl…
Technology opened people to different means of presenting information, but PowerPoint remains to be above competition. Know why PPT still works today.
The viewer will learn how to create a normally distributed random variable in Excel, use a normal distribution to simulate the return on an investment over a period of years, Create a Monte Carlo simulation using a normal random variable, and calcul…
The viewer will learn how to create two correlated normally distributed random variables in Excel, use a normal distribution to simulate the return on different levels of investment in each of the two funds over a period of ten years, and, create a …

708 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

16 Experts available now in Live!

Get 1:1 Help Now