Solved

Disable Autocorrect in IE11 on Windows 7

Posted on 2014-02-26
18
4,943 Views
Last Modified: 2014-02-28
I've exhausted ALL Google links I could find and before giving up and declaring this actually impossible I figured I would ask here.

Is it possible to disable auto correction while leaving automatic spell check in IE 11 Win7?

I want the red underlines to show me that I typed something not in the dictionary.  What I don't want is IE thinking it is smarter than I am (even though it probably is) and changing what I typed.

It has caused some issues when responding to, say questions here on EE.  I mean to type some function name and IE changes it to something that doesn't exist.
0
Comment
  • 7
  • 4
  • 2
  • +2
18 Comments
 
LVL 19

Expert Comment

by:helpfinder
ID: 39890215
did you also check Tools>Manage Addons>Spelling correction and untick Enable spelling correction
0
 
LVL 3

Expert Comment

by:costanos
ID: 39890223
I dont think there is a way to do this, however if you force the page to use compatibility settings it will revert to ie7 core and by default i believe autocorrect is disabled.
0
 
LVL 77

Author Comment

by:slightwv (䄆 Netminder)
ID: 39890224
>>untick Enable spelling correction

That also disables spell check doesn't it?

Per above:  disable auto correction while leaving automatic spell check
0
Use Case: Protecting a Hybrid Cloud Infrastructure

Microsoft Azure is rapidly becoming the norm in dynamic IT environments. This document describes the challenges that organizations face when protecting data in a hybrid cloud IT environment and presents a use case to demonstrate how Acronis Backup protects all data.

 
LVL 77

Author Comment

by:slightwv (䄆 Netminder)
ID: 39890226
>>however if you force the page to use compatibility settings it

Let me play around with that...
0
 
LVL 19

Assisted Solution

by:helpfinder
helpfinder earned 30 total points
ID: 39890229
then probably only option is to add words into dictionary (a lot of work obviously) or use different browser (I know, probably not satisfied)
0
 
LVL 77

Author Comment

by:slightwv (䄆 Netminder)
ID: 39890246
>>then probably only option is to add words into dictionary (a lot of work obviously)

Not an option since the words I use in EE to answer questions that I mean to misspell may need to be corrected on other pages.

>>or use different browser

Not really an option.  Work computer and all...  limited in what I can control on it.

>>force the page to use compatibility settings

Tried:  Tools > Compatibility View Settings and added experts-exchange.com.  Then it broke experts-exchange.com...

I'm beginning to think it may actually be impossible?


Was sort of hoping there is some obscure registry hack that hasn't made it on the web yet (or at least in the first 15 or so pages of Google results).
0
 
LVL 3

Assisted Solution

by:costanos
costanos earned 220 total points
ID: 39890264
This is a long shot but have you checked in HKLM(HKCU)\Software\Wow6432Node\Microsoft\Internet Explorer\Main\FeatureControl\ ?

That is where features like spell check are store in IE10.  I dont have IE11 or I would check for you, sorry :\
0
 
LVL 15

Assisted Solution

by:ericpete
ericpete earned 30 total points
ID: 39890271
Out of curiosity... is there a reason you MUST use IE? Because you could move over to a real browser like Firefox, which knows it's smarter than you but wants to teach you how to spell along the way...
0
 
LVL 43

Accepted Solution

by:
Rob earned 220 total points
ID: 39890310
Did you turn off autocorrect under internet options?

autocorrect settings
0
 
LVL 77

Author Comment

by:slightwv (䄆 Netminder)
ID: 39890688
>>Because you could move over to a real browser like Firefox

Alas....   I use FF for most things.  I'll start the arduous process of IE deviation.

>>Did you turn off autocorrect under internet options?

Saw that before.  Sort of read over 'Forms'.  I'll have to try that tomorrow to see if it no longer corrects my bad grammar while on EE.
0
 
LVL 15

Expert Comment

by:ericpete
ID: 39890702
Ah, yes. I understand the need for several browsers; the suggestion was based solely on the possibility that you could get away with just one.
0
 
LVL 77

Author Comment

by:slightwv (䄆 Netminder)
ID: 39893183
>>Did you turn off autocorrect under internet options?

Sorry for the delay.  It's been one of those days.

'Forms' is grayed out for me (probably a group policy) but it isn't checked.

Looking like it might actually be impossible after all.

pic
0
 
LVL 43

Expert Comment

by:Rob
ID: 39893321
Yeah certainly looks that way... you've deleted the history ?
0
 
LVL 77

Author Comment

by:slightwv (䄆 Netminder)
ID: 39893450
>> you've deleted the history ?

I'll try it tomorrow but not holding out much hope.  :(
0
 
LVL 43

Expert Comment

by:Rob
ID: 39893465
Neither am i.  I'll have a look at some point on my windows 7 VM and see if i can replicate the issue.  I'm running win 8.1 on my laptop so no point testing that ;)
0
 
LVL 43

Expert Comment

by:Rob
ID: 39894325
i fired up my VM and couldnt' get it to autocorrect my terrible typing however it reminded me of how Word works and the autocorrect where there's checkboxes to ask "Replace text as you type?" and "Automatically use suggestions from the spelling checker".  I dare say, and I'm only guessing, that these are just built in to the IE engine
Really just my 2c, can't confirm any of it.
0
 
LVL 77

Author Closing Comment

by:slightwv (䄆 Netminder)
ID: 39895262
Originally missed the registry FeatureControl suggestion above.  Sorry about that.  I looked through them and nothing jumped out at me to even attempt to tweak.


I'm giving up.  Guess it really is impossible or it hasn't annoyed anyone other than me enough to jump in with both feet and crack it.

Points for valiant attempts.  A few points for the suggestions of:  Just don't use IE.
0

Featured Post

Secure Your Active Directory - April 20, 2017

Active Directory plays a critical role in your company’s IT infrastructure and keeping it secure in today’s hacker-infested world is a must.
Microsoft published 300+ pages of guidance, but who has the time, money, and resources to implement? Register now to find an easier way.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

If you get continual lockouts after changing your Active Directory password, there are several possible reasons.  Two of the most common are using other devices to access your email and stored passwords in the credential manager of windows.
The Windows functions GetTickCount and timeGetTime retrieve the number of milliseconds since the system was started. However, the value is stored in a DWORD, which means that it wraps around to zero every 49.7 days. This article shows how to solve t…
This Micro Tutorial will teach you the basics of configuring your computer to improve its speed. It will also teach you how to disable programs that are running in the background simultaneously. This will be demonstrated using Windows 7 operating…
How to create a custom search shortcut to site-search Experts Exchange using Google in the Firefox browser. This eliminates the need to type out site:experts-exchange.com whenever you want to search the site. Launch your Bookmark Menu: Press 'Ctrl +…

733 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question