Windows DNS server not updating

I am running a Windows 2008 R2 domain with Active Directory integrated DNS. All users have laptops and frequently switch from wired to wireless connections (these are on separate VLAN's). It seems the wireless DNS entry is the predominant one which is held in DNS which makes name resolution fail often. For instance I ran wireless most of yesterday. When I came in today I hard wired (and have been all morning). I performed a cold boot of my machine and obtained a wired DHCP address. When I attempt to ping my machine from another device it is returning the wireless IP address from yesterday and thus timing out. What settings should I look for to keep DNS as up to date as possible?



For the zone in question i have refresh interval of 15 minutes, retry 10 minutes, expiration 1 day, TTL 1 hour.
LVL 1
Snagajob ITAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

MaheshArchitectCommented:
Check my comments in below EE article to check DNS - DHCP integration is setup properly

http://www.experts-exchange.com/Networking/Protocols/DHCP/Q_28375413.html

it might help
0
Snagajob ITAuthor Commented:
Thanks for the link. I had most of that in place but did find the DHCP lease time for the wireless scope was set to 7 days and Name Protection was not enabled. I have set this to match the wired scope for lease of 1 day and Name Protection enabled. I will monitor the issue for a few days and update status as it progresses
0
Daniel McAllisterPresident, IT4SOHO, LLCCommented:
Sounds like you may have stumbled onto your issue -- that is, your AD integration means that your DHCP server is letting your DNS server know each time it assigns a lease. Since when you log off the wireless, you're NOT actually releasing the address, the DNS server is keeping that address -- as you have pointed out, for the term of the DHCP lease, or 7 days.

You say there are separate VLANs for the wired and wireless networks -- if that also means there are separate DHCP servers, then you're especially in luck... most locations with lots of wireless users set a DHCP lease time of 15 minutes (vs. the 1 day you referenced). The issue being, with a 1-day lease, assuming a 24-bit netmask, you can only allow connections from 253 users per day -- regardless of how many at once.

Once your wireless DHCP server drops the address, it should remove it from the DNS server, thus allowing the DNS ADD request from the wired VLAN DHCP server to succeed -- and your name recognition should work (at least most of the time).

I hope this helps explain what's going on...

Dan
IT4SOHO
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

Snagajob ITAuthor Commented:
I didn't look at it like that. I have one DHCP server with several scopes. The main point you mention though is setting the wireless lease time to 15 minutes. I will adjust these settings and see what happens. Great idea though.
0
MaheshArchitectCommented:
you need to setup Dhcp advanced DNS options to Always dynamically update DNS A and PTR records
Also you must set credentials in DHCP server properties, other wise this process will not work

This will ensure that when DHCP lease will expires \ changes by any mean on DHCP server, it will update corresponding DNS records

Also you need to set DNS scavenging in such a way that no-refresh interval must be set to (half) less than refresh interval
This will keep DNS server open for accepting dynamic update more time
Also ensure that secure dynamic update is enabled on DNS zone

Check below article to understand scavenging process correctly and to identify its relation with DHCP
http://241931348f64b1d1.wordpress.com/2010/11/08/how-to-configure-dns-scavenging-stale-record/

To setup scavenging
http://skibbz.com/how-to-setup-aging-and-scavenging-in-dns-server/

Mahesh
0
Snagajob ITAuthor Commented:
I had the dynamic update and DHCP credentials already in place. I modified the DNS scavenging to

No-refresh = 1 hour
Refresh interval = 2 hours

I will keep you posted on the results as I am still experiencing the issue but just made this change.
0
MaheshArchitectCommented:
You have kept very tight refresh and no refresh interval

Ensure that your domain DNS zone srv records are updating as appropriate
Other wise scavenging process will eventually delete all those srv records as well under _msdcs.domain.com zone and domain.com zone (_TCP, _UDP, _MSDCS folders etc.)

I'd keep refresh interval 8 HRS and No refresh interval 4 HRS as a precautionary measure so that you will get sufficient time to update all relevant SRV records on domain controller

Remember, scavenging need to be enabled on only one DNS server and changes will get replicated to all other DNS servers (which are also domain controllers)

Mahesh
0
Snagajob ITAuthor Commented:
I have made the suggestion to set the refresh intervals to the times above. I noticed this morning that I now have 2 entries in DNS for most of the machines that switch between wireless and wired connections.
0
MaheshArchitectCommented:
What is the DHCP lease period you have kept for wired and wireless networks ?
0
Snagajob ITAuthor Commented:
Each is set to 1 hour.
0
MaheshArchitectCommented:
OK

Every half hour the lease will try to renew by machines itself
Because generally client will try renewal after half lease time elapsed
Now Even if you keep No refresh (1 HR) + refresh (2 HRS) = 3 HRS, scavenging will run every 3 HRS and it will delete records older than 3 HRS
Most of the records are updated every half an hour, hence scavenging will not delete most of the records
Is there any specific reason for keeping such a short duration, if you could please explain...
The reason I suggesting you to not keep such a small scavenging period is all SRV records may get deleted if they do not updated within 3 HRS

What is the frequency of DHCP client in out ?
Are you running out of IP addresses ?

In order to avoid multiple records try below.
Please set your DHCP advanced DNS options as below so that your DNS records will get updated
DHCP advanced DNS OptionsAlso add DHCP server to DNSUpdateProxy Group on Domain Controller (DNS Server)
You already have set credentials in DHCP console

Mahesh
0
Snagajob ITAuthor Commented:
I inherited the setup and am in the process of trying to clean up some of the previous admins configurations. The devices are moving constantly as team members go from desk to conference and desk again. Some more frequently than others. I have the DHCP advanced options in place. It was one of the first modifications I made. Earlier today I reverted the scavenging times to no-refresh 4 hours, refresh 8 hours. The DHCP lease times have been reduced to 1 hour for each VLAN. The changes seem to be making a difference in the DNS clean up. I am not running out of DHCP addresses so that is not a concern. The DHCP server is installed on a domain controller/DNS server. I appreciate your assistance and based on your suggestions it is getting better. Let me know if you need any further information
0
MaheshArchitectCommented:
Ok
Great. Appreciate thoroughness of your explanation

I hope you have added DHCP server computer account to DNSUpdateProxy group on DC

If DHCP is located on a Windows 2008 R2 or Windows 2012 DC, you can and must secure the DNSUpdateProxy group by running the following:

dnscmd /config /OpenAclOnProxyUpdates 0

Check EE article for more information
http://www.experts-exchange.com/OS/Microsoft_Operating_Systems/Server/Windows_Server_2008/Q_28302450.html

Mahesh
0
Snagajob ITAuthor Commented:
I am splitting the points between several of the posts since it was a combination of each one that helped me get to a stable working solution. Thanks to all who added their comments.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
DNS

From novice to tech pro — start learning today.