Outlook prompting creds from 1 user, username resolves incorrectly\inconsistently

Got a weird one for you fine folks.  I have a single user who has recently started getting prompted for credentials when launching Outlook.  He is on Outlook 2013 but I can reproduce the problem on a different workstation with Outlook 2007.  The correct login format is domain\username, but when Outlook launches it's trying to use fullemailaddress@domain.com to authenticate.  Once he's supplied the correct credentials Outlook is happy for the remainder of the session until he reboots.  

I first cleared his credential store and created a new profile from the Mail snap-in.  I noticed that when entering his username and selecting 'check name', it resolves to fullemailaddress@domain.com.  This does not happen for any other user.  Where it gets weird is if I enter gibberish into the username field, it obviously fails....but when I enter his username again in the prompt which comes up following the 'name cannot be matched to a name in the address list' notice and then 'check name' it correctly resolves to his underlined domain username.  Afterward, using that profile, he's good until the following restart when Outlook again assumes the fullemailaddress@domain.com for authentication.

I've checked out the attribute editor and compared him against another staff member and haven't seen any obvious discrepancies.  Autodiscover tests are all successful and no other user has this problem.  This feels like a value got flipped and I'll have to use ADSIedit to correct it, but I don't know what to look for.  Suggestions?  Thanks!

Outlook 2013 (reproduced problem on Outlook 2007), Exchange 2007, Server 2008 (not R2) domain.
GS-HelpAsked:
Who is Participating?
 
Simon Butler (Sembee)Connect With a Mentor ConsultantCommented:
Single user issues are rarely worth doing much with other than creating a new account.
The fact that Outlook pops up with the email address for authentication would suggest that Autodiscover is failing. As it is just one user and follows the user to another machine points at the account.

You could try moving the user to another database, or if you have multiple servers then another server would be even better. That could have the affect of cleaning up/resetting the account attributes.

However if that doesn't work, new account, forward the old one to the new one.

Simon.
0
 
GS-HelpAuthor Commented:
Thanks for the followup.  I didn't mention that it's the owner (of course) and redoing everything would be a significant timesink.  Single server, single database. Autodiscover looks just fine and tests successfully after he authenticates and as noted, no other users, old or newly created, have any problems whatsoever.  I'd rather fix the glitch.
0
 
Simon Butler (Sembee)ConsultantCommented:
Doesn't really matter who it is, the fix is the same, because you could spend hours looking for a problem. It usually is a director/VP of some description with the problem, but my answer is always the same. I gave up thinking about the person's role in the business a long time ago and it allows me to resolve issues a lot quicker.

On Exchange 2007 and higher you can have multiple databases, so if you don't have another one, create it and move the user about.

Simon.
0
Simplify Active Directory Administration

Administration of Active Directory does not have to be hard.  Too often what should be a simple task is made more difficult than it needs to be.The solution?  Hyena from SystemTools Software.  With ease-of-use as well as powerful importing and bulk updating capabilities.

 
GS-HelpAuthor Commented:
Not really a fix so much as a workaround, I don't want a single user hanging out in their own database just because.  I'll try creating a new database, moving the mailbox to that database, then back and report results.  I dislike bandaids.
0
 
hecgomrecConnect With a Mentor Commented:
Could you please try to make sure this machine is able to ping the desire server using DNS and IP.

Try checking if the DNS are set properly at client level (PC) and make sure you flush and re-register dns.

Also, check that in the accounts settings, more settings, security tab, the option "Always prompt for logon credentials" is not selected.
0
 
Simon Butler (Sembee)ConsultantCommented:
That was pretty much what I was expecting.
Although it is best practise to have multiple databases, as it makes restores from backups much quicker. If a client has more than 30 users they get additional databases on my designs.

Simon.
0
 
GS-HelpAuthor Commented:
They have fewer than 30 users fwiw.  Mailbox move didn't change a thing and the client has declined to have any more time spent on the issue and will just live with it.  Thanks for trying.

@hecgomrec:

The DNS settings are all fine, server and workstations are reachable from each other.  The key point here is that I can set up his account on other machines and get the same results, but if I do other users in the same location they have no problem.  It's definitely something specific to his account.  The prompting for credentials setting is not set but would also not be relevant as the problem is that Outlook insists on using the wrong credentials.  Some points all around for effort, thanks.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.