Solved

Exchange 2010 - 451 4.4.0 DNS query failed

Posted on 2014-02-27
8
2,772 Views
Last Modified: 2014-03-22
Hi Guys,

We just started using mimecast for spam filtering, inbound emails works fine but problem is with the outbound emails.

Basically email should be routed through the mimecast servers but when use the mimecast's server FQDN on the send connector the email gets stuck in the queue with the 451 4.4.0 DNS query failed error ( see attached ).

I thought it was DNS issue with the exchange server and for that reason I ran a nslookup but it resolved the names properly, then I tried with telnet and I was able to connect and even to sent emails through the eu-smtp-outbound-1.mimecast.com server.

This is not a firewall issue because I am able to run telnet tests.

I have been working on this for the past 2 days but still unable to figure it out :(
Queue.jpg
0
Comment
Question by:R2_D2
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
8 Comments
 
LVL 26

Expert Comment

by:DrDave242
ID: 39892410
Did you follow the procedure shown here for setting up the SMTP connector?
0
 
LVL 63

Expert Comment

by:Simon Butler (Sembee)
ID: 39892425
Check whether you have external DNS servers listed on the Receive Connector. That can sometimes cause this problem.

Also be aware of this issue with DNS:
http://support.microsoft.com/kb/2508835

That can be caused by some firewalls.

Simon.
0
 

Author Comment

by:R2_D2
ID: 39894382
DrDave242, I did follow the instrucitons from the link but didnt help.

Simon, my exchange server is win2012 and the patch was incompatible.
Also my default received connector had some IP addresses on the " receive mail from remote servers that have these ip addresses " and i just removed them and left the default settings " 0.0.0.0-255.255.255.255" and "::ffff.ffff.ffff.ffff "but unfortunately it did't fix it :(

this issue is very weird.
0
[Live Webinar] The Cloud Skills Gap

As Cloud technologies come of age, business leaders grapple with the impact it has on their team's skills and the gap associated with the use of a cloud platform.

Join experts from 451 Research and Concerto Cloud Services on July 27th where we will examine fact and fiction.

 
LVL 27

Accepted Solution

by:
skullnobrains earned 500 total points
ID: 39896272
in the properties of the smarthostdeliveryconnector, Network tab,

try to check "Use the External DNS Lookup settings ont the transport server"

if already checked, try to specify dns servers explicitely

---

as a quick workaround for the time being, adding a line in the hosts table or using the ip addresses associated with the mimecast server in the connector should work
0
 

Author Comment

by:R2_D2
ID: 39897576
tried with the "Use the External DNS Lookup settings ont the transport server" but didn't work neither.

How can i  specify dns servers explicitely ??

Finaly, I didn't edit the host file because the eu-smtp-outbound-1.mimecast.com resolves to a large range of ip addresses.
0
 
LVL 27

Expert Comment

by:skullnobrains
ID: 39898294
through the properties of the "external dns servers"

you can associate as many ip addresses you want with a single name in a host file by adding multiple lines. this is only a poor man's workaround

can you confirm that running nslookup on the exchange server gives the proper address ?
0
 

Author Comment

by:R2_D2
ID: 39931175
Sorry for the late reply.

The Setting "Use the External DNS Lookup settings on the transport server" and restarting the exchange server fixed the problem.

Thank you for your help.
0
 
LVL 27

Expert Comment

by:skullnobrains
ID: 39947122
good to know this required a restart. thanks for sharing

best regards
0

Featured Post

IoT Devices - Fast, Cheap or Secure…Pick Two

The IoT market is growing at a rapid pace and manufacturers are under pressure to quickly provide new products. Can you be sure that your devices do what they're supposed to do, while still being secure?

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This article will help to fix the below errors for MS Exchange Server 2013 I. Certificate error "name on the security certificate is invalid or does not match the name of the site" II. Out of Office not working III. Make Internal URLs and Externa…
Check out this step-by-step guide for using the newly updated Experts Exchange mobile app—released on May 30.
In this video we show how to create an Address List in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Organization >> Ad…
This video shows how to quickly and easily add an email signature for all users on Exchange 2016. The resulting signature is applied on a server level by Exchange Online. The email signature template has been downloaded from: www.mail-signatures…
Suggested Courses

624 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question