Expiring Today—Celebrate National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

Guest accessible share not working on Domain Joined Server 2012 R2

Posted on 2014-02-27
7
Medium Priority
?
3,032 Views
Last Modified: 2014-04-12
Security concerns aside, we require a share that had Read access for non-domain joined uses that connect as guest.

Under Server 2008R2 we simply changed 'allow everyone permission to apply to anonymous users' in security policies, enabled the Guest account, set share to everyone, security to everyone on the folder.

I've tried many things in Server 2012 with no resolve, and found numerous postings of people having this issue but some stating they managed to get it working. Their solution didn't work for us.

Additional settings I've tried on local security policy (gpedit.msc)
Restrict anonymous access to named pipes disable
allow anonymous access to named pipes (added our share name to the list)
allow anonymous access to shares (added out share name to the list)

We've restarted the server after each security change.

I know the remote client is coming in as guest by watching the connection using the ShareWatch utility.  The client is either WindowsXP, Win7, or Win8, all of them can now connect to the server and see shares, but opening the share in question give an error that the client does not have permission.

Server: Server 2012 R2 Standard
Tested clients (all non-domain joined): Win7, Win8.1, Server 2003, Server 2012R2

It's strange as Server 2008R2 works and I can't find anything has been changed to 2012.  I even installed the File Services role that gives the Server manager wizard for creating shares and settings quotas etc. I went through it's steps and did everything for a guest share, same issue.
0
Comment
Question by:MemxIT
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
7 Comments
 
LVL 48

Expert Comment

by:Jackie Man
ID: 39902146
Antivirus or third party firewall installed?
0
 

Author Comment

by:MemxIT
ID: 39902231
Currently no. Firewall is set to off, Antivirus has not been deployed yet.  Server and test client are in same subnet, client can browse to server and see list of shares.  When opening share the error persists.  No messages stand out in Event Viewer on Server or client.
0
 
LVL 2

Expert Comment

by:Rob Jurd (eenookami)
ID: 39947167
MemxIT,

A message has been sent to some additional experts asking them to review your question. We will check back again to see if you are getting the help you need.

Please do not respond to this comment; we will be monitoring your question for activity from the Experts.

Thank you for using Experts Exchange,
eenookami
Community Support Moderator
http://www.experts-exchange.com/R_28863.html
0
Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

 

Author Comment

by:MemxIT
ID: 39947622
I have solved this problem 2 days ago and it was caused by a scenario i failed to mention in my initial post. I will post the solution later today when I have access to a computer.
0
 

Accepted Solution

by:
MemxIT earned 0 total points
ID: 39983338
The solution:
http://www.briantist.com/errors/server-2012-vmware-esxi-permissions-errors-removable-storage-auditing/

I failed to mention this was in an ESXi 5.5 Environment.  The issue is related to devices being reported to the OS as supporting hot plug. Server 2012 has a new 'feature' called Audit Object Access that blocked hot plug/removable devices from being accessed remotely.

Summary:
gpedit.msc
Enabled Guest Account
Allow everyone permissions to apply to anonymous

Share folder with permissions set for everyone

Run the following from an elevated command line:
auditpol /set /subcategory:"Removable Storage" /failure:disable
0
 

Author Closing Comment

by:MemxIT
ID: 39995819
I found the solution on my own.
0

Featured Post

Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Background Information Recently I have fixed file server permission issues for one of my client. The client has 1800 users and one Windows Server 2008 R2 domain joined file server with 12 TB of data, 250+ shared folders and the folder structure i…
A procedure for exporting installed hotfix details of remote computers using powershell
This Micro Tutorial will give you a introduction in two parts how to utilize Windows Live Movie Maker to its maximum capability. This will be demonstrated using Windows Live Movie Maker on Windows 7 operating system.
Windows 8 came with a dramatically different user interface known as Metro. Notably missing from that interface was a Start button and Start Menu. Microsoft responded to negative user feedback of the Metro interface, bringing back the Start button a…

730 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question