Wireless Lan controller through Cisco asa

We have a cisco 5508 wireless lan controller that I'm trying to configure for guest access.  It connects to the guest ssid and obtains an ip address but can't the web page at 1.1.1.1 doesn't open up.    I'll describe my topology a bit.  

Our wlc is configured as a dhcp server and to give a scope of addresses with the cisco asa being the default gateway.  The guest wireless is assigned to vlan 205 on the wlc.  The port on the switch the wlc is connected to is trunked to allow vlan 205 among others.   The cisco asa has an interface configured on the subnet of vlan 205 and is connected to the switch in a port that is configured as switchport access vlan 205.   The interface on the cisco asa vlan 205 is also set with the security level of 5.

When i connect to the wireless guest, i can't ping 1.1.1.1, or the vlan 205 ip address of the wlc.  I'm obtaining a dhcp address from the wlc but that's it.  

Any help would be much appreciated.   thanks so much
techlindenAsked:
Who is Participating?
 
Craig BeckCommented:
Well, when i change the routing to not use the asa but to use our nexus switch at the datacenter, i get the login page and can log in.
This isn't actually a routing issue then, although it may appear as though it is.

What's happening is the client can't resolve anything via DNS when connected via the ASA.  This is crucial in order for the client to be redirected.  If the client can't resolve a hostname the WLC won't see any HTTP traffic to redirect.

If you allow DNS resolution through the ASA this should work fine.
0
 
Craig BeckCommented:
The 1.1.1.1 address isn't actually a routable address - it's just what's used by the WLC to 'grab' your traffic.  If you're successfully associated and authenticated you should be able to see the guest login page but you won't ping its address.

Can you go to the Clients page on the WLC, then click on the MAC address of the client and post a screen-shot of the details?

Can you also post a screenshot of the WLAN's Layer2 and Layer3 pages under the Security tab?
0
 
techlindenAuthor Commented:
Well, when i change the routing to not use the asa but to use our nexus switch at the datacenter, i get the login page and can log in.    I'm wondering if it's something as simple as cable not plugged into the correct port.   Both the nexus and asa are at our datacenter.  I noticed when i shut down the interface on the nexus switch that is labeled as going to the guest wireless in the nexus, the corresponding interface on the cisco asa doesn't shut down.     I'm thinking it should?
0
Choose an Exciting Career in Cybersecurity

Help prevent cyber-threats and provide solutions to safeguard our global digital economy. Earn your MS in Cybersecurity. WGU’s MSCSIA degree program was designed in collaboration with national intelligence organizations and IT industry leaders.

 
techlindenAuthor Commented:
I meant to write going to the guest interface on the asa.  when i shut down the port on the nexus, the corresponding port on the asa stays up.
0
 
techlindenAuthor Commented:
Actually, i think it is the right port because when i disable the port on the asa the corresponding nexus port goes down.   What's weird is that every other interface that goes into the nexus, i can issue the command sh mac address-table interfacexxx or sh mac address-table address (mac address of asa interface), it will show the vlan on the nexus that that interface asa is connected to.  When i issue those commands on my guest interface, i come up with nothing.
0
 
techlindenAuthor Commented:
i still believe it to be a firewall issue.  i can't get connectivity established between the asa and the nexus.  i understand what you're saying about dns connectivity and will make sure they can get to our internal dns what's the firewall issue is resolved. thx
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.