Want to win a PS4? Go Premium and enter to win our High-Tech Treats giveaway. Enter to Win

x
?
Solved

FTP using Windows 7

Posted on 2014-02-28
7
Medium Priority
?
279 Views
Last Modified: 2014-09-12
Hi

Using FTP in Windows 7 behaves as follows:

It correctly displays the FTP folders and files. You can navigate to different folders and browse file and folder lists. When you double click on a file to open it, Windows Explorer will launch an Internet Explorer window to open the file. The file location points to a local temp folder, e.g.:
 
C:\Users\WINDOWS_USERNAME\AppData\Local\Microsoft\Windows\Temporary Internet Files\Content.IE5\B5TPE5SG\SampleText[1].doc

Whereas FTP in Windows XP opens the file I double-click on DIRECTLY (i.e. it does NOT download a copy of it) so I can edit the file directly without having to edit the file then copy it back.  THIS IS EXACTLY WHAT I NEED TO HAPPEN IN WINDOWS 7.


Is there a way I can get the way FTP works in Windows XP to work in  Windows 7.

Thanks,

Thomas
0
Comment
Question by:malco8477
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
7 Comments
 
LVL 35

Accepted Solution

by:
Dan Craciun earned 2000 total points
ID: 39894398
I don't think Windows XP (or any OS, for that matter) allowed you to work directly on remote files.

The way it did work, it downloaded a copy of that file and opened it for you in whatever program was setup as default for that file type (for ex Notepad for txt files).

Now, that default program is always Internet Explorer.

You could try another ftp client. Filezilla is widely used and you can simply right click on a file, choose "View/edit" and it will open with your computer's default program.

HTH,
Dan
0
 
LVL 63

Expert Comment

by:☠ MASQ ☠
ID: 39894442
XP is only behaving as you describe because the default setting has been changed to "open with XXXX program" rather  than "download to YYYYYY location".  XP also downloads the file to the local PC first before opening.

Problem is with IE not Win 7 - the "save and open" option was removed from IE in version 9.

It's about the only browser that doesn't allow one click to do both download and open as a "security feature".

I guess one solution would be to switch to Firefox ...
0
 
LVL 2

Expert Comment

by:pierrejeanes
ID: 39894613
Use ftp client.
0
Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

 
LVL 16

Expert Comment

by:AlexPace
ID: 39895272
Do this to get the old effect using a different web browser:
Install other web browser
Open Control Panel
Click on Default Programs
Click on Associate a file type or protocol with a program
Wait for list to be displayed
Scroll down to the bottom where the protocols are listed (the top shows file extensions)
Double-Click on FTP
Choose alt browser from the popup box (ie: Firefox or Chrome)
Close
0
 
LVL 24

Expert Comment

by:Eirman
ID: 39895536
Try this highly rated and free FTP program.
https://filezilla-project.org/
0
 
LVL 35

Expert Comment

by:Dan Craciun
ID: 39895705
@Eirman: see my answer: ID: 39894398 :)
0
 

Author Comment

by:malco8477
ID: 39896438
Thanks for the comments and the help.

I am not convinced it is to do with the version of Internet Explorer - I still believe it is the version of Windows.

On a computer with Windows XP and Internet Explorer 7 this is what happens.
1) When I open the file from an FTP site the file (eg letter.doc) still has the same name and (as far as I can tell) is still stored in the same location
2) When I make the changes and save the file it updates the original, which is EXACTLY what I want to happen

On a computer with Windows Vista/7 and Internet Explorer 7 this is what happens.
1) When I open the file from an FTP site the file (eg letter.doc) changes its name to letter(1).doc and is stored in the Temporary Internet files folder
2) When I make the changes and save the file it updates the file in the Temporary Internet files folder but my original file has NOT been altered.  This is NOT what I want to happen

I have tried changing the browser to Firefox and Chrome but I still get the same problem.

Thanks for the suggestion of filezilla and, if there is no other way, I guess that is the method I shall have to use.

Thomas
0

Featured Post

Enroll in October's Free Course of the Month

Do you work with and analyze data? Enroll in October's Course of the Month for 7+ hours of SQL training, allowing you to quickly and efficiently store or retrieve data. It's free for Premium Members, Team Accounts, and Qualified Experts!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This article is a collection of issues that people face from time to time and possible solutions to those issues. I hope you enjoy reading it.
This article provides a convenient collection of links to Microsoft provided Security Patches for operating systems that have reached their End of Life support cycle. Included operating systems covered by this article are Windows XP,  Windows Server…
As developers, we are not limited to the functions provided by the VBA language. In addition, we can call the functions that are part of the Windows operating system. These functions are part of the Windows API (Application Programming Interface). U…
Finding and deleting duplicate (picture) files can be a time consuming task. My wife and I, our three kids and their families all share one dilemma: Managing our pictures. Between desktops, laptops, phones, tablets, and cameras; over the last decade…

618 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question