RDP over SonicWall site-to-site VPN

RhemaTek
RhemaTek used Ask the Experts™
on
I have a site-to-site VPN setup for a client using a SonicWall TZ 205 wireless-N in the main building and a TZ 100 wireless-N in the remote building. The main building is using a 192.168.100.x subnet and the remote building is using a 192.168.1.x subnet. The VPN works fine. It shows connected on both ends. While in the remote building I can ping all IP’s on the main buildings subnet and access all the shares on the network. I can RDP into the domain controller in the main building with no issues. When I try and RDP into a workstation using its IP address I cannot connect. I can ping it though. I made sure I could RDP into it from the same subnet and I can RDP into it from my office over the SonicWall VPN client. I am a little lost on why I can’t RDP into this workstations over the site-to-site VPN. Any suggestions would be great. Thank you.
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Director of Solutions Consulting
Commented:
Does the firewall on the workstation allow all connections? Check advanced firewall to see if its limited to the subnet.
bbaoIT Consultant
Commented:
in addtion to aarontomosky's comment, please see below the link for more information how to check the Windows firewall settings. please be aware the method actually applies to all Windows versions above XP though the instructions and screenshots are for XP in the article.

http://technet.microsoft.com/en-us/library/cc875822.aspx

moreover, as you mentioned that all worksations on local subnet and via VPN clients can access the problem computer, please double check if all VPN clients are actually on the local subnet as they obtain IPs from the same DHCP sevrver on the subnet.
Distinguished Expert 2018

Commented:
Sounds like you need to check the firewall rules in the Sonicwalls themselves. Named, look at the firewall polices and allow the flow of RDP traffic between the two LANs across the VPN. It has nothing to do with Windows Firewall

Commented:
Instead of RDP to the workstation, do this test:  telnet to the workstation.
From a command prompt type:  telnet your.ip.address.here 3389

If you get a response, the screen will refresh and you'll end up with a blinking cursor.

Do you get that, or does it flat out not connect?

This test will show if there's a firewall issue or not.

Author

Commented:
Thank you for all the suggestions. It turned out to be the firewall on the workstation being used to remote into. I had to go into the advanced settings in the firewall and check the Remote Desktop and Telnet Server boxes. I also went into the ICMP tab and checked the Allow incoming echo request, Allow incoming timestamp request, mask request and router request. It works fine now. Thanks again.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial