Running Ubuntu 12.04.4 On a Toshiba Satellite - Sound Problem

I am running Ubuntu 12.04.4 LTS on a Toshiba Satellite S55D-A5366. It came with Windows 8.1 and it was a disaster, with intermittent rebooting, driver issues, until I installed Ubuntu. Which seems to work very well, in general.

What I am experiencing  is, that the sound switches off as if I muted it, sometimes, by itself and it is not coming back when it is un-mute with top panel control.

The speaker icon on the top panel occasionally flips to muted by itself, but even if I un-mute it the sound doesn't come back.

Then, even though I have the sound un-muted starting out before reboot, in the login screen it comes up with the sound muted.

Mute / Un-mute seems to work opposite with the login screen and on the desktop many times, but not always.  I am using Mate Desktop 1.6.0, but if I go over to the original Unity desktop it seems to work the same.

What I found on the Internet regarding this, as a solution:

http://www.aetas.dk/no-sound-ubuntu/

If I do this outlined here, it runs identical in the terminal, with the sound card in the example (they must have been messing with the same model computer):

attila@attila-Satellite-S55D-A:~$ amixer
Simple mixer control 'IEC958',0
  Capabilities: pswitch pswitch-joined penum
  Playback channels: Mono
  Mono: Playback [on]
attila@attila-Satellite-S55D-A:~$ sudo amixer -c 0 set IEC958 playback 100% unmute
[sudo] password for attila:
Simple mixer control 'IEC958',0
  Capabilities: pswitch pswitch-joined penum
  Playback channels: Mono
  Mono: Playback [on]
attila@attila-Satellite-S55D-A:~$

BUT! For me, the sound doesn't come back!

I am using HDA ATI HDMI (Alsa Mixer) for sound. See attached screen shot of
all the possibilities in the mixer that come up.

I don't know what to do next, so that sound doesn't work at random. Any ideas?

Thank you for your help.
Sound.png
AttilaBAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Duncan RoeSoftware DeveloperCommented:
Have you tried runn9ing alsamixer from the command line? (it's an ncurses program).
Then you could run alsactl store when you have your speakers unmuted. Perhaps whatever is messing with your sound would respect that.
0
gheistCommented:
Well you need to specify the model of your soundcard (and wipe mixer settings in single mode for each try)
https://help.ubuntu.com/community/HdaIntelSoundHowto
Why? I see you adjust SPDIF while spec of machine says you dont have one...
0
AttilaBAuthor Commented:
Thank you for your help. Well, I have trouble understanding what specifically I need to do, on a more step-by-step level.

Either if you could get a little more specific, or  I need to find some resource on how to do this.

Incidentally, if I run:

attila@attila-Satellite-S55D-A:~$ cat /proc/asound/card0/codec* | grep Codec
Codec: ATI R6xx HDMI

So, this is not an Intel sound card in the laptop.
0
Determine the Perfect Price for Your IT Services

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden with our free interactive tool and use it to determine the right price for your IT services. Download your free eBook now!

gheistCommented:
It still conforms to intels' HDA spec.
What is the codec of card1?

There should be one handling output sockets and other handling HDMI output to TV (one we see)
0
AttilaBAuthor Commented:
Interestingly, now I got more info when running

cat /proc/asound/card0/codec*

and

cat /proc/asound/card1/codec*

on the command line.  See attached text file

'CommandCapture.txt'
CommandCapture.txt
0
gheistCommented:
so card1 is output sockets.... it means that you need to adjust all mixer controllers to use the other (non-idc, non hdmi) card
card0 is if you hook up tv-set (say for mythtv or xbmc)
0
AttilaBAuthor Commented:
I just don't know how I can stabilize the sound. For the last two days it was working fine,
and it is working right now. I just don't know when I will boot the machine and the sound will be broken no matter what until an undetermined future reboot... when it works 'magically'  again...
0
Duncan RoeSoftware DeveloperCommented:
Did you try alsamixer? It seems to me that your problem is that sometimes your system starts up with the "right" sound card as default and sometimes not. If you run alsamixer, configure the card you want, save the config with alsactl then your system should always use it in future.
(alsactl lets you select which card to work on - type h in the window to see a full list of what you can do (dismiss the help window with <ESC>))
0
AttilaBAuthor Commented:
I just ran AlsoMixer, and it provided the info attached in the pdf file.

I don't know how I would save the configuration though for future use, though.

I don' quite know what the problem is, this is what it does:

attila@attila-Satellite-S55D-A:~$ alsactl store 0
alsactl: save_state:1608: Cannot open /var/lib/alsa/asound.state for writing: Permission denied

Isn't it the way I was supposed to save it?

This is what help says:

Usage: alsactl <options> command

Available global options:
  -h,--help        this help
  -d,--debug       debug mode
  -v,--version     print version of this program

Available state options:
  -f,--file #      configuration file (default /var/lib/alsa/asound.state)
  -F,--force       try to restore the matching controls as much as possible
                   (default mode)
  -g,--ignore      ignore 'No soundcards found' error
  -P,--pedantic    do not restore mismatching controls (old default)
  -I,--no-init-fallback
                   don't initialize even if restore fails
  -r,--runstate #  save restore and init state to this file (only errors)
                   default settings is 'no file set'
  -R,--remove      remove runstate file at first, otherwise append errors

Available init options:
  -E,--env #=#         set environment variable for init phase (NAME=VALUE)
  -i,--initfile #  main configuation file for init phase (default /usr/share/alsa/init/00main)


Available commands:
  store   <card #> save current driver setup for one or each soundcards
                   to configuration file
  restore <card #> load current driver setup for one or each soundcards
                   from configuration file
  init        <card #> initialize driver to a default state

I am not sure how to use alsactl.
AlsaMixerRun.pdf
0
AttilaBAuthor Commented:
Now my sound card is all quiet again this morning, for no known reason. All I did was reboot, since yesterday.
I am selecting it with AlsaMixer as 0 and it does not make a difference.
I just cannot turn it on.
0
gheistCommented:
Guess one:
You really need to specify HDA card model
Guess two:
You need to delete gnome mixer saved data (it once loaded what alsamixer had saved, now it reads from its own files, messing up channels, like muting right hdmi channel using saved value of what once was microphone etc (i posted ubuntu sound page, it is all there)
0
AttilaBAuthor Commented:
Where is this page "i posted ubuntu sound page, it is all there"?

Can you give me a URL to what you are describing?

If I Google it an awful lot of stuff comes up, that has nothing to do with it.
0
gheistCommented:
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux

From novice to tech pro — start learning today.