Solved

Running Ubuntu 12.04.4 On a Toshiba Satellite - Sound Problem

Posted on 2014-02-28
13
471 Views
Last Modified: 2014-03-04
I am running Ubuntu 12.04.4 LTS on a Toshiba Satellite S55D-A5366. It came with Windows 8.1 and it was a disaster, with intermittent rebooting, driver issues, until I installed Ubuntu. Which seems to work very well, in general.

What I am experiencing  is, that the sound switches off as if I muted it, sometimes, by itself and it is not coming back when it is un-mute with top panel control.

The speaker icon on the top panel occasionally flips to muted by itself, but even if I un-mute it the sound doesn't come back.

Then, even though I have the sound un-muted starting out before reboot, in the login screen it comes up with the sound muted.

Mute / Un-mute seems to work opposite with the login screen and on the desktop many times, but not always.  I am using Mate Desktop 1.6.0, but if I go over to the original Unity desktop it seems to work the same.

What I found on the Internet regarding this, as a solution:

http://www.aetas.dk/no-sound-ubuntu/

If I do this outlined here, it runs identical in the terminal, with the sound card in the example (they must have been messing with the same model computer):

attila@attila-Satellite-S55D-A:~$ amixer
Simple mixer control 'IEC958',0
  Capabilities: pswitch pswitch-joined penum
  Playback channels: Mono
  Mono: Playback [on]
attila@attila-Satellite-S55D-A:~$ sudo amixer -c 0 set IEC958 playback 100% unmute
[sudo] password for attila:
Simple mixer control 'IEC958',0
  Capabilities: pswitch pswitch-joined penum
  Playback channels: Mono
  Mono: Playback [on]
attila@attila-Satellite-S55D-A:~$

BUT! For me, the sound doesn't come back!

I am using HDA ATI HDMI (Alsa Mixer) for sound. See attached screen shot of
all the possibilities in the mixer that come up.

I don't know what to do next, so that sound doesn't work at random. Any ideas?

Thank you for your help.
Sound.png
0
Comment
Question by:AttilaB
  • 6
  • 5
  • 2
13 Comments
 
LVL 34

Expert Comment

by:Duncan Roe
ID: 39896943
Have you tried runn9ing alsamixer from the command line? (it's an ncurses program).
Then you could run alsactl store when you have your speakers unmuted. Perhaps whatever is messing with your sound would respect that.
0
 
LVL 61

Expert Comment

by:gheist
ID: 39897868
Well you need to specify the model of your soundcard (and wipe mixer settings in single mode for each try)
https://help.ubuntu.com/community/HdaIntelSoundHowto
Why? I see you adjust SPDIF while spec of machine says you dont have one...
0
 

Author Comment

by:AttilaB
ID: 39900436
Thank you for your help. Well, I have trouble understanding what specifically I need to do, on a more step-by-step level.

Either if you could get a little more specific, or  I need to find some resource on how to do this.

Incidentally, if I run:

attila@attila-Satellite-S55D-A:~$ cat /proc/asound/card0/codec* | grep Codec
Codec: ATI R6xx HDMI

So, this is not an Intel sound card in the laptop.
0
 
LVL 61

Expert Comment

by:gheist
ID: 39900657
It still conforms to intels' HDA spec.
What is the codec of card1?

There should be one handling output sockets and other handling HDMI output to TV (one we see)
0
 

Author Comment

by:AttilaB
ID: 39900863
Interestingly, now I got more info when running

cat /proc/asound/card0/codec*

and

cat /proc/asound/card1/codec*

on the command line.  See attached text file

'CommandCapture.txt'
CommandCapture.txt
0
 
LVL 61

Expert Comment

by:gheist
ID: 39901234
so card1 is output sockets.... it means that you need to adjust all mixer controllers to use the other (non-idc, non hdmi) card
card0 is if you hook up tv-set (say for mythtv or xbmc)
0
Comprehensive Backup Solutions for Microsoft

Acronis protects the complete Microsoft technology stack: Windows Server, Windows PC, laptop and Surface data; Microsoft business applications; Microsoft Hyper-V; Azure VMs; Microsoft Windows Server 2016; Microsoft Exchange 2016 and SQL Server 2016.

 

Author Comment

by:AttilaB
ID: 39901351
I just don't know how I can stabilize the sound. For the last two days it was working fine,
and it is working right now. I just don't know when I will boot the machine and the sound will be broken no matter what until an undetermined future reboot... when it works 'magically'  again...
0
 
LVL 34

Expert Comment

by:Duncan Roe
ID: 39901563
Did you try alsamixer? It seems to me that your problem is that sometimes your system starts up with the "right" sound card as default and sometimes not. If you run alsamixer, configure the card you want, save the config with alsactl then your system should always use it in future.
(alsactl lets you select which card to work on - type h in the window to see a full list of what you can do (dismiss the help window with <ESC>))
0
 

Author Comment

by:AttilaB
ID: 39902251
I just ran AlsoMixer, and it provided the info attached in the pdf file.

I don't know how I would save the configuration though for future use, though.

I don' quite know what the problem is, this is what it does:

attila@attila-Satellite-S55D-A:~$ alsactl store 0
alsactl: save_state:1608: Cannot open /var/lib/alsa/asound.state for writing: Permission denied

Isn't it the way I was supposed to save it?

This is what help says:

Usage: alsactl <options> command

Available global options:
  -h,--help        this help
  -d,--debug       debug mode
  -v,--version     print version of this program

Available state options:
  -f,--file #      configuration file (default /var/lib/alsa/asound.state)
  -F,--force       try to restore the matching controls as much as possible
                   (default mode)
  -g,--ignore      ignore 'No soundcards found' error
  -P,--pedantic    do not restore mismatching controls (old default)
  -I,--no-init-fallback
                   don't initialize even if restore fails
  -r,--runstate #  save restore and init state to this file (only errors)
                   default settings is 'no file set'
  -R,--remove      remove runstate file at first, otherwise append errors

Available init options:
  -E,--env #=#         set environment variable for init phase (NAME=VALUE)
  -i,--initfile #  main configuation file for init phase (default /usr/share/alsa/init/00main)


Available commands:
  store   <card #> save current driver setup for one or each soundcards
                   to configuration file
  restore <card #> load current driver setup for one or each soundcards
                   from configuration file
  init        <card #> initialize driver to a default state

I am not sure how to use alsactl.
AlsaMixerRun.pdf
0
 

Author Comment

by:AttilaB
ID: 39903138
Now my sound card is all quiet again this morning, for no known reason. All I did was reboot, since yesterday.
I am selecting it with AlsaMixer as 0 and it does not make a difference.
I just cannot turn it on.
0
 
LVL 61

Expert Comment

by:gheist
ID: 39903162
Guess one:
You really need to specify HDA card model
Guess two:
You need to delete gnome mixer saved data (it once loaded what alsamixer had saved, now it reads from its own files, messing up channels, like muting right hdmi channel using saved value of what once was microphone etc (i posted ubuntu sound page, it is all there)
0
 

Author Comment

by:AttilaB
ID: 39903278
Where is this page "i posted ubuntu sound page, it is all there"?

Can you give me a URL to what you are describing?

If I Google it an awful lot of stuff comes up, that has nothing to do with it.
0
 
LVL 61

Accepted Solution

by:
gheist earned 500 total points
ID: 39903596
0

Featured Post

How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

Join & Write a Comment

Currently, there is not an RPM package available under the RHEL/Fedora/CentOS distributions that gives you a quick and easy way to allow PHP to interface with Oracle. As a result, I have included a set of instructions on how to do this with minimal …
If you have a server on collocation with the super-fast CPU, that doesn't mean that you get it running at full power. Here is a preamble. When doing inventory of Linux servers, that I'm administering, I've found that some of them are running on l…
Learn how to navigate the file tree with the shell. Use pwd to print the current working directory: Use ls to list a directory's contents: Use cd to change to a new directory: Use wildcards instead of typing out long directory names: Use ../ to move…
Connecting to an Amazon Linux EC2 Instance from Windows Using PuTTY.

743 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

13 Experts available now in Live!

Get 1:1 Help Now