Solved

Way to run Android OS within a Virtual machine

Posted on 2014-03-01
18
492 Views
Last Modified: 2015-09-10
Hi,
Is there a way to run Android by a Virtual machine within one PC/Desktop? I've got that Virtualbox is not the option for this.
0
Comment
Question by:HuaMinChen
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 8
  • 6
  • 2
  • +1
18 Comments
 
LVL 36

Expert Comment

by:Kimputer
ID: 39896970
You could basically run android since day one. Just download the android sdk from Google. Make sure you know which android version you wish to run, and add it after the sdk is installed. See the section avd (android virtual device).

developer.android.com/sdk/index.html
0
 
LVL 13

Expert Comment

by:Abhilash
ID: 39897043
You can Run Android Kit Kat on VMware Workstation now.
VMware guys wrote a blog post on how to do this.

The ISO can be found at
http://www.android-x86.org/releases/releasenote-4-4-rc1

Download the ISO and install it and you will have the Android OS up a and running in your VMware workstation/Player.

I doubt if virtual box supports it, but since the ISO/Live CD is available you can give it a try.
0
 
LVL 19

Expert Comment

by:Peter Hutchison
ID: 39897052
I have Android x86 on Virtual box and it does work, so you can run most apps in the ISO ok. Obviously you will not get any of the phone, gps, or touch features that work on a real Android phone.
0
Connect further...control easier

With the ATEN CE624, you can now enjoy a high-quality visual experience powered by HDBaseT technology and the convenience of a single Cat6 cable to transmit uncompressed video with zero latency and multi-streaming for dual-view applications where remote access is required.

 
LVL 11

Author Comment

by:HuaMinChen
ID: 39898241
Many thanks all.

Cmsxpjh,
Within Virtualbox, what OS type/version do you choose, when setting up Android X86?
0
 
LVL 13

Expert Comment

by:Abhilash
ID: 39898351
You can choose Type Linux and Version as Linux 2.6
0
 
LVL 19

Expert Comment

by:Peter Hutchison
ID: 39898360
Well the recommended settings are:
OS: Linux 2.6
Memory: 512 MB
Video: 8MB
CD Image: android-x86-2.2r2-eeepc.iso
Sound: Sound blaster 16
Network: PCNet-Fast III over NAT
0
 
LVL 11

Author Comment

by:HuaMinChen
ID: 39898561
Thanks all.
How about that I want to set up

android-x86-4.4-RC1

within Virtualbox? Which Linux version should I choose there?
0
 
LVL 13

Expert Comment

by:Abhilash
ID: 39898588
It would be the same version.
Last time i remember 4.3 was working fine on Linux 2.6, so 4.4 should work too.
0
 
LVL 11

Author Comment

by:HuaMinChen
ID: 39899379
Sorry, I try to set it up within one Virtualbox. But I get the attached
t669.png
0
 
LVL 13

Expert Comment

by:Abhilash
ID: 39899449
I just tested with mine. Android 4.4 RC1 and Virtualbox 4.0.4.
Works fine. See the below screenshot.
Android on Virtualbox
Give the Specs as in the screenshot and try? Also verify that your ISO is not corrupt.
0
 
LVL 11

Author Comment

by:HuaMinChen
ID: 39899467
Sorry, I still get the same, after I've downloaded the same .iso file again from
http://www.android-x86.org/releases/releasenote-4-4-rc1

I am using Virtualbox 4.3.8.
0
 
LVL 13

Expert Comment

by:Abhilash
ID: 39899706
Android 4.0+ needs Intel VT-x or AMD-V to be enabled on your host OS. Have you enabled it in Bios?

Not related to issue. But since we are spending so much time with the issue its fair to increase the points for your question.
0
 
LVL 11

Author Comment

by:HuaMinChen
ID: 39899759
Many thanks. I've requested Moderator to add mark to this.
0
 
LVL 11

Author Comment

by:HuaMinChen
ID: 39905224
Hi Abhilash,
I want to know where  I can enable

Intel VT or AMD-V

within the BIOS of my HP Probook 4530s?
0
 
LVL 13

Accepted Solution

by:
Abhilash earned 500 total points
ID: 39905357
Make these changes in BIOS

1. System Configuration > Device Configurations > Virtualization Technology > ENABLE
2. System Configuration > Set Security Level > Data Execution Prevention > set to Change
3. System Configuration > Set Security Level > Virtualization Technology > set to Change
0
 
LVL 11

Author Comment

by:HuaMinChen
ID: 39906512
But I am already using Virtualbox within the same machine. I think what you pointed out above, is not the real reason.
0
 
LVL 11

Author Comment

by:HuaMinChen
ID: 39911583
Any help?
0

Featured Post

Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

When rebooting a vCenters 6.0 and try to connect using vSphere Client we get this issue "Invalid URL: The hostname could not parsed." When we get this error we need to do some changes in the vCenter advanced settings to fix the issue.
This article outlines why you need to choose a backup solution that protects your entire environment – including your VMware ESXi and Microsoft Hyper-V virtualization hosts – not just your virtual machines.
In this video tutorial I show you the main steps to install and configure  a VMware ESXi6.0 server. The video has my comments as text on the screen and you can pause anytime when needed. Hope this will be helpful. Verify that your hardware and BIO…
How to Install VMware Tools in Red Hat Enterprise Linux 6.4 (RHEL 6.4) Step-by-Step Tutorial

688 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question