Solved

Help with Understanding Router Configuration

Posted on 2014-03-01
9
774 Views
Last Modified: 2014-03-14
Hello Experts,

I have router configuration with the following setup.

The customer has leased line internet connection


Internet>>ISP Modem>>  Customer Router

I have the router configured as follows. I am just trying a. What typed of configuration or technology playing a role ? b. How must have the ISP setup ?

ISP has provided the public ip address and how its routing to ISP.


hostname R1
!
boot-start-marker
boot-end-marker

mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
no aaa new-model
ip subnet-zero
ip cef
!
!
!
!
ip name-server 4.2.2.2
ip name-server 8.8.8.8
ip ips po max-events 100

!

track 1 interface Tunnel0 line-protocol
!
track 2 interface Tunnel1 line-protocol
!
no crypto isakmp ccm
!

interface Tunnel0
 description Connection to ISP
 ip unnumbered FastEthernet0/0
 ip tcp adjust-mss 1400
 keepalive 10 3
 tunnel source 192.168.70.62
 tunnel destination 192.168.70.61
!
interface Tunnel1
 description Connection to ISP Wireless Backup
 ip unnumbered FastEthernet0/1
 ip tcp adjust-mss 1452
 keepalive 10 3
 tunnel source 192.168.73.58
 tunnel destination 192.168.73.57
!
interface FastEthernet0/0
 description *Connection to ISP Modem
 ip address 192.168.70.62 255.255.255.252
 ip nbar protocol-discovery
 load-interval 30
 speed 100
 full-duplex
!
interface FastEthernet0/1
 description *Connection to ISP Wireless
 ip address 192.168.73.58 255.255.255.252
 ip tcp adjust-mss 1452
 load-interval 30
 duplex auto
 speed auto
!
interface FastEthernet0/0/0
 load-interval 30
 duplex full
 speed 100
!
interface FastEthernet0/0/1
 duplex full
 speed 100
!
interface FastEthernet0/0/2
!
interface FastEthernet0/0/3
!
interface Vlan1
 description $ES_LAN$
 ip address 1.1.1.1 255.255.255.248
 ip tcp adjust-mss 1400
!
interface Dialer0
 no ip address
!
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.70.61 track 1
ip route 0.0.0.0 0.0.0.0 192.168.73.57 100 track 2


end 

Open in new window


Please can someone help in understand this scenario.

Thanks
0
Comment
Question by:cciedreamer
  • 5
  • 4
9 Comments
 
LVL 11

Expert Comment

by:Miftaul
ID: 39897258
a. What typed of configuration or technology playing a role ?
Your router seems to be connected to the ISP router and also a wireless router using two interfaces.
ISP created two separate tunnel with failover to wireless from your end to the ISP.

b. How must have the ISP setup ?

ISP created the tunnel interface possibly to route the public IP they provided to you. They have created a static route for the public IP block towards your router.

c) ISP has provided the public ip address and how its routing to ISP.

The public subnet ISP provided to you is being routed via the tunnel interface. As there are multiple hops between your lan and ISP office, they have created the tunnel interface to make it reachable in a single hop. And at ISPs end, they have created a static route pointing towards you for the public IP subnet.
0
 
LVL 3

Author Comment

by:cciedreamer
ID: 39897335
Thanks

 Is it kind of GRE tunneling ?

Thanks
0
 
LVL 11

Expert Comment

by:Miftaul
ID: 39897415
It is exactly a gre tunnel.
0
PRTG Network Monitor: Intuitive Network Monitoring

Network Monitoring is essential to ensure that computer systems and network devices are running. Use PRTG to monitor LANs, servers, websites, applications and devices, bandwidth, virtual environments, remote systems, IoT, and many more. PRTG is easy to set up & use.

 
LVL 3

Author Comment

by:cciedreamer
ID: 39897504
Actually I need to understand from ISP point of view.

How they are playing with routing ?

let says they have another customer with setup ? How they do that ?

Please bear with me as I am trying to understand from ISP prespective.

Thanks
0
 
LVL 3

Author Comment

by:cciedreamer
ID: 39898280
I have slightly understood.

I can assume the ISP and Customer are connected with point to point ( or may be switch in  the middle). They have GRE setup.


The customer is routing public IP to ISP and vice versa.

But just need to understand " How ISP would be routing those public to internet ?

Thanks
0
 
LVL 11

Accepted Solution

by:
Miftaul earned 500 total points
ID: 39898303
Internet Assigned Numbers Authority is primarily responsible for assignment of addresses. Users are assigned IP addresses by Internet service providers (ISPs). ISPs obtain allocations of IP addresses from a local Internet registry (LIR) or National Internet Registry (NIR), or from their appropriate Regional Internet Registry (RIR). Source

Now ISPs all public block of addresses are declared in the BGP routing table and share on the internet routing table so that any router on the internet knows which router to go to reach that IP subnet.

ISPs usually provides private RFC 1918 to the customers. At the customer router, there is a default route pointed towards the isp. and at the ISP end, a static route is pointed towards customers so the return traffic can find its way to the customers. Default route at the customer end forwards all traffic towards the ISP and static route at ISP forwards all traffic destined to that specific subnet towards the customer.

Now, when a customer requires a public IP block and ISP allocates that to customer, one way to achieve this is to use one of the public IP configured at the ISP router interface and use that as default gateway address for the customer and another IP on that subnet at the customer router interface and do the NAT to translate internal subnets to the internet. Also do necessary port forwarding to use any of the remaining public IP to be mapped to internal servers.

Here the ISP have provided the customer with two private block of IPs (192.168.73.56/30 & 192.168.70.60/30) and pointed two static routes for these to IP subnets so the return traffic can come back to the customer router. The static route at the ISP might look like below
Ip route 192.168.73.56 255.255.255.252 192.168.73.58
Ip route 192.168.70.60 255.255.255.252 192.168.70.62
And the customer has default routes like we see
ip route 0.0.0.0 0.0.0.0 192.168.70.61 track 1
ip route 0.0.0.0 0.0.0.0 192.168.73.57 100 track 2

Now for the public block of IP the ISP gave to the customer say a.b.c.1/30. ISP will have this IP subnet (or the summary address) declared within their BGP. For the customer, they will create an additional static route pointing to them like below.
Ip route a.b.c.1 255.255.255.255 192.168.73.58 10
Ip route a.b.c.1 255.255.255.255 192.168.70.62 20
To the customer router, this public IPs doesnt need any additional configuration for routing, because there is a default route pointing to the ISP anyway.
0
 
LVL 3

Author Comment

by:cciedreamer
ID: 39914465
Sorry for the delay. That was awesome explanation. Just few more questions

Lets I have internet connection from the ISP called as DIA. I have been given fiber connectivity to the customer router with a block 1.1.1.0/30. 1.1.1.1 will be ISP end and 1.1.1.2 will be customer end

And default route on customer router pointing to ISP router. What that type of connection could be ? Is is point to point connection ?

Thanks
0
 
LVL 11

Assisted Solution

by:Miftaul
Miftaul earned 500 total points
ID: 39914555
If you are directly connected to the ISP, its a point to point connectivity. There can be two separate scenarios.

One:  
I have a contract with a single ISP to provide Internet connectivity to 8 sites in different cities. The ISP doesn't work in two of the city. What they did is took a lease internet connectivity from one of the local ISPs. They then created a point to point tunnel from their router interface in my remote office and created a tunnel to their office. and routed all my traffic through the tunnel. When I ping my ISP DNS, its not one hop away, although its multiple hop away via second local ISP link

One:
You are connecting to the ISP with a 1.1.1.0/30 subnet. Now you want a public IP say 2.2.2.2 from the ISP for port forwarding requirement to one of your internal servers. Now, ISP can reconfigure the link between you and ISP to 2.2.2.0/30 subnet so you get the 2.2.2.2 in your WAN interface. Or they can create a static route on their router to forward all traffic destined to 2.2.2.2 to your router leaving the current configuration as they are. This is because your subnet connecting to ISP is different to the public IP you have from ISP.
0
 
LVL 3

Author Comment

by:cciedreamer
ID: 39914616
Hi,
thanks

If possible can you provide me sanitized configuration of the case , Just for knowledge purposes or any example available on internet.

Thanks
0

Featured Post

3 Use Cases for Connected Systems

Our Dev teams are like yours. They’re continually cranking out code for new features/bugs fixes, testing, deploying, testing some more, responding to production monitoring events and more. It’s complex. So, we thought you’d like to see what’s working for us.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
ASA Deny No Connection PSH ACK, Traffic is dropped 10 86
VIRL IP adress 3 71
Understanding split up wire 10 35
Stacked switch question 7 24
In the hope of saving someone else's sanity... About a year ago we bought a Cisco 1921 router with two ADSL/VDSL EHWIC cards to load balance local network traffic over the two broadband lines we have, but we couldn't get the routing to work consi…
If you are thinking of adopting cloud services, or just curious as to what ‘the cloud’ can offer then the leader according to Gartner for Infrastructure as a Service (IaaS) is Amazon Web Services (AWS).  When I started using AWS I was completely new…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

778 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question