Solved

Wordpress Migration

Posted on 2014-03-01
11
304 Views
Last Modified: 2014-03-26
Hello Experts,

I am migrating a wordpress website from one hosting company (Host1) to another (Host2). From Host1, I made a copy of the root directory and dumped the db in a .sql.

I then installed a fresh copy of wordpress on Host2, then used FTP to 'overwrite' the root directory of the clean install with the root directory from Host1. I then imported the database on host2 and edited the wp-config with the new db info. (dbname/user/pass/dbhost)

The hosting company said this should have worked, but I'm getting an error on the webpage that says:

Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

Did I miss a step?
0
Comment
Question by:zequestioner
  • 6
  • 5
11 Comments
 
LVL 70

Expert Comment

by:Jason C. Levine
ID: 39897678
Three things that may have gone wrong.

1) you don't need to FTP all of WordPress, just the wp-content folder. You may have brought over something else you didn't need to and that could cause a 500

2) You need to edit the .sql file and make sure the file paths are changed from host 1 to host 2.  Those paths are used by plugins and can cause problems if not changed.

3) Did the FTP copy PHP as ASCII and other stuff as binary?
0
 
LVL 1

Author Comment

by:zequestioner
ID: 39897728
Wow, sounds like a lot of work... do you know how many places I would need to change the file paths in the DB? Is there a list of this somewhere?
0
 
LVL 1

Author Comment

by:zequestioner
ID: 39897732
I did edit the index.php:

/** require('./wp-blog-header.php');  */

require('./newSite.com/wp-blog-header.php');

Since on my new host, I'm setting up individual folders for each website on the new domain. This is the first site..

What's weird is if I leave it as default (currently commented out) that gives the error.. but if I change it to the latter, the site comes up with a blank page. When I view source there's a blank line 1 and nothing else...

Thoughts?
0
 
LVL 1

Author Comment

by:zequestioner
ID: 39897735
Note, when installing wordpress, I did set it to point to the correct folder as the default root directory for wp.
0
 
LVL 70

Expert Comment

by:Jason C. Levine
ID: 39897770
It's not as much work as you think.  I wrote an article a while back that deals with exactly how to do this:

http://www.experts-exchange.com/Web_Development/Blogs/WordPress/A_10258-How-To-Move-A-WordPress-Site.html

Since you are not changing domains, just skip those steps.  But all the others apply.
0
IT, Stop Being Called Into Every Meeting

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

 
LVL 1

Author Comment

by:zequestioner
ID: 39898740
Thanks for the info.. for some reason I'm still having problems. The site comes up (with the default wp theme) and the /wp-admin throws the same error. Any thoughts?
0
 
LVL 70

Expert Comment

by:Jason C. Levine
ID: 39898812
Because something is still not changed over to use the server 2 environment.
0
 
LVL 1

Author Comment

by:zequestioner
ID: 39899126
Bwp debug says there is no lib folder on the theme.. but there isn't. Can I remove the runonce function?
0
 
LVL 70

Expert Comment

by:Jason C. Levine
ID: 39899259
No idea.  Don't know what theme you are using , have no way to test your exact setup...
0
 
LVL 1

Author Comment

by:zequestioner
ID: 39899350
My apologies... here is the exact error from the wp debug. My question is this... what is the file I should look at, which references 'line 3'.... and is there a way to bypass the Warning: require_once since setup has already been run...

Here is the rest of the error:

Warning: require_once (some/path/wp-content/themes/crystal/lib/init.php): failed to open stream: No such file or directory in /some/path/wp-content/themes/crystal/functions.php on line 3 Fatal error: require_once(): Failed opening required

The weird the is that I've looked through the db file and cannot find references to /some/path since I've changed everything to the root path. /wp-everything....

Hope this helps.
0
 
LVL 70

Accepted Solution

by:
Jason C. Levine earned 500 total points
ID: 39899354
Server paths don't work the same way as URLs.  Changing everything to /wp-everything will break include and require statements.

/some/path/to/wordpress from server 1 needs to become /some/other/path/to/wordpress in order for things to work. This means you have to know what the new path is (use the pwd command on server 2)
0

Featured Post

What Should I Do With This Threat Intelligence?

Are you wondering if you actually need threat intelligence? The answer is yes. We explain the basics for creating useful threat intelligence.

Join & Write a Comment

I annotated my article on ransomware somewhat extensively, but I keep adding new references and wanted to put a link to the reference library.  Despite all the reference tools I have on hand, it was not easy to find a way to do this easily. I finall…
Using SQL Scripts we can save all the SQL queries as files that we use very frequently on our database later point of time. This is one of the feature present under SQL Workshop in Oracle Application Express.
This video teaches users how to migrate an existing Wordpress website to a new domain.
The viewer will learn how to count occurrences of each item in an array.

758 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

17 Experts available now in Live!

Get 1:1 Help Now