Exchange 2007 to 2013 coexistence OWA and Outlook anywhere not workikng correctly

Hello All and thank in advance,

I am migrating Exchange 2007 to 2013 and last night I configured the coexistence mode.

Exchnage 2013 is sitting on a 2012 R2 server and Exchange 2007 on a 2003 R2.

OWA was working fine in the begin but now externally it will redirect immediately to the legacy URL and nothing will load. Haven't change anything at all and I have checked my virtual directories to make sure that everything is correct same with the SSL.

Internally is working, but if I use an account that is on the 2007 exchange I will be able to  login but if I logout and try the owa url again it will redirect me to the legacy immediately (even if I do ctrl + F5 to clear the cache).

Second configuring phone email is working fine for the test user on the exchange 2013 but when I try to configure on my iphone a user that is on the 2007 exchange it fails.

Both Exchange servers are on the latest update.

Appreciate your time and help.
jamescarson69Asked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

jamescarson69Author Commented:
Hello All,

I resolved the first part of the OWA issue by making some changes in the Firewall. Now I am able to access OWA externally but again it redirects me immediately to the the legacy.domain.com/owa. So there is no way to login to OWA with a user created in Exchange 2013
0
jamescarson69Author Commented:
Also when I try the Microsoft Remote Analyzer for RPC while using the account of a user that exists in the Exchange 2013 everything is working fine. When I try the same test with a user account from the exchange 2007 It fails and I get the below

Attempting to ping RPC proxy owa.domain.co.uk.
       RPC Proxy can't be pinged.
       
      Additional Details
       
An HTTP 401 Unauthorized response was received from the remote Unknown server. This is usually the result of an incorrect username or password. If you are attempting to log onto an Office 365 service, ensure you are using your full User Principal Name (UPN).
Headers received:
request-id: a8da4815-131b-46d9-a400-19bbfa5ef11d
X-FEServer: DCLVMEX13
Content-Length: 0
Date: Sat, 01 Mar 2014 22:42:24 GMT
Server: Microsoft-IIS/8.5
WWW-Authenticate: Basic realm="owa.domain.co.uk"
X-Powered-By: ASP.NET
Elapsed Time: 183 ms.
0
Simon Butler (Sembee)ConsultantCommented:
First

"Exchange 2013 is sitting on a 2012 R2 server"

Is that Exchange 2013 SP1? If not, then you are in an unsupported scenario. Exchange 2013 prior to SP1 was not supported on Windows 2012 R2. Windows 2012 and 2012 R2 are not the same thing.

Simon.
0
Protecting & Securing Your Critical Data

Considering 93 percent of companies file for bankruptcy within 12 months of a disaster that blocked access to their data for 10 days or more, planning for the worst is just smart business. Learn how Acronis Backup integrates security at every stage

jamescarson69Author Commented:
Hello Simon,

Yes it is Exchange 2013 SP1
0
Simon Butler (Sembee)ConsultantCommented:
Exchange 2013 will proxy ActiveSync and Outlook Anywhere, but redirect OWA.
You need to ensure that ActiveSync has no external URL configured.

For Outlook Anywhere, it should just work, as long as the servers can see each other and the settings are close to default.

Simon.
0
jamescarson69Author Commented:
Hello Simon and thank you for the reply.

I spoke with Microsoft today and they helped me resolve the issue.

The OWA issue got resolved by itself not sure what to say about it:S

About active sync there were two issues:

First issue was that in the virtual directories I was using the external URL for the internal and as you suggested I had the external URL empty instead I should have used the FQDN of the server for the internal and the Microsoft engineer configured also the external URL.

And second is that on the IIS of the 2007 exchange at the active sync properties I had to enable the integrated windows authentication because as they told me when in coexistence basic authentication only will not work.
iis-for-active-sync.JPG
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
jamescarson69Author Commented:
Worked together with Microsoft Support and they resolved the issue with the above.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.