Solved

Lost paprtition on USB thumb drive

Posted on 2014-03-02
23
753 Views
Last Modified: 2014-03-23
I have a 8GB Sandisk Cruzer Glide USB stick with about 3GB free space, been working fine. Out of nowhere, Windows cant open it and wants to reformat it (E:\). Recuva doesnt recognize the file system (E:\). Mini XP from Hiren's boot disk does not see it. Im guessing something happened to the partition and that my files are still there just inaccessible at this time. How do I fix the partition? So far I tried Paragon's Rescue Kit but its about as helpful as a can of Crisco. Any bright ideas?

XP and 7

EDIT: I don't remember what file system it was originally (FAT32, NTFS).
I did not run chkdsk lest it somehow makes it worse (/f)?
The activity light is flashing rhythmically.
0
Comment
Question by:disciple_of_chim-chim
  • 9
  • 8
  • 4
  • +1
23 Comments
 
LVL 14

Expert Comment

by:Rob Miners
ID: 39899214
I haven't fully tested this sofware but it may help

Partition Wizard Windows PC and Server Disk Partition Management Software

Download from here:

http://download.cnet.com/MiniTool-Partition-Wizard-Home-Edition/3001-2094_4-10962200.html?hlndr=1

http://www.partitionwizard.com/download.html
0
 
LVL 18

Expert Comment

by:web_tracker
ID: 39899511
If the lights are flashing and disc management can recognize the usb stick it is possible you can repair the recovery partition, but if it is not able to recognize the drive period then you may be out of luck as the usb stick maybe damaged.
0
 

Author Comment

by:disciple_of_chim-chim
ID: 39899640
The mini tool does not see it. When inserted in USB port, Windows gives the "found it" sound. Windows warns that this device could work faster if connected to a high speed USB port. In my computer E: is grayed out . Disk properties>hardware> type is disk drive >properties>volumes>populate:

volume propertiesdisk managementIn my computer, it can be opened (empty). When trying to save a file to it:
item not foundIts not lookin good for the home team.
0
 
LVL 14

Expert Comment

by:Rob Miners
ID: 39899652
Try this

Click the Start button and in the search box type in cmd. Now press Ctrl+Shift + Enter, left Arrow and Enter again.
At a command prompt, type the following command, and then press the Enter key.
set devmgr_show_nonpresent_devices=1
Type the following command at the command prompt, and then press the Enter key.
start devmgmt.msc
 
NOTE: Click Show hidden devices on the View menu in Device Managers before you can see devices that are not connected to the computer.
 
Phantom Devices are icons that appear translucent or faded.
 
Delete all of the Phantom devices that are not connected to your Computer. Check under Portable Devices and Universal Serial Bus controlers. Also uninstall the device if it is listed in under Portable Devices.
 
Uninstall all devices under USB Controllers.
Uninstall all devices under Disk Drives.
Do the same under Storage Volumes leaving the exposed Generic volume.
If you have a yellow ! with unknown devices, uninstall all of the entries there as well.
I spent the time and went through everything and making an educated guess got rid of anything that didn't look approprite. I left my disconnected printer alone.
Restart the System and see if your drives are now detected as a couple of mine were.
0
 
LVL 91

Expert Comment

by:nobus
ID: 39899718
i would test it on another pc - to be sure it is still ok.
chances are it just went bad.
here the easus data recovery program,   http://www.easeus.com/resource/drive/usb-flash-drive.htm

but i fear it won't work until windows sees the stick..
0
 
LVL 18

Expert Comment

by:web_tracker
ID: 39902250
I had a similar problem with a memory stick, I ended up giving up on it as no matter what I did I could not access the memory stick, even when trying to access it in different computers. I finally gave up thinking that the usb stick is dead. Since memory sticks are cheap now it is better just to chuck it out then waste several hours trying to get it working again. Of course if there is valuable data on the stick that is another story. Sometimes the data on the stick is a hundred times worth more than the stick itself. Then if that is the case take it to a data recovery place before it dies and no one can retrieve data from it.
0
 
LVL 91

Expert Comment

by:nobus
ID: 39902580
and remember nevr to put valuable data on 1 usb device ONLY
0
 

Author Comment

by:disciple_of_chim-chim
ID: 39904106
@ nobus the Easus data recovery does not see the 8GB thumb drive.

Its in Device Manager, RAW in Disk management, in My Computer but Windows want to reformat it - "volume does not contain a recognized file system" and USB safe removal sees it and allows ejection. Thats a lot of contradiction.

@rrjmin0 There are 32 generic volumes under storage volumes. 2 are not grayed out. The stick, E drive, is listed under portable devices along with others from the past. Im not going to touch any of the 50 items under non PnP devices. There are 40 network monitors. The Sandisk is under disk drives along with like 20 others from the past, only an unattached Seagate is not grayed out. There are 32 generic volumes under storage volumes. 2 are not grayed out. There are 40 network monitors. The Sandisk is under disk drives along with like 20 others from the past. There are 70 items under USB controllers from unknown to composite to USB mass storage device to USB root hub. items that are not grayed out:
3 of 8 generic hubs
all 7 Intel USB host controllers                
all 8 USB root hubs


That a lot of deleting and uninstalling. I dunno, I cant say Im dying to do that (because of potential problems).
0
 
LVL 14

Expert Comment

by:Rob Miners
ID: 39904923
As web_tracker pointed out it can be futile to continue trying to fix the drive. If there is no important information on the drive I would replace it, if there is important information you can use a recovery service but be prepared to pay for it.
0
 

Author Comment

by:disciple_of_chim-chim
ID: 39905522
This drive,  compared to the 2TB USB Seagate that is 96% full of family and vacation video, means nothing. Im thinking did someone walk through my house with a BIG magnet? I realized that after i started this question but one thing at a time. When it rains its a torrential downpour - also dealing with a failed internal HDD secondary to bad sectors (in another question).  So since this is the same problem/failure as the thumb drive, Im not sure if its is appropriate or not to try and solve that problem in this thread or start another question.  Mods?

It is showing the same signs as the Sandisk, Windows says format it, Disk Management sees it as raw BUT the Mini Tool Partition Wizard does see it  and I can drill down in it with the explorer. It sees it's total capacity and that its 96% full. So much better off than the Sandisk. The EaseUS Data Recovery tool sees it too.  But being completely unfamiliar with both these apps, I hesitate to proceed. The Mini Tool has both partition utilities and Data Recovery tools. Im not 100% sure what exactly the problem is. A missing partition or what.
0
 
LVL 91

Expert Comment

by:nobus
ID: 39905630
did you try both on another PC? that's the first step to take !
that will show if they are ok - or not
the 2 TB drive - does it have it's own power supply? chances are your usb delivers not enough power (you could test by connecting only 1 device) or what i do : connect the usb devices with a POWERED usb hub
0
Better Security Awareness With Threat Intelligence

See how one of the leading financial services organizations uses Recorded Future as part of a holistic threat intelligence program to promote security awareness and proactively and efficiently identify threats.

 

Author Comment

by:disciple_of_chim-chim
ID: 39905663
yes, the first thing I did was try it on another machine. It has its own power supply AND its connected through a powered hub.
0
 
LVL 91

Expert Comment

by:nobus
ID: 39906017
and both are still not working on this, or the other PC?
then it can be :
the drive itself, the cable, or the usb bridge (case)
you cancheck if you can remove the disk from the external case, and connect it directly to a sata cable
if this fails too -the drive is bad
0
 

Author Comment

by:disciple_of_chim-chim
ID: 39906061
I dont follow. Are both what still working? The 8GB thumbdrive remains what appears to be empty. The 2TB drive has conflicting indicators. Disk Management sees it as raw BUT the Mini Tool Partition Wizard does see it  and I can drill down to the file level with the explorer. The file and folder structure is as it should be. It sees it's total capacity and that its 96% full. At the same time the EaseUS Data Recovery tool recognizes the drive but nothing more. That kinda leads me away from any singular hardware problem. I dont know whether to use the partition utility or the data recovery utility in the Mini Tool Partition Wizard since it seems to be the most promising. From what Ive described, is there a possibility it could be a lost or corrupt partition?
0
 
LVL 91

Expert Comment

by:nobus
ID: 39906614
it looks like the 8 Gb is dead
and the other one has problems. which ones is still to be determined, hard or soft.
try GetDataBack on the 2 tb drive, you can use it for free to check what it finds, only buy it  for storing the data.  http://www.runtime.org/      

it can be a file proble that can be cured by soft, but also a hardware problem, so what i said still holds :
then it can be :
the drive itself, the cable, or the usb bridge (case)
you can check if you can remove the disk from the external case, and connect it directly to a sata cable
if this fails too -the drive is bad
0
 
LVL 14

Expert Comment

by:Rob Miners
ID: 39908432
Follow  nobus's  advice and see how you get on.
0
 

Author Comment

by:disciple_of_chim-chim
ID: 39911444
Can either GetdataBack or Minitool Partition Wizard recover the partition and restore the drive back to previous state? If I have to recover it all to another drive, I dont have one. Minitool Partition Wizard took 24 hours to scan the drive but found everything. I dont know if it can restore the drive back to previous state or have to recover it all to another drive. The documentation on that seems to be a little scarce.
0
 
LVL 91

Expert Comment

by:nobus
ID: 39911752
Getdata back is a Data recovery soft - it does not set it to any state.
i never used the other tool - so : no comment
another drive is very cheap nowadays, and very much needed in this case (you can best recover to another drive - most softwares even don't allow  to store to the same drive)
0
 

Author Comment

by:disciple_of_chim-chim
ID: 39925550
Sorry for the delay. Last week I sustained multiple almost simultaneous drive failures. I began to suspect there was more going on than met the eye. The WD2500 in my office box boxed. I decided after a while to toss it and replace it with another WD2500. My GF knows just enough to be dangerous. After some waterboarding I got her to confess that since just wanted to help (bless her little pointed head) and since the drive was to be tossed, SHE DROPPED A DBAN DISK IN AND BOOTED FROM IT! >_< She thinks she used the Auto Nuke option. As the story goes, she realized that leaving the 8GB and 2TB USB drives connected might be a bad idea idea so she pulled them in less than a minute. Im guessing here but the 8GB was a total loss because it was the F drive and the 2TB was the N drive, so in effect the stick sacrificed itself to save the 2TB. o/0 So, its present status according to GetDataBack, its all there and all I have to do is let it copy the files to another drive. Now is the issue of where am I gonna put them temporarily, I did a quick inventory and I can scrape together about 1000GB, leaving me short 800GB of free space. I could eat rice and beans for a week and rustle up $100 for a 3TB Seagate but, if the drive is not physically damaged in any way and what i see is what a partition deletion job stopped in dead in its tracks would look like. Thats a critical point because if Im right, once I reformat it will work fine and can be trusted. Then I have a new drive I didnt need to buy. I did a 7GB practice run and GDB made it look easy

How much of this sounds plausible?
0
 
LVL 91

Accepted Solution

by:
nobus earned 500 total points
ID: 39925707
i assume you hit the right nail on the top -  and a GF around PC's ...can be..arh...causing ..let's say - problems
you can buy a 2 TB sata drive for much less than the 3 tb one - and have the GDB running
0
 

Author Comment

by:disciple_of_chim-chim
ID: 39930547
With these delays that HDD Regenerator found,  whats the prognosis?

HDD Regenerator pass
0
 
LVL 91

Expert Comment

by:nobus
ID: 39931000
Are the D charactors  showing on the diag??  there seems to be problems with either ram, or video; best correct these, before making cocnlusions!
0
 
LVL 91

Expert Comment

by:nobus
ID: 39948314
some more ideas :
run HDDRegenerator again - it may reduce the delays
then run the disk drive Diag, to make sure it responds OK
then try to use the drive again; you may need to run chkdsk
0

Featured Post

Google Storage: Standard vs. Nearline vs. Coldline

Google Cloud Storage has a number of classes to choose from. Although there are a lot in common, they vary in price and usage terms. This post explains Google Cloud Storage classes and helps to understand which  one to choose.

Join & Write a Comment

Don't buy such-and-such disk drives, they are not reliable!    Boy, how many times have we read a post from a well-meaning person who had some bad experiences with a drive and now they exclaim the entire company's products can't be trusted.  First, …
How to update Firmware and Bios in Dell Equalogic PS6000 Arrays and Hard Disks firmware update.
This video teaches viewers how to encrypt an external drive that requires a password to read and edit the drive. All tasks are done in Disk Utility. Plug in the external drive you wish to encrypt: Make sure all previous data on the drive has been …
This tutorial will walk an individual through the process of installing the necessary services and then configuring a Windows Server 2012 system as an iSCSI target. To install the necessary roles, go to Server Manager, and select Add Roles and Featu…

707 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

13 Experts available now in Live!

Get 1:1 Help Now