Solved

Setting up WDS to PXE boot on server 2003 with DHCP on same server

Posted on 2014-03-03
7
942 Views
Last Modified: 2014-03-03
I am trying to set up a WDS server on server 2003 that also has AD, DNS and DHCP configured. It all works when the client connects once in Windows but the server is not providing an IP address over DHCP when booting from the network to PXE boot. I have configured it with the guidelines on the Microsoft website so that WDS does not listen on port 67 and also PXEclient is on port 60 but it does not seem to work. Can anyone help me?
0
Comment
Question by:MSSC_support
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 3
7 Comments
 
LVL 21

Accepted Solution

by:
Radhakrishnan R earned 500 total points
ID: 39900683
Hi,

By default WDS will use UDP Port 67. But as this is also used by DHCP, a conflict can occur that can stop the DHCP Server service from binding to the network adapter and prevent computers from getting an IP address. This will occur if both services are set to Automatic startup and the server is rebooted. If WDS starts up before DHCP, it will grab port 67 and DHCP will subsequently issue errors such as:

"Error: The DHCP service is not servicing any clients because none of the active network interfaces have statically configured IP addresses, or there are no active interfaces."

If the DHCP Server service starts up before WDS service, then DHCP will use Ports 67 and 68, and WDS will use port 69.

To ensure this situation does not occur set the WDS service to Manual start.

Hope this helps.
0
 

Author Comment

by:MSSC_support
ID: 39900726
Ok, I tried that and manually started the WDS service but it still does not receive an IP over PXE. I get the message no DHCP OR proxyDHCP offers were received.
0
 
LVL 21

Expert Comment

by:Radhakrishnan R
ID: 39900759
You need to make the service manual, reboot the server, start the service and see it works?
0
Free eBook: Backup on AWS

Everything you need to know about backup and disaster recovery with AWS, for FREE!

 
LVL 21

Expert Comment

by:Radhakrishnan R
ID: 39900770
In addition to my earlier post. Open WDS>>Select the server>>Right click and properties>DHCP>>make sure both options are ticked "Do not listen on port 67" and "Configure DHCP options 60 to indicate that this server is also a PXE server"
0
 
LVL 21

Expert Comment

by:Radhakrishnan R
ID: 39900774
Also, make sure that you have added 060 PXEClient in DHCP>>Server Options? String value "PXEClient"
0
 

Author Comment

by:MSSC_support
ID: 39900789
I have done that but I still get the same error message.
0
 

Author Comment

by:MSSC_support
ID: 39900815
I have it working thank you! I had to authorise the DHCP as a final step.
0

Featured Post

Efficient way to get backups off site to Azure

This user guide provides instructions on how to deploy and configure both a StoneFly Scale Out NAS Enterprise Cloud Drive virtual machine and Veeam Cloud Connect in the Microsoft Azure Cloud.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Many of us need to configure DHCP server(s) in their environment. We can do that simply via DHCP console on server or using MMC snap-in on each computer with Administrative Tools installed in a network. But what if we have to configure many DHCP ser…
Learn how to PXE Boot both BIOS & UEFI machines with DHCP Policies and Custom Vendor Classes
In a recent question (https://www.experts-exchange.com/questions/29004105/Run-AutoHotkey-script-directly-from-Notepad.html) here at Experts Exchange, a member asked how to run an AutoHotkey script (.AHK) directly from Notepad++ (aka NPP). This video…

738 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question