Solved

Icon not working on gp deployed shortcut

Posted on 2014-03-03
5
536 Views
Last Modified: 2014-03-03
I deployed a desktop shortcut to all domain users via GP.  The link works, but the icon is blank.  I selected the icon during the editing of the policy.  What did I do wrong?
0
Comment
Question by:lpadmin1
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 2
5 Comments
 
LVL 3

Expert Comment

by:costanos
ID: 39901300
Where is the location of the icon youre using?
0
 

Author Comment

by:lpadmin1
ID: 39901305
i saved it to the c:\ of the server i am using for group policy changes
0
 
LVL 3

Accepted Solution

by:
costanos earned 500 total points
ID: 39901316
Make sure the icon is on the local machine of the computers youre trying to add the icon to.  You can do this using group policy as well.  

Create a new policy called something along the lines of icon transfer.

Edit the policy via Computer config > policies > windows settings > scripts and double click on the “Startup” script.

Click Show files and then right click in that window that comes up and create a new text document, naming it the same as you named the policy (doesn’t have to be the same just for reference) and .cmd extension.  So icontransfer.cmd is good.

Use the following command to make it perform the transfer:  xcopy domain.com\NETLOGON\iconname.ico C:\ /D (to place it in the local computers c:\).  Please change out domain.com with your domain.

Now make sure you place the .ico file in \\domain.com\NETLOGON

Then link this policy to the OUs you need it to run in.  That should do the trick.  Now you just need to change the location you used when you originally chose the icon and point it to \\domain.com\NETLOGON\iconname.ico

Placing it in the \\domain.com\NETLOGON and linking it there without copying it local MIGHT work, i have just not had luck without it being on the local system as well but i am not sure if its coincidence.
0
 

Author Closing Comment

by:lpadmin1
ID: 39901375
ok.. i dont know if it needed to be local or not but I did everything you said and did a gpupdate /force in my test OU and the icon is now displaying!

thanks!
0
 
LVL 3

Expert Comment

by:costanos
ID: 39901381
Glad you got it working!
0

Featured Post

Office 365 Training for IT Pros

Learn how to provision tenants, synchronize on-premise Active Directory, implement Single Sign-On, customize Office deployment, and protect your organization with eDiscovery and DLP policies.  Only from Platform Scholar.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This article shows the method of using the Resultant Set of Policy Tool to locate Group Policy that applies a particular setting.
Here's a look at newsworthy articles and community happenings during the last month.
This Micro Tutorial will give you a introduction in two parts how to utilize Windows Live Movie Maker to its maximum capability. This will be demonstrated using Windows Live Movie Maker on Windows 7 operating system.
There are cases when e.g. an IT administrator wants to have full access and view into selected mailboxes on Exchange server, directly from his own email account in Outlook or Outlook Web Access. This proves useful when for example administrator want…

689 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question