Solved

Time Capsule - Failed to mount disk image

Posted on 2014-03-03
30
2,764 Views
Last Modified: 2014-06-17
OS X 10.6.8


I have 2 Apple computers that are backing up to one Time Capsule using Time Machine. Currently the backup is not working on both computers. The message says that it can't mount the disk image. I tried using the Disk Utility to run a repair but it says that it can't fix it.

I found the following post that should solve my problem but I need step-by-step instructions.
http://www.experts-exchange.com/OS/Apple_Operating_Systems/OS_X/Q_27176518.html

In that post there is a reference to http://blog.jthon.com/?p=31 in which it talks about running HDIUTIL and FSCK_HFS. I need step-by-step help to run these commands.
0
Comment
Question by:LeonGarfield
  • 13
  • 8
  • 6
  • +1
30 Comments
 
LVL 40

Expert Comment

by:Eoin OSullivan
ID: 39903081
Before you get into command line tools .. have you tried??

1. Connect the TimeCapsule to one of your Macs via Ethernet cable and do not run diagnostics over WiFi.

2. Disabling Time Machine -  go into the Time Machine System Preferences, TURN IT OFF on both Macs

3. If you can open the TimeCapsule drive in the Finder but when you double click and try and mount  the specific sparseimage for the individual computer Time Machine backups .. it fails .. then you have a few choices.
  a. Try re-enabling Time Machine, reselect the TimeCapsule and it will try and restart a backup and it might resolve the issue
  b. Drag the sparsebundle to the Disk Utility sidebar, Select the sparsebundle, then click Repair, If the repair is successful, attempt to backup via Time Machine.
  c. You could try the more hardcore hdiutil tools - details here .. http://www.iotashan.com/2009/01/fixing-corrupt-time-machine-sparsebundles/
  d. Delete the sparsebundle backup and then re-enable the TimeMachine and reselect the TimeCapsule and it will create a brand new backup (you'll have lost the historic backups)
0
 
LVL 53

Expert Comment

by:strung
ID: 39903235
There is an excellent and very comprehensive Time Machine troubleshooting guide here:

http://pondini.org/TM/Troubleshooting.html
0
 

Author Comment

by:LeonGarfield
ID: 39904148
***********
Correction to my question.

One computer is NOT having a problem backing up to the Time Capsule.

Does this change the step you gave?
***********


1. The Time Capsule is always connected to Ethernet and so is the computer that is having the problem.

2. Disabling Time Machine -  Do I still need to turn off Time Machine on both computers since one of them it working?

3. If you can open the Time Capsule drive in the Finder - On the computer that is having the problem, in Finder, under Devices, there is no Time Capsule listed. On the computer that is working, in Finder, under Devices, the Time Capsule appears during the backup.




In system preferences for Time Machine, when Time Machine is trying to start a backup, it says "Making backup disk available".  

Sometimes when Time Machine gives up a window pops up and says:
Time Machine could not complete the backup. The backup disk image "/Volumes/Data/users iMac.sparsebundle" could not be accessed (error 109)
0
Enterprise Mobility and BYOD For Dummies

Like “For Dummies” books, you can read this in whatever order you choose and learn about mobility and BYOD; and how to put a competitive mobile infrastructure in place. Developed for SMBs and large enterprises alike, you will find helpful use cases, planning, and implementation.

 
LVL 40

Expert Comment

by:Eoin OSullivan
ID: 39904194
1. Good
2. No need to disable TimeMachine on working Mac (for now)
3. The fact that the TimeMachine is not appearing on the problem Mac ... or is giving the error (could not be accessed...) would indicate a problem with the connection
http://pondini.org/TM/C17.html

There are a few things you need to check .. as per the link above
hardware: is the Ethernet cable intact - any possible damage or wear on the cable?
network: is there any reason why the mac would lose or drop connection to the timecapsule?
software: use the working mac to open the timecapsule, view the sparsebundle file for the iMac that has problems and run it through the Repair Disk function in Disk Utility
0
 

Author Comment

by:LeonGarfield
ID: 39904580
On the website you gave it listed "Try repairing them, per item A5". According to this page http://pondini.org/TM/A5b.html the picture shows that in Finder, the Time Capsule should be listed under SHARED. In my comments above I was talking about the Devices list. My mistake.

-I found the sparsebundles and ran a repair-
1) I was successful connecting to the Time Capsule, 1st I had to click "connect as".
2) I dragged the sparsebundle to the Disk Utility and Ran the Repair.
I got this message:
This utility can't repair this disk. Backup as many files...and format the disk.

What next.
0
 
LVL 40

Expert Comment

by:Eoin OSullivan
ID: 39904590
Did you try and repair the sparsebundle?  Not the timecapsule itself?  You need to make sure it is the sparsebundle file which is being repaired.
0
 

Author Comment

by:LeonGarfield
ID: 39904604
There were 2 sparsebundles listed. I dragged the sparsebundle for the computer that has the problem.
0
 
LVL 40

Expert Comment

by:Eoin OSullivan
ID: 39904659
Can you try that same process with disk utility on the Mac which was failing to backup to timemachine .. in case it is permission-based errors which are preventing the repair.

Can you supply a screenshot of Disk Utility showing the application and error?
0
 

Author Comment

by:LeonGarfield
ID: 39905160
I already ran the Disk Utility using the computer with the problem.

So you want me to no run it on the computer that is working fine?
0
 
LVL 40

Expert Comment

by:Eoin OSullivan
ID: 39905642
I wanted you to attach a screenshot of disk utility on the computer that is working so we can see clearly the image being selected and the error.
The next stage is to run the command line repair tools as I outlined in step C in the earlier post.
0
 

Author Comment

by:LeonGarfield
ID: 39910503
Last time I ran the Disk Utility it gave a lot of information. This time no message appears in the Disk Utility, all that appears is a popup window that says it can't  fix the problem and to backup your data.
0
 
LVL 40

Expert Comment

by:Eoin OSullivan
ID: 39910775
Move onto the command line repair options step C ... unless you don't care about recovering the backup and are happy to start a new one in which case delete or rename the sparsebundle file that is not working and the iMac will create a new one when you restart Tiemmachine
0
 

Author Comment

by:LeonGarfield
ID: 39912804
How do I format the commands?

This is the Disk Image path /Volumes/Data/User's iMac (2).sparsebundle.
I got this from the Disk Utility.
Since there is a space in the path name, do I need to use quotes?
0
 
LVL 40

Expert Comment

by:Eoin OSullivan
ID: 39912813
There's a nice trick in OSX .. if you just type the command but don't enter any of the path to the sparsebundle file.
Instead .. drop the sparsebundle file onto the Terminal window and OSX will write the full path and quote or mark the spaces correctly.

If it looks OK then simply press RETURN to execute the command
0
 
LVL 29

Expert Comment

by:serialband
ID: 39913008
For those that prefer the keyboard over the mouse or touchpad, you can either put backslashes in front of the spaces and parethesis or just put quotes around the whole thing.  Quotes are simpler for typing in manually.  If you use command completion, the shell automatically puts backslashes if there aren't any name collisions.

/Volumes/Data/User's\ iMac\ \(2\).sparsebundle
"/Volumes/Data/User's iMac (2).sparsebundle"
0
 

Author Comment

by:LeonGarfield
ID: 39913844
I won't have access to the computer for 2 to 3 weeks. I will try it once I get back and post right away.
0
 

Author Comment

by:LeonGarfield
ID: 40047859
I finally was able to get to the mac and I ran the following with the results. The results are not like what is posted here http://blog.jthon.com/?p=31.  What next?

P.S. I modified on this post the name of the sparsebundle to keep the user anonymous.
 

Last login: Thu Mar  6 10:42:00 on console
js-imac-2:~ js$
js-imac-2:~ js$ hdiutil attach -nomount -readwrite /Volumes/Data/Jac\ SSS\ iMac\ \(2\).sparsebundle
/dev/disk1                Apple_partition_scheme               
/dev/disk1s1              Apple_partition_map                  
/dev/disk1s2              Apple_HFSX                           
js-imac-2:~ js$ fsck_hfs -rf /dev/disk1s2
** /dev/rdisk1s2
   Executing fsck_hfs (version diskdev_cmds-491.6~3).
** Checking Journaled HFS Plus volume.
   Invalid B-tree node size
(3, 0)
** The volume   could not be verified completely.
js-imac-2:~ js$
0
 
LVL 53

Accepted Solution

by:
strung earned 500 total points
ID: 40047949
It sounds like the disk directory is damaged beyond the ability of fsck to repair it.

Your only hope is Disk Warrior:  http://www.alsoft.com
0
 

Author Comment

by:LeonGarfield
ID: 40075598
that's it! I need to dump the backup and start from scratch?
0
 
LVL 53

Assisted Solution

by:strung
strung earned 500 total points
ID: 40075715
Either that or try to fix the backup with Disk Warrior.
0
 

Author Comment

by:LeonGarfield
ID: 40086993
I will try Disk warrior.

If it doesn't work how do I remove the corrupted sparsebundle and start anew? remember I have 2 computers backing up to the TimeCapsule and only one sparsebundle has a problem.
0
 
LVL 53

Assisted Solution

by:strung
strung earned 500 total points
ID: 40087027
Yes. You can simply remove the sparse bundle and start afresh. You will lose the ability to check for old erased or changed files, though, since your backup will be brand new.
0
 

Author Comment

by:LeonGarfield
ID: 40087086
1) how do I remove the sparse bundle?

and

2) If I hold onto the damaged sparcebundle, how do I tell timeMachine to leave the damaged one and start a new backup.
0
 
LVL 53

Assisted Solution

by:strung
strung earned 500 total points
ID: 40087140
Time Capsule should show up under "shared" in the sidebar of any finder window. If it does not, click "show" beside "shared".  Also make sure you have "connected servers" checked in the sidebar tab of the Finder prefs.

Double click on Time Capsule in Finder, then on the Data Volume. It may take a few seconds, but eventually the sparsebundle should appear and you can just drag it to the trash, or alternatively copy it to another volume, then trash it.

Telling it to ignore the existing sparse bundle is a complicate issue. You might have a look here:

http://pondini.org/TM/Troubleshooting.html
0
 

Author Comment

by:LeonGarfield
ID: 40134750
I was not able to fix the sparsebundle. It was time to throw in the towel. I had to delete it and start the backup from scratch.



Thank you for all your help.
0
 

Author Comment

by:LeonGarfield
ID: 40134825
I've requested that this question be closed as follows:

Accepted answer: 0 points for LeonGarfield's comment #a40134750

for the following reason:

I was not able to resolve the problem. The backup was too corrupted to be fixed. I had to delete all backups and start from scratch.
0
 
LVL 40

Expert Comment

by:Eoin OSullivan
ID: 40134826
Leon was given very comprehensive and thorough answers on all the possible ways to try and repair the TimeMachine. It is not the fault of the experts that the device was unable to be repaired.

The answers and steps are still valid so points should be awarded.
0
 
LVL 53

Expert Comment

by:strung
ID: 40141221
The answers given did lead to a solution. The solution was to delete the sparsebundle that was damaged beyond repair and create a fresh one. That solution appears explicitly in the series of questions and answers beginning at ID 40047949 and ending at ID 40087140 and was implicit in the answers given by Eoin O'Sullivan.
0

Featured Post

Free Tool: Site Down Detector

Helpful to verify reports of your own downtime, or to double check a downed website you are trying to access.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Mac Infection 16 59
facebook change 4 70
Restore MAC  computer back to its original OS 3 57
Me. Patrol Video app on a Mac 3 47
This article will cover some tips for successfully installing the new update to OS X; 10.5.7. Although the information contained within could be used for any OS X point release.  Please note that this information applies to point releases to a parti…
The /etc/authorization file in Mac OS X 10.x can be used to control access to the various panes of the System Preferences amongst other things. It’s used by some of us Mac Sys Admin’s to give Standard Users access to System Prefs panes that only adm…
This Micro Tutorial hows how you can integrate  Mac OSX to a Windows Active Directory Domain. Apple has made it easy to allow users to bind their macs to a windows domain with relative ease. The following video show how to bind OSX Mavericks to …
I've attached the XLSM Excel spreadsheet I used in the video and also text files containing the macros used below. https://filedb.experts-exchange.com/incoming/2017/03_w12/1151775/Permutations.txt https://filedb.experts-exchange.com/incoming/201…

733 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question