Password requested for EVERYONE share

Hi,

This is I'm sure simple enough....

I have a folder that needs to be shared (say c:\share) and it has been setup using advanced setup for share with all permissions. Security permissions on the other hand have been to be EVERYONE, initially with "most" permissions (except for taking ownership, changing perm, deleting the folder). Authenticated users, admin and system were left as are defaults.

The computer is visible but a password is requested when there is attempt to access the system \\computer or the share \\computer\sharename. I would have expected this with Authenticated users setup but not when EVERYONE permissions were added. It makes no difference if permission is set to full control.

Both systems (in this case) are Windows 7.

How can I have a custom share (not using public) and access across network without a password being required (and without setting up user account on the share computer).
LVL 2
DanielTAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

JohnBusiness Consultant (Owner)Commented:
You are not using Homegroup here (and I do not suggest it for this setup). The obverse of Homegroup is to use password protected sharing. So I think you will need to use password security.
Matthew KellyCommented:
You need to turn off password protected sharing. Attached is a screen shot from my Windows 8 machine but the below steps are for Windows 7:

1. Click Start
2. Under you user picture, right click Network
3. Choose Properties (this opens Control Panel\Network and Internet\Network and Sharing Center)
4. Click Choose homegroup and sharing options in the lower list (this opens Control Panel\Network and Internet\Network and Sharing Center\Homegroup)
5. Click Change advanced sharing settings... (this opens Control Panel\Network and Internet\Network and Sharing Center\Advanced sharing settings)
6. The setting right before the last one is: Password protected sharing!
7. Choose Turn off password protected sharing
passwordprotectedsharing.png

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Fred MarshallPrincipalCommented:
Even will all this, I've seen difficulties.  Another thing you can do is to set up a "standard user" on all the machines with the same password.  Then when you go to access files on another computer it may ask for the login.  But, once logged in, you never see that again .. ever.  So it seems like there's no login needed.  That'll bend your mind!  You need a login but you don't need a login.....

One way to see what's going on is to right click on Computer or This PC.
Then select
Manage / Computer Management (Local) / Shared Folders / Sessions
There you can see all the shares and who is logged in.
You might try this on a computer that's "working".
Get Cisco Certified in IT Security

There’s a high demand for IT security experts and network administrators who can safeguard the data that individuals, corporations, and governments rely on every day. Pursue your B.S. in Network Operations and Security and gain the credentials you need for this high-growth field.

JohnBusiness Consultant (Owner)Commented:
Windows 7 is a well-secured system and it is better to use usernames and passwords. You are more secure this way and will have fewer issues.
DanielTAuthor Commented:
Have to check some of your suggestions - thanks.

Typically I always setup with usernames, passwords etc but in this instance all local network users are to be able to access. This is transitioning from an XP system and not all users' are using proper credentials, thus the desire/need to share for all.

So what is the purpose of EVERYONE permissions if 'everyone cannot access when that permission is set? Surely it is different than Authenticated user or users. :))
JohnBusiness Consultant (Owner)Commented:
Once you are logged into a system, anyone logged in can access a folder permitted to Everyone. Everyone is NOT a log in permission.
Matthew KellyCommented:
Not all users are using proper credentials is maybe the real problem you need to fix. If you are getting push back from users/management, tell them they will get the logon prompt until everyone is in compliance.
DanielTAuthor Commented:
I knew about permissions and always do that but in this case it will not work for this client. I would do it differently but it's their choice.

The key was indeed to turn off password protected sharing, then the permissions and sharing setup worked just fine and also only for the intended folder.

Of course, everyone permissions were required and even though they had already been set (as per original question) but I have awarded some points to that post as it is a requirement as well.

Thanks.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Networking

From novice to tech pro — start learning today.