• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 341
  • Last Modified:

enable read/write in local path of home directory.

I have a IIS5 website that has READ, WRITE checked under the Home Directory tab of the website properties - please see the attached.

How do I setup the same thing in IIS7?

Thanks.
0
nav2567
Asked:
nav2567
  • 4
  • 2
1 Solution
 
nav2567Author Commented:
0
 
nav2567Author Commented:
Sorry, I forgot to send the screenshot.
0
 
David Johnson, CD, MVPOwnerCommented:
You need to work with the iis settings and the ntfs settings
http://preview.tinyurl.com/lxqu627
0
Easily Design & Build Your Next Website

Squarespace’s all-in-one platform gives you everything you need to express yourself creatively online, whether it is with a domain, website, or online store. Get started with your free trial today, and when ready, take 10% off your first purchase with offer code 'EXPERTS'.

 
nav2567Author Commented:
Sorry, that does not help.

Can you explain how I do it from the IIS 7 Manager?
0
 
gurutcCommented:
Hi,

Select the site or Vdir you want to set the perms for.

Click on Handler Mappings

Under Actions (On the right hand side pane) - Click on Edit Handler Permissions.

But to set Write Perms you have to select NTFS permission (not Handlers perms) which is not in IIS manager.

It's removed from the UI. You can select Explore option and then set the NTFS permissions on the folder from Windows Explorer.

- gurutc
0
 
nav2567Author Commented:
gurutc,

After I clicked on Handler Mapping, I ionly see "Edit Feature Permissions" but do not see "Edit Handler Permissions".  

I see READ, SCRIPT are checked but EXECUTE is unchecked.  Should I select EXECUTE?

As for NTFS permission, what account should I grant write if I want everyone who hits the website to have write permission?

Please ellobrate again.  

Thanks.
0
 
David Johnson, CD, MVPOwnerCommented:
Read/write is fine but execute is troublesome, as a user can write an executable and then execute the executable. For the NTFS permissions you would be setting permissions as per the Application Pool identity
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Easily Design & Build Your Next Website

Squarespace’s all-in-one platform gives you everything you need to express yourself creatively online, whether it is with a domain, website, or online store. Get started with your free trial today, and when ready, take 10% off your first purchase with offer code 'EXPERTS'.

  • 4
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now