Solved

Running window DHCP server in host-only mode on VMware workstation

Posted on 2014-03-04
9
4,110 Views
Last Modified: 2014-03-07
Hi

I am trying to set up a lab environment using VMware workstation 10.

I have 2 VMs, a Windows 8 client and a Windows Server 2012 R2 server.

I have put them both into VMnet2 which is configured as a host only network.

I have unchecked the box that enables the built in VMware DHCP server.

The windows server 2012 VM has dhcp server set up and it is authorized.

My Windows 8 VM will not pick up an IP address from the server.

Any suggestions to what I am doing wrong?
0
Comment
Question by:roy_batty
9 Comments
 
LVL 78

Expert Comment

by:David Johnson, CD, MVP
ID: 39903228
host only means that it will only communicate with the host and not other vm's nor the outside network.
0
 
LVL 13

Expert Comment

by:SagiEDoc
ID: 39903237
Do you have a domain controller for this lab? Having an authorised DHCP server you will also need a DC with working DNS. Another issue I can see here is that on physical switches there is a DHCP help address which is the address of the DHCP server, this provides clients with a means to identify the DHCP server and obtain an address. I am not aware of a way to set this helper address on a virtual switch in vmware.
0
 
LVL 1

Author Comment

by:roy_batty
ID: 39905842
I think I have been misunderstanding exactly what "host only" means. I thought any VM added to the host only network would be able to communicate with each other. Is this not the case?

I have therefore put both VMs on a NAT network. I'm still cant get the client to get an IP address from the server.
0
 
LVL 1

Author Comment

by:roy_batty
ID: 39906292
After moving both VMs to a NAT network I was still having issues getting the clients to talk to one another. I noriced that there was an additonal TAP-Windows Network adaptor which was confusing things on both VMs.

So I deleted all the network adaptors on both VMs and rebooted them and let them install the adaptors again (this time just the one adaptor each - no TAP)

It is all working now. Client VM is getting IP from DHCP VM.

Many thanks.
0
Better Security Awareness With Threat Intelligence

See how one of the leading financial services organizations uses Recorded Future as part of a holistic threat intelligence program to promote security awareness and proactively and efficiently identify threats.

 
LVL 16

Accepted Solution

by:
vivigatt earned 500 total points
ID: 39906306
You were right (and David Johnson is wrong) :
Host only is a "private network" internal to the host that does not allow packets to get outside this network.
All VMs in host-only can communicate together, and they can also communicate with the host, but that's all :
http://pubs.vmware.com/workstation-10/index.jsp?topic=%2Fcom.vmware.ws.using.doc%2FGUID-93BDF7F1-D2E4-42CE-80EA-4E305337D2FC.html

If you want the DHCP server to work from a guest VM, you have to check the usual stuff for DHCP servers.
DHCP server Authorization requires a Active Directory Domain. You can use a stand-alone server (no AD) with DHCP service, and then it does not need to be authorized (because it can't).
Things to check:
- Firewall (disable it completely for diagnosis purposes)
- Network Bindings
- Event Logs
- Reboot the DHCP Server VM and see if this is any better
0
 
LVL 1

Author Comment

by:roy_batty
ID: 39906342
Well its all working now and I also have the benefit of being able to access the internet from the VMs now too.

I only wanted to use host only to stop the Lab interfering with my home network. e.g didn't want wife's laptop to suddenly start getting ip addresses from the virtual dhcp server.

I now realize that this wouldn't happen anyway as the virtual nat network is "protected" by the nat itself. i.e no broadcast dhcp requests.

Now that the host-only function has been cleared up, I feel that the initial issue was caused by the dhcp server binding to the TAP adaptor.

You deserve some point for this but I think its too late now.

Thanks though.
0
 
LVL 16

Expert Comment

by:vivigatt
ID: 39906447
You accepted a wrong solution, that does not explain/resolve your issue and that may confuse users in the future !
Once again : a host-only network is a private network in which ALL the guests can communicate together and with the host but not with the outside world.
0
 
LVL 1

Author Closing Comment

by:roy_batty
ID: 39912037
As I mentioned. I think the issue was down to DNS server network bindings.

Thanks for the help guys.
0

Featured Post

IT, Stop Being Called Into Every Meeting

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

Join & Write a Comment

This article will show you how to create an ISO CD-ROM/DVD-ROM image (*.iso), and MD5 checksum signature, for use with VMware vSphere Hypervisor 6.5 (ESXi 6.5). It's a good idea to compare checksums, because many installations fail because of a corr…
HOW TO: Upload an ISO image to a VMware datastore for use with VMware vSphere Hypervisor 6.5 (ESXi 6.5) using the vSphere Host Client, and checking its MD5 checksum signature is correct.  It's a good idea to compare checksums, because many installat…
Windows 8 came with a dramatically different user interface known as Metro. Notably missing from that interface was a Start button and Start Menu. Microsoft responded to negative user feedback of the Metro interface, bringing back the Start button a…
With the advent of Windows 10, Microsoft is pushing a Get Windows 10 icon into the notification area (system tray) of qualifying computers. There are many reasons for wanting to remove this icon. This two-part Experts Exchange video Micro Tutorial s…

705 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

18 Experts available now in Live!

Get 1:1 Help Now