Mobile device defaults to test.website.com instead of www.website.com

Nicholas_BlueStar
Nicholas_BlueStar used Ask the Experts™
on
My website is: www.bluestarbussales.com

When I enter bluestarbussales.com on my desktop it will put in www. automatically.

When I do the same on my iPhone, (i.e. input bluestarbussales.com) it defaults to test.bluestarbussales.com - Can someone tell me how to fix this?
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Commented:
You have this on your page:
<script language=javascript>
<!--
if ((navigator.userAgent.match(/iPhone/i)) || (navigator.userAgent.match(/iPod/i))) {
location.replace("http://test.bluestarbussales.com/index-2.html");
}
-->
</script>

Open in new window


Change http://test.bluestarbussales.com/index-2.html with the page you want.

HTH,
Dan

Author

Commented:
Dan, you rock! Thanks!

Commented:
Glad I could help!
Announcing the Winners!

The results are in for the 15th Annual Expert Awards! Congratulations to the winners, and thank you to everyone who participated in the nominations. We are so grateful for the valuable contributions experts make on a daily basis. Click to read more about this year’s recipients!

Author

Commented:
Dan

I updated that line of code. I tried it on my phone and it is still re-directing me to the test.bluestarbussales.com

how can I verify that the code has been updated? Do I need to reset my browser or anything on my iPhone?

Commented:
If you're using Safari, you can go to Settings->Safari->Advanced->Website Data->Edit and delete the cache for your page.

Or you could force-kill Safari...

Author

Commented:
that did it! thanks again Dan!

Commented:
You're welcome

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial