Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 325
  • Last Modified:

Problem attaching mdf and log files

I am trying to attach a database to my sql server. both the mdf and the ldf files.

I point to them and when I click OK I get an error that "Access is denied  Error: 5120)

What should I do ?  I tried copying to different folder, I tried importing into a different computer, no luck.

Using MS SQL 2009 R2 Express, they are all the same version.
0
Aleks
Asked:
Aleks
  • 3
  • 2
1 Solution
 
Sreedhar VengalaSr. Consultant - Business IntelligenceCommented:
Add your user account to the System Administrator role. I suspect your account does not have the necessary permissions.
0
 
AleksAuthor Commented:
How do I do that  ?  

I have mixed mode and logging in with the admin user of windows
0
 
Sreedhar VengalaSr. Consultant - Business IntelligenceCommented:
If the user account already part of adminstrator role.  Try with below:

Perfom "run as administrator" for SQL Server Management Studio and try attaching the database.
0
Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

 
Anthony PerkinsCommented:
Make sure the mdf and ldf are on the same server as SQL Server Express.
0
 
AleksAuthor Commented:
They are in the same computer. Ill try running SQL Management as admin ...
0
 
AleksAuthor Commented:
Running the SQL Management as admin worked .. go figure !
0

Featured Post

Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

  • 3
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now