[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 637
  • Last Modified:

Localhost stopped working on xampp

HI Experts,

On a separate machine I have installed xampp, and the admin page was working. A few days  this machine was off, and then I installed NetBeans without re-checking if the Apache Admin site was working (http://localhost).

After installing Netbeans I wanted to go to phpMyAdmin, but it did not work. I did realized that the Apache admin site was not working also.

I disabled Windows Firewall, and my 3rd party antivirus/firewall, but still no dice. I unhooked my NAS drive from the network and it worked for a few minutes, then stopped again. I even unhooked my machine from the entire network, but it did not help.

I read online that it conflicts with Skype, and I used to have Skype on this machine, but removed it. I also don't have IIS on this machine.

Thank you
0
APD_Toronto
Asked:
APD_Toronto
  • 6
  • 5
1 Solution
 
belowzerotechCommented:
I'd maybe make sure your application is listening on localhost. One thing you can also do is make sure even apache is listening on localhost, try doing a telnet to localhost on port 80 and see what that yields.
0
 
APD_TorontoAuthor Commented:
how can I do what you say?
0
 
belowzerotechCommented:
Telnet to localhost on port 80 and you should see it connect. Then maybe instead of going to http://localhost try going to http://ipaddress see if that yields some different results.
0
What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

 
APD_TorontoAuthor Commented:
I tried http://192.168.1.117, but same error - server not reachable.

I do not understand what is telnet and how do I use it.
0
 
belowzerotechCommented:
type "telnet localhost 80" from the server and see if it responds with something like

Connected to localhost.
Escape character is '^]'.
then that is a good sign.

if it says something like

Trying 127.0.0.1...
telnet: connect to address 127.0.0.1: Connection refused

that's a bad sign and should start looking at the application being started. Also try alternating "localhost" for the server IP address and see what result you get.
0
 
APD_TorontoAuthor Commented:
from cmd I get 'telnet is not recognized ...
0
 
APD_TorontoAuthor Commented:
Ok, I googled this and enabled Telnet Client, but not Telnet Server

After I re-ran telnet localhost 80 and get a blank screen.

Should I also enable Telnet Server?

What do I do next?
0
 
belowzerotechCommented:
if it got a blank screen, you're likely in good shape. That means the server is listening on localhost. Likely if you have skype installed, it is listening on port 80 as well. If you have skype installed, you're likely going to have to uninstall it. which it looks like you have. You can run a "netstat -ab" and see what app is listening on port 80.

http://community.skype.com/t5/Modern-Windows-from-Windows/How-to-change-port/td-p/1173550
0
 
APD_TorontoAuthor Commented:
These are my netstat results, and  I se port 80 for a few.

However, I did a search for "localhost" and it isn't found, though I have apache started as a service.
netstat.txt
0
 
belowzerotechCommented:
So it looks like your computer is indeed listening on port 80 and apache the application listening. Could you perhaps post your apache config?
0
 
APD_TorontoAuthor Commented:
Where is my Apache config
0
 
lenamtlCommented:
The problem seems that you cannot run several web server on the same computer.
If you stop all Netbean services (and other web server services that you may have installed in the past IIS ) Xampp should work again.

If not, uninstall Xampp, restart computer then reinstall Xampp or Wampserver

In all case perform a backup of the htdocs - www folder and database folder prior to unsinstall just in case.

I prefer using Wampsever which is easier to set and userfriendly
http://www.wampserver.com/en/
0

Featured Post

Upgrade your Question Security!

Add Premium security features to your question to ensure its privacy or anonymity. Learn more about your ability to control Question Security today.

  • 6
  • 5
Tackle projects and never again get stuck behind a technical roadblock.
Join Now