Solved

Terminal server with broken clipboard

Posted on 2014-03-05
5
1,194 Views
Last Modified: 2014-03-12
Hi experts.

I upgraded a TS 2008 R2 to 2012 R2 (in 2 steps). All went right, all RemoteApps still work, but the clipboard lets us only transport text to and from the RemoteApps, no longer can we transport files via clipboard (Clients are still the same, win7/8.1 with latest RDP Clients)
I see no reason and the event log is clean, the Server is patched. Policies don't interfere.

Anyone seen and solved this before?
0
Comment
Question by:McKnife
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 2
5 Comments
 
LVL 8

Expert Comment

by:Lee Ingalls
ID: 39906353
Start Task Manager on the Terminal Server by pressing CTRL+SHIFT+ESC, and then verify that the Rdpclip.exe process is running. Note that by default, this process should start when you start your computer.
Start the Terminal Services Configuration snap-in from Administrative Tools.
Right-click the RDP-TCP Connection icon, and then click Properties.
Click the Permissions tab.
Click the Users icon (which represents normal users logging on to the Terminal Server), and then click Advanced.
Click Users, and then click View/Edit.
The Permission Entry for RDP-Tcp dialog box opens. Verify that the Virtual Channels entry has a check under the Allow column, and that the Deny column does not have a check. Click OK.
Click OK until all of the remaining dialog boxes are closed.

Reference: http://support.microsoft.com/kb/302443
0
 
LVL 55

Author Comment

by:McKnife
ID: 39906377
Sorry, without rdpclip.exe logically, no text transport would be possible , so yes, it is running.
About configuring the Terminal Services Configuration snap-in from Administrative Tools: this is not present in Server 2012, was last seen on 2008 R2.
0
 
LVL 8

Expert Comment

by:Lee Ingalls
ID: 39906408
Apologies for jumping the gun... went through the same thing on 2008 r2.
0
 
LVL 55

Accepted Solution

by:
McKnife earned 0 total points
ID: 39912362
OK, self-solved: expected behavior, see http://social.technet.microsoft.com/Forums/en-US/winserver8gen/thread/9c4eae05-b477-4c2d-8743-56508e870128/#d0e15223-6495-47a8-84fd-d8391857c86e

2012 R2 has changed the game: no longer possible if drive redirection is denied.
0
 
LVL 55

Author Closing Comment

by:McKnife
ID: 39922909
self-solved
0

Featured Post

Free NetCrunch network monitor licenses!

Only on Experts-Exchange: Sign-up for a free-trial and we'll send you your permanent license!

Here is what you get: 30 Nodes | Unlimited Sensors | No Time Restrictions | Absolutely FREE!

Act now. This offer ends July 14, 2017.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

My GPO's made for 2008 R2 servers were not allowing me to RDP into a new 2012 server by default.  That’s why I tried to allow RDP via Powershell, because I could log into a remote shell without further configuration. Below I will describe how I wen…
The following article is comprised of the pearls we have garnered deploying virtualization solutions since Virtual Server 2005 and subsequent 2008 RTM+ Hyper-V in standalone and clustered environments.
In this Micro Tutorial viewers will learn how to use Boot Corrector from Paragon Rescue Kit Free to identify and fix the boot problems of Windows 7/8/2012R2 etc. As an example is used Windows 2012R2 which lost its active partition flag (often happen…
In this Micro Tutorial viewers will learn how to restore their server from Bare Metal Backup image created with Windows Server Backup feature. As an example Windows 2012R2 is used.

728 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question