Remote Web Workplace - Shared Folders

lbit
lbit used Ask the Experts™
on
Running SBS 2008 R2 (2011).  I have a user who is restricted to only one sub-folder.  The structure is c:\shared data\folderx.  User A is denied access for the 'shared data' folder and allowed access for 'folderx'.  Both levels are shared folders.

shared data - share permissions is full control for EVERYONE;  NTFS is deny for User A.
FolderX - share permission is full control for EVEYRYONE; NTFS is full control for User A.

Works fine when User A is logged in at the office.  However, when using Remote Web Workplace, 'Shared Data' displays as a shared folder, but I cannot get the FolderX to show up.  And since he is denied Shared Data, he cannot get to FolderX.

I know it has something to do with denying access at the 'shared data' level because if I move the folder to the root level, all is good (and no, that is not a permanent option).  

Ideas?
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Top Expert 2016

Commented:
enable access based enumeration on the share.

Author

Commented:
Tried it - same result.  'folderx' does not appear in RWW shared files
Commented:
I was able to correct this by setting the root folder (shared data) to only read rights for 'this folder only' for the restricted user groups.  Then allowing full access to those user groups for 'folderx'.  That way they can see all folders/sub-folders but cannot access any files until they get to the level where they have permission.

Author

Commented:
easy to implement

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start Today