User Access to Server 2012 Remote Desktop

Hello Techies

I've been deploying several Server 2012 machines over the last couple weeks and I'm having trouble getting users to be able to login via Remote Desktop Connection.

I added one of the staff members to the "Remote Desktop Users" security group, but got this error on the login screen after making the connection:
To sign in remotely, you need the right to sign in through Remote Desktop Services. By default, members of the Administrators group have this right. If the group you're in doesn't have this right, or if the right has been removed from the Administrators group, you need to be granted this right manually.
After a little digging I thought I might need to install the Remote Desktop Services role and the Remote Desktop Licensing Manager. I did that and added 20 Server 2012 Device CALs to the system. However, this did not resolve the issue.

What am I missing here?



Thanks,
Brian
SkinnerTechAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Santosh GuptaCommented:
is this domain controller or member server ?

if member server then check the local GPO GPO_name\Computer Configuration\Windows Settings\Security Settings\Local Policies\User Rights Assignment
and see that Remote Desktop user is added to  "Allow log on through Remote Desktop Services" .

and its domain controller then also check "Allow logon locally" policy.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
SkinnerTechAuthor Commented:
sgupta1181

That was it!

This is a secondary domain controller, so I made the following changes:

Group Policy\Computer Configuration\Policies\Windows Settings\Security Settings\Local Policies\User Rights Assignment\Allow log on locally
Account operators
Administrators
Backup Operators
Print Operators
Remote Desktop Users
The first four groups are allowed by default if this settings is not defined, as described on the 'Explain' tab, so I kept them on the list to avoid any compatibility issues.

Group Policy\Computer Configuration\Policies\Windows Settings\Security Settings\Local Policies\User Rights Assignment\Allow log on through Remote Desktop Services
Administrators
Remote Desktop users
Again, 'Administrators' are allowed by default if this settings is not defined, so if you want 'Administrators' to have Remote Desktop Access you either have to add them to the Remote Desktop Users group or add 'Administrators' to this setting.
0
SkinnerTechAuthor Commented:
Great response time and accurate answer!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2012

From novice to tech pro — start learning today.