Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
?
Solved

Exchange 2010 Archive Database - Attachment Sizes

Posted on 2014-03-05
5
Medium Priority
?
321 Views
Last Modified: 2014-03-05
Greetings.  We recently set up personal archiving on our Exchange 2010 on-premises server. Mail over a certain age is moved automatically to the user's archive folder in an archive database.

Around the same time, I lowered the maximum send/receive message size from 30MB to 10MB.

One of the members of my test group informed me today that archiving is working perfectly, except that messages with large attachments are not being moved.

Are these two related ?  Is there a connection between the server moving messages automatically and the send/receive size on the Send Connector and Transport ? Interesting.

Thanks much.
-Stephen
0
Comment
Question by:lapavoni
  • 3
  • 2
5 Comments
 
LVL 44

Accepted Solution

by:
Adam Brown earned 2000 total points
ID: 39908010
When you drop the Send/Receive max it actually applies a maximum to the size of email that is stored anywhere on the server in the back end, so emails that break the new policy cannot be recreated in any mailbox including the archive, though they will remain where they are with no issues. This is kind of a hidden gotcha for Exchange that you never realize until something like this happens.
0
 

Author Comment

by:lapavoni
ID: 39908028
Thanks, acbrown.  That's a very good explanation.  That really seems to defeat the purpose of removing large chunks of mail from the user's main mailbox while preventing huge messages from accumulating again. Hmmm.
0
 

Author Closing Comment

by:lapavoni
ID: 39908029
Excellent.  Not good news for me, but exact answer to the question I asked.
0
 

Author Comment

by:lapavoni
ID: 39908032
I'm wondering if I can run a script to change the max/send receive every night before maintenance is done, then change it back in the morning ... sneaky :-)
0
 
LVL 44

Expert Comment

by:Adam Brown
ID: 39908196
yeah.
set-mailboxdatabase <database name> -prohibitsendquota 30MB -prohibitsendreceivequota 30MB 

Open in new window


set as a scheduled task before the exchange maintenance is scheduled should work. Then another with 10MB instead of 30MB to run right after. You'll just have to make sure the exchange management snap-in gets added prior to that line.
0

Featured Post

Free Tool: Site Down Detector

Helpful to verify reports of your own downtime, or to double check a downed website you are trying to access.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

If you have come across a situation where you need to find some EDB mailbox recovery techniques, then here you will find the same. In this article, we will take you through three techniques using which you will be able to perform EDB recovery. You …
You finally migrated Public Folders to Office 365, decommissioned the Public Folder mailbox database and since then, when you send an email from on-premise to mail-enabled Public Folders, you get the following error: "Misconfigured public folder mai…
This video shows how to quickly and easily deploy an email signature for all users in Office 365 and prevent it from being added to replies and forwards. (the resulting signature is applied on the server level in Exchange Online) The email signat…
This video shows how to quickly and easily add an email signature for all users on Exchange 2016. The resulting signature is applied on a server level by Exchange Online. The email signature template has been downloaded from: www.mail-signatures…
Suggested Courses
Course of the Month15 days, 11 hours left to enroll

580 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question