Problem with new site

Hi,
I've created one more site within the same Win 2008 server but I get this error

Service Unavailable


HTTP Error 503. The service is unavailable.

when I am going to the new site, that is
http://my-friend.co

then I have to stop the new site and start the old one, that is

http://my-friend.co/Start

and I get no problem when going to the old site, using the same server. why?
LVL 12
HuaMin ChenProblem resolverAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Emmanuel AdebayoGlobal Windows Infrastructure Engineer - ConsultantCommented:
Hi,

In the host header, you will need to use the site name instead of IP address for the two websites.

Regards
0
HuaMin ChenProblem resolverAuthor Commented:
Many thanks. Are you talking about Site Bindings or not? If not, where is host header?
0
David Johnson, CD, MVPOwnerCommented:
Yes that is in the Bindings.. hostname, port, ip address, one must be unique for each site
0
CompTIA Cloud+

The CompTIA Cloud+ Basic training course will teach you about cloud concepts and models, data storage, networking, and network infrastructure.

HuaMin ChenProblem resolverAuthor Commented:
Here are the bindings I have, while I also have the same for the previous site, which is working fine.
t679.png
0
HuaMin ChenProblem resolverAuthor Commented:
Any other help?
0
HuaMin ChenProblem resolverAuthor Commented:
Any help?
0
Monica PSoftware DeveloperCommented:
Check the target framework is set properly to the version of dotnet application you have created for all sites....

http://technet.microsoft.com/en-us/library/cc754523(v=ws.10).aspx
0
HuaMin ChenProblem resolverAuthor Commented:
No, I've started VS2013 already, which is of the new site I am talking about, while VS2012 is of the previous site.
https://dl.dropboxusercontent.com/u/40211031/t682.png

but I am still getting the same problem.
0
HuaMin ChenProblem resolverAuthor Commented:
Any other help?
0
GaryCommented:
I've requested that this question be deleted for the following reason:

The question has either no comments or not enough useful information to be called an "answer".
0
David Johnson, CD, MVPOwnerCommented:
do you have a dns entry for my-friend.co that points to the correct ip address?
0
HuaMin ChenProblem resolverAuthor Commented:
Yes, I have.

The question is why I cannot go to
http://my-friend.co

but I have to go to this

http://my-friend.co/Start
0
David Johnson, CD, MVPOwnerCommented:
in iis manager go to the site,
you will be presented with this viewif you switch to content view
Content View
What do you see there? Perhaps you should change your virtual directory to <whatever_it_is_now> to <whatever_it_is_now>\start
0
HuaMin ChenProblem resolverAuthor Commented:
Sorry, what to adjust to the following?

https://dl.dropboxusercontent.com/u/40211031/t835.png
0
HuaMin ChenProblem resolverAuthor Commented:
Gary,
Can you please hold on and wait for 2 weeks more to delete this, as I also want to see if there is one solution or not? Thanks a lot.
0
HuaMin ChenProblem resolverAuthor Commented:
Hi all,
I really want to object deleting this thread. Please help. Thanks  a lot
0
David Johnson, CD, MVPOwnerCommented:
you need to clilck on vs2012 and then show the contents .. is there a web.config located there?  any files at all?
0
HuaMin ChenProblem resolverAuthor Commented:
Sorry, what to adjust to VS2012 below?
https://dl.dropboxusercontent.com/u/40211031/t837.png
0
David Johnson, CD, MVPOwnerCommented:
you first have to SELECT the site as shown here
http://screencast.com/t/EXOiSB5H

I'm thinking that all you will see in the content is the folder start so you have to change the virtual directory to point to <path>\VS2012\Start
0
HuaMin ChenProblem resolverAuthor Commented:
Hi,
do you mean to add one VirtualDirectory, within VS2012 below?
https://dl.dropboxusercontent.com/u/40211031/t839.png

what to put above?
0
David Johnson, CD, MVPOwnerCommented:
since virtual directory that you named vs2012 can be pointing ANYWHERE what are the contents of that folder! is the folder start actually the location of your website's aspx/html files?
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
HuaMin ChenProblem resolverAuthor Commented:
VS2012 is actually pointing to this physical folder

C:\inetpub\VS2012

to which each time I do deploy the relevant projects.
0
HuaMin ChenProblem resolverAuthor Commented:
Any other help?
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
.NET Programming

From novice to tech pro — start learning today.