[Webinar] Streamline your web hosting managementRegister Today

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 300
  • Last Modified:

Disable one update action of puppet agent -test

Hi Guys,

One of our customers are having an issue with the contents of /etc/cron.d/* not being processed correctly and have decided to use crontab instead (until the issue is resolved).

However, our PuppetMaster is set to enforce the usage of /etc/cron.d/* and delete any crons under /var/spool/cron/ (once puppet agent -t is run).

Is there a way (perhaps in site.pp) to prevent the deletion of /var/spool/cron/ ?

Thank you.
0
m0nk3yza
Asked:
m0nk3yza
  • 2
  • 2
1 Solution
 
fiboCommented:
You might try to run your cron jobs as "at jobs", ie when a job has run it reschedules the next run.
Just a workaround to the real problem: cron.d
What happens there which create the problem?
0
 
m0nk3yzaAuthor Commented:
Hi Fibo,

There is some corruption in the cron files under /etc/cron.d/

Our developers are trying to resolve this issue.

The customer has placed all their crons in the root crontab, and this seems to work, but each time they run puppet agent -t, it reverts these changes.

So I wanted a temporary work-around to disable just the enforcement of this one directory (/etc/cron.d).
0
 
m0nk3yzaAuthor Commented:
The issue remains unresolved.
0
 
fiboCommented:
Can you find somethiung in the Puppet "jobs" which might cause this cron.d reiterated clean-up?
0

Featured Post

The new generation of project management tools

With monday.com’s project management tool, you can see what everyone on your team is working in a single glance. Its intuitive dashboards are customizable, so you can create systems that work for you.

  • 2
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now