Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 669
  • Last Modified:

My Cisco WS-C2948G-GE-TX will not autoboot

From cold start:

0:00.576482: ig0: 00:18:18:36:40:be is 10.0.10.12
0:00.577209: netmask: 255.255.255.0
0:00.577556: broadcast: 10.0.10.255
0:00.577890: gateway: 10.1.3.254
WS-C2948G-GE-TX bootrom version 6.1(6), built on 2003.09.19 15:52:35
H/W Revisions:    Fin: 2    Ventral: 7    Board: 1
Supervisor MAC addresses: 00:18:18:36:40:80 through 00:18:18:36:40:bf (64 addresses)
Installed memory: 64 MB
Testing LEDs.... done!
rommon 1 >

From set:

rommon 1 > set
PS1=rommon ! >
TftpServer=10.0.10.100
WHICHBOOT=bootflash:cat4000-k8.8-4-2-GLX.bin
DiagBootMode=post
MemorySize=64
ResetCause=20
TmpfsAddr=2197815296
TmpfsSize=12582912
TmpfsDirectorySize=10240
DiagFreePageLimit=12288
AutobootStatus=fail
?=0
CONFIG_FILE=bootflash:switch.cfg
WHICHBOOT=bootflash:cat4000-k8.8-3-2-GLX.bin
ROMVERSION=6.1(6)
rommon 2 >


I belive I have cat4000-k8.8-4-2-GLX.bin in flash but not cat4000-k8.8-3-2-GLX.bin
when I type in boot the switch bootes up and start running normally
0
soffcec
Asked:
soffcec
  • 10
  • 7
1 Solution
 
Jordan MedlenCommented:
Once booted, can you run "dir" and paste the output here?

Also, to change the boot file, issue the command syntax "set boot system flash device:<filename>"
0
 
soffcecManagerAuthor Commented:
How do I clear set boot system flash device: ? I did set wrong text into it.

dir say's dir <device>
0
 
soffcecManagerAuthor Commented:
Well, I was wrong about the filename, but still have the problem

Console> (enable) dir
-#- -length- -----date/time------ name
  1  4662592 --- -- ---- --:--:-- cat4000-k8.8-3-2-GLX.bin

11065920 bytes available (4662720 bytes used)
0
Who's Defending Your Organization from Threats?

Protecting against advanced threats requires an IT dream team – a well-oiled machine of people and solutions working together to defend your organization. Download our resource kit today to learn more about the tools you need to build you IT Dream Team!

 
soffcecManagerAuthor Commented:
What is the newest image I can use on this switch ?
0
 
Jordan MedlenCommented:
So run the following command....

"set boot system flash bootflash:cat4000-k8.8-3-2-GLX.bin"

This should change your boot parameter and allow for autoboot. It appears you get the config from a TFTP server. So, you will then copy the config to your TFTP server so that upon reload, it gets the correct information. Or, you can modify the config on the TFTP server so that it boots correctly.
0
 
soffcecManagerAuthor Commented:
This did not work , maybe because then BOOT variable is full of trash ?


PS1=rommon ! >
TftpServer=10.0.10.100
DiagBootMode=post
WHICHBOOT=bootflash:cat4000-k8.8-3-2-GLX.bin
MemorySize=64
ResetCause=6
TmpfsAddr=2197815296
TmpfsSize=12582912
TmpfsDirectorySize=10240
DiagFreePageLimit=12288
AutobootStatus=fail
?=0
CONFIG_FILE=bootflash:switch.cfg
WHICHBOOT=cat4000-k8.8-4-2-GLX.bin
BOOT=device:cat4000-k8.8-4-2-GLX.bin[A[A[A[A[A[A[A[A[A,1;device:cat4000-k8.8-4-2-GLX.bin,1;device:cat4000-k8.8-4-2-GLX.bin,1;device:cat4000-k8.8-4-2-GLX.bin,1;device:,1;device:,1;device,1;bootflash:cat4000-k8.8-3-2-GLX.bin,1;
ROMVERSION=6.1(6)
0
 
Jordan MedlenCommented:
Issue the following commands...

clear boot system all
set boot system flash bootflash:cat4000-k8.8-3-2-GLX.bin
0
 
Jordan MedlenCommented:
Add the following config line as well...

set boot auto-config bootflash:switch.cfg

If that is your actual config file.
0
 
soffcecManagerAuthor Commented:
rommon 3 > clear boot system all
Usage: clear boot
rommon 4 > set boot system flash bootflash:cat4000-k8.8-3-2-GLX.bin
Combined new BOOT variable would be too long!
Not changing BOOT variable in NVRAM.
rommon 5 >
0
 
Jordan MedlenCommented:
These commands need to be run after the switch has booted. So issue the boot command and once in the CatOS, then issue the commands I provided earlier.
0
 
soffcecManagerAuthor Commented:
The switch is still not booting.
I don't know the name of my .cfg file

Console> (enable) clear boot system all
BOOT variable =
Console> (enable) set boot system flash bootflash:cat4000-k8.8-3-2-GLX.bin
BOOT variable = bootflash:cat4000-k8.8-3-2-GLX.bin,1;
Console> (enable) set boot auto-config bootflash:switch.cfg
CONFIG_FILE variable = bootflash:switch.cfg
Warning: File not found but still added in the auto-config string.
Console> (enable)
0
 
Jordan MedlenCommented:
There may not be one. Have you done any other configurations on this switch?
0
 
soffcecManagerAuthor Commented:
No other configuration.
0
 
soffcecManagerAuthor Commented:
Still not working....
0
 
soffcecManagerAuthor Commented:
Did add config-register 0x0 and everything started working.
0
 
Jordan MedlenCommented:
My apologies. I've been in and out of meetings all day and was not able to get back to this. I am glad you got a solution.
0
 
soffcecManagerAuthor Commented:
Found the solution on http://cisco.com
0

Featured Post

Who's Defending Your Organization from Threats?

Protecting against advanced threats requires an IT dream team – a well-oiled machine of people and solutions working together to defend your organization. Download our resource kit today to learn more about the tools you need to build you IT Dream Team!

  • 10
  • 7
Tackle projects and never again get stuck behind a technical roadblock.
Join Now