Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

VMWare ESXi MPIO vs

Posted on 2014-03-06
5
Medium Priority
?
745 Views
Last Modified: 2014-03-09
I post my comment/question under HOW TO: Add an iSCSI Software Adaptor article.

Reading here
under Basic Requirements it is suggested to not use  to use MPIO or MC/S with Link Aggregation
Note: It is not recommended to use MPIO or MC/S with Link Aggregation Network Links, please select one method (MPIO or MC/S) or use Link Aggregation. Using both, while technically possible, is not practical, and involves complicated network setup.

I am wonder what is recommended to set up on physical switch instead?

I implemented configuration where both NIC for Synology NAS are set up via LACP  ethernet channel, and switch is configured with LACP and ports are bundled in port-channel.

On the ESXi side I below configuration creating MPIO,
and on the switch I have two ports bundled in port-channel.

How do you recommend the switch setup for that?
(I have separate vlan isolated from other traffic only for data storage.)
0
Comment
Question by:Martin Tarlink
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 2
5 Comments
 
LVL 42

Expert Comment

by:paulsolov
ID: 39909424
Keep in mind that if doing iscsi you should use MPIO and not link aggregation in most cases.  Link aggregation works well if you have a one to many IP sessions, but in most cases you have an ESXi host communicating from one IP on the ESXi host to the iscsi target.  It establishes a session and even though you may have many links in your lacp port group it can't span more than 1 nic.  LACP is good for VM network port group/vswitch because you have many VM sessions and thus multiple sessions taking advantage of more than one nic in the port group.

MPIO by default uses more than one nic (ensure you configure round robin on the datastore)
0
 
LVL 5

Author Comment

by:Martin Tarlink
ID: 39909517
So I should disable on the Catalyst
and change:
 
interface GigabitEthernet1/0/3
 description ESXi VM-STORAGE
 switchport access vlan 50
 switchport mode access
channel-group 5 mode on

interface GigabitEthernet2/0/3
 description ESXi VM-STORAGE
 switchport access vlan 50
 switchport mode access
 no channel-group 5 mode on

Open in new window

to
interface GigabitEthernet1/0/3
 description ESXi-2A VM-STORAGE
 switchport access vlan 50
 switchport mode access

interface GigabitEthernet2/0/3
 description ESXi-2A VM-STORAGE
 switchport access vlan 50
 switchport mode access

Open in new window


and using Synology NAS could I still use Link Aggregation with 2NIC so I will have one IP connection to the iSCSI Target, or it is recommended to set NIC separately? (if yes how than add iSCSI Target in ESXi?)



You have mentioned set Round Robin
http://forum.synology.com/wiki/index.php/How_to_use_iSCSI_Targets_on_VMware_ESXi_with_Multipath_I/O
I should probably follow STEP 9 from Mounting the iSCSI Target on the ESXi Hypervisor
0
 
LVL 42

Expert Comment

by:paulsolov
ID: 39909866
How are your vswitches configured?  That would have a a lot to do with how your switching is configured
0
 
LVL 5

Author Comment

by:Martin Tarlink
ID: 39910014
My vSwitch for Storage is configured as shown at the bottom of this post

One vSwitch with two VMKernel Ports that is associated with one NIC per VmKernel Port witch IP address associated to each.
0
 
LVL 42

Accepted Solution

by:
paulsolov earned 2000 total points
ID: 39911203
Yep, that's exactly how you should do it.  Just put each vmnic port on an access port on the switch with no etherchannel.  Or better yet on two switches to reduce single point of failure

So break the channel group and setup as individual ports
0

Featured Post

Automating Your MSP Business

The road to profitability.
Delivering superior services is key to ensuring customer satisfaction and the consequent long-term relationships that enable MSPs to lock in predictable, recurring revenue. What's the best way to deliver superior service? One word: automation.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

In this article, I will show you HOW TO: Perform a Physical to Virtual (P2V) Conversion the easy way from a computer backup (image).
In this article we will learn how to backup a VMware farm using Nakivo Backup & Replication. In this tutorial we will install the software on a Windows 2012 R2 Server.
Teach the user how to use configure the vCenter Server storage filters Open vSphere Web Client:  Navigate to vCenter Server Advanced Settings: Add the four vCenter Server storage filters: Review the advanced settings: Modify the values of the four v…
Advanced tutorial on how to run the esxtop command to capture a batch file in csv format in order to export the file and use it for performance analysis. He demonstrates how to download the file using a vSphere web client (or vSphere client) and exp…

722 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question