Solved

Backup Exec attempted to back up an Exchange database according to the job settings. The database was not found

Posted on 2014-03-06
8
1,204 Views
Last Modified: 2014-03-11
Hi,

I am having a hard to figure out this one, so I am reverting to the experts ;)
Hope you can help me on that one.

We have a Backup Exec 2012 server on the same physical machine as our Exchange2010/DC server. I know, I shouldn't have ;)

We've been without a successful backup of this critical server for a few weeks now. There was another blocker before, but for a few days now, the backup states it cannot find the only MailboxDatastore we have.

Backup Exec attempted to back up an Exchange database according to the job settings. The database was not found

V-79-57344-913 - Backup Exec attempted to back up an Exchange database according to the job settings. The database was not found, however. Update the selection list and run the job again.

BEREMOTE: [03/05/14 13:52:13] [10608] 2014-03-05T13:52:08.373 [ndmp\ndmpsrvr] | Backup Job Starting
 BEREMOTE: [03/05/14 13:52:13] [10608] 2014-03-05T13:52:08.374 [ndmp\loops] - The media server PDC is already in the advertisement list.
 BEREMOTE: [03/05/14 13:52:13] [10608] 2014-03-05T13:52:08.374 [fsys\ese] - [ESE_AttachToDLE] device_name:\\pdc.processia2003.com\Microsoft Information Store\Mailbox Database 0056630370 attach_reason:0x21 backup_type:4
 BEREMOTE: [03/05/14 13:52:13] [10608] 2014-03-05T13:52:08.374 [fsys\ese] - [ESE_ValidateBackup] Mailbox Database 0056630370 enter ...
 BEREMOTE: [03/05/14 13:52:13] [10608] 2014-03-05T13:52:08.374 [fsys\shared] - Monad RPC timeout 300000
 BEREMOTE: [03/05/14 13:52:13] [10608] 2014-03-05T13:52:08.374 [fsys\shared] - EseProcess::Init: OpenThreadToken successful
 BEREMOTE: [03/05/14 13:52:13] [10608] 2014-03-05T13:52:08.375 [fsys\shared] - ESE07 Create process returned 522
 BEREMOTE: [03/05/14 13:52:13] [10608] 2014-03-05T13:52:08.375 [fsys\shared] - ESE07 process not ready
 BEREMOTE: [03/05/14 13:52:13] [10608] 2014-03-05T13:52:08.375 [fsys\ese] - [ESE_ValidateBackup] exit (0xe000ff21).
 BEREMOTE: [03/05/14 13:52:13] [10608] 2014-03-05T13:52:08.375 [ndmp\loops] - LP_ENV::MsgError: error 0xe000ff21 processing object <Unknown>
 BEREMOTE: [03/05/14 13:52:13] [10608] 2014-03-05T13:52:08.375 [ndmp\ndmpsrvr] + ndmp_data.cpp (13051):
 BEREMOTE: [03/05/14 13:52:13] [10608] 2014-03-05T13:52:08.375 [ndmp\ndmpsrvr] | Backup Job Stopped(0)
 BENGINE: [03/05/14 13:52:13] [5236] 2014-03-05T13:52:08.375 [server] - Test Run Error: e000ff21

Every BE service is running under the domain administrator account
It is configured as the system account in BE.
Assigned to the job.
The administrator account has Organisation management rôle in Exchange and is member of Back Operator group, as well as Domain Admin group.

The credential tests fail on the Mailboxstore in BE.

I rebooted the server.

vssadmin list writers gives me all stable writers.

Tried this :
http://www.symantec.com/business/support/index?page=content&id=TECH209154&actp=search&viewlocale=en_US&searchid=1394030905270

Tried those too :
http://www.symantec.com/business/support/index?page=content&id=TECH140090

Only thing I am seeing, is that the domain Administrator is not a local admin on the DC, as there are no local admins on DCs.

Any hint ?

Exchange is @ SP3, but not roll update 3, should I ? (Knowing I don't have a good backup in case of a problem)

Thanks for your help !
0
Comment
Question by:maxalarie
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 2
8 Comments
 
LVL 32

Accepted Solution

by:
Rodney Barnhardt earned 500 total points
ID: 39912388
It did not look like you view this one which applies to 2010 and 2012. It all points to user authentication.

http://www.symantec.com/business/support/index?page=content&id=TECH137852

You are correct in that your server configuration is highly discouraged and can be problematic. As you mentioned, the above document says that the backup account must be in the local admins group on the server. You could try creating a specific BE service account that is not the domain administrator account, giving it all needed permissions and try that. I have seen a corrupt logon within BE cause problems and a new account correct that issue.
0
 
LVL 17

Expert Comment

by:Gerald Connolly
ID: 39916954
Curious why you are using NDMP if your BE is running on the same server as Exchange?
0
 
LVL 2

Author Comment

by:maxalarie
ID: 39917565
Hi guys,

sorry, I was sick friday.

@Aikimark, thanks for the addition.

@Rodney, I did see that one.
We did try to create another account and make give it all priviledges, it didn't work.
Some of the services mentionned are not running as system logon account though, will check that.

How do you make a user member of local admin group on a primary domain controler ?

@Gerald
We are exporting the backup on a  NAS
0
Problems using Powershell and Active Directory?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

 
LVL 2

Author Comment

by:maxalarie
ID: 39917584
Wow, running the agent as local system account did it.
I get a success now from the Credential Tests. Will tell you more tomorrow as I run the backup tonight.

Thanks for your help !
0
 
LVL 17

Expert Comment

by:Gerald Connolly
ID: 39918076
NDMP is normally used to get data off a filer, rather than put data on a NAS box, when it should just be a file operation
0
 
LVL 2

Author Comment

by:maxalarie
ID: 39918128
We configured this as a storage in BE, and configured a backup-to-disk, this was never a choice we made to use NDMP.

I am suspecting by backup will fail anyway.
Running a test job fails without much details.
Will have to see tonight, as the debug tools doesn't give me much, while running the test.
0
 
LVL 2

Author Comment

by:maxalarie
ID: 39920443
Full backup was a success ! Thanks for your support experts !
0

Featured Post

Instantly Create Instructional Tutorials

Contextual Guidance at the moment of need helps your employees adopt to new software or processes instantly. Boost knowledge retention and employee engagement step-by-step with one easy solution.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
VB.Net creating Contact in Outlook 1 49
Save Exchange PowerShell Command 12 31
Can't open Apps in Windows 10 8 64
RPC Proxy can't be pinged 4 25
Utilizing an array to gracefully append to a list of EmailAddresses
Having trouble getting your hands on Dynamics 365 Field Service or Project Service trial? Worry No More!!!
The viewer will learn how to create two correlated normally distributed random variables in Excel, use a normal distribution to simulate the return on different levels of investment in each of the two funds over a period of ten years, and, create a …
how to add IIS SMTP to handle application/Scanner relays into office 365.

740 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question