Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

Backup Exec attempted to back up an Exchange database according to the job settings. The database was not found

Posted on 2014-03-06
8
Medium Priority
?
1,250 Views
Last Modified: 2014-03-11
Hi,

I am having a hard to figure out this one, so I am reverting to the experts ;)
Hope you can help me on that one.

We have a Backup Exec 2012 server on the same physical machine as our Exchange2010/DC server. I know, I shouldn't have ;)

We've been without a successful backup of this critical server for a few weeks now. There was another blocker before, but for a few days now, the backup states it cannot find the only MailboxDatastore we have.

Backup Exec attempted to back up an Exchange database according to the job settings. The database was not found

V-79-57344-913 - Backup Exec attempted to back up an Exchange database according to the job settings. The database was not found, however. Update the selection list and run the job again.

BEREMOTE: [03/05/14 13:52:13] [10608] 2014-03-05T13:52:08.373 [ndmp\ndmpsrvr] | Backup Job Starting
 BEREMOTE: [03/05/14 13:52:13] [10608] 2014-03-05T13:52:08.374 [ndmp\loops] - The media server PDC is already in the advertisement list.
 BEREMOTE: [03/05/14 13:52:13] [10608] 2014-03-05T13:52:08.374 [fsys\ese] - [ESE_AttachToDLE] device_name:\\pdc.processia2003.com\Microsoft Information Store\Mailbox Database 0056630370 attach_reason:0x21 backup_type:4
 BEREMOTE: [03/05/14 13:52:13] [10608] 2014-03-05T13:52:08.374 [fsys\ese] - [ESE_ValidateBackup] Mailbox Database 0056630370 enter ...
 BEREMOTE: [03/05/14 13:52:13] [10608] 2014-03-05T13:52:08.374 [fsys\shared] - Monad RPC timeout 300000
 BEREMOTE: [03/05/14 13:52:13] [10608] 2014-03-05T13:52:08.374 [fsys\shared] - EseProcess::Init: OpenThreadToken successful
 BEREMOTE: [03/05/14 13:52:13] [10608] 2014-03-05T13:52:08.375 [fsys\shared] - ESE07 Create process returned 522
 BEREMOTE: [03/05/14 13:52:13] [10608] 2014-03-05T13:52:08.375 [fsys\shared] - ESE07 process not ready
 BEREMOTE: [03/05/14 13:52:13] [10608] 2014-03-05T13:52:08.375 [fsys\ese] - [ESE_ValidateBackup] exit (0xe000ff21).
 BEREMOTE: [03/05/14 13:52:13] [10608] 2014-03-05T13:52:08.375 [ndmp\loops] - LP_ENV::MsgError: error 0xe000ff21 processing object <Unknown>
 BEREMOTE: [03/05/14 13:52:13] [10608] 2014-03-05T13:52:08.375 [ndmp\ndmpsrvr] + ndmp_data.cpp (13051):
 BEREMOTE: [03/05/14 13:52:13] [10608] 2014-03-05T13:52:08.375 [ndmp\ndmpsrvr] | Backup Job Stopped(0)
 BENGINE: [03/05/14 13:52:13] [5236] 2014-03-05T13:52:08.375 [server] - Test Run Error: e000ff21

Every BE service is running under the domain administrator account
It is configured as the system account in BE.
Assigned to the job.
The administrator account has Organisation management rôle in Exchange and is member of Back Operator group, as well as Domain Admin group.

The credential tests fail on the Mailboxstore in BE.

I rebooted the server.

vssadmin list writers gives me all stable writers.

Tried this :
http://www.symantec.com/business/support/index?page=content&id=TECH209154&actp=search&viewlocale=en_US&searchid=1394030905270

Tried those too :
http://www.symantec.com/business/support/index?page=content&id=TECH140090

Only thing I am seeing, is that the domain Administrator is not a local admin on the DC, as there are no local admins on DCs.

Any hint ?

Exchange is @ SP3, but not roll update 3, should I ? (Knowing I don't have a good backup in case of a problem)

Thanks for your help !
0
Comment
Question by:maxalarie
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 2
8 Comments
 
LVL 32

Accepted Solution

by:
Rodney Barnhardt earned 2000 total points
ID: 39912388
It did not look like you view this one which applies to 2010 and 2012. It all points to user authentication.

http://www.symantec.com/business/support/index?page=content&id=TECH137852

You are correct in that your server configuration is highly discouraged and can be problematic. As you mentioned, the above document says that the backup account must be in the local admins group on the server. You could try creating a specific BE service account that is not the domain administrator account, giving it all needed permissions and try that. I have seen a corrupt logon within BE cause problems and a new account correct that issue.
0
 
LVL 17

Expert Comment

by:Gerald Connolly
ID: 39916954
Curious why you are using NDMP if your BE is running on the same server as Exchange?
0
 
LVL 2

Author Comment

by:maxalarie
ID: 39917565
Hi guys,

sorry, I was sick friday.

@Aikimark, thanks for the addition.

@Rodney, I did see that one.
We did try to create another account and make give it all priviledges, it didn't work.
Some of the services mentionned are not running as system logon account though, will check that.

How do you make a user member of local admin group on a primary domain controler ?

@Gerald
We are exporting the backup on a  NAS
0
Are your AD admin tools letting you down?

Managing Active Directory can get complicated.  Often, the native tools for managing AD are just not up to the task.  The largest Active Directory installations in the world have relied on one tool to manage their day-to-day administration tasks: Hyena. Start your trial today.

 
LVL 2

Author Comment

by:maxalarie
ID: 39917584
Wow, running the agent as local system account did it.
I get a success now from the Credential Tests. Will tell you more tomorrow as I run the backup tonight.

Thanks for your help !
0
 
LVL 17

Expert Comment

by:Gerald Connolly
ID: 39918076
NDMP is normally used to get data off a filer, rather than put data on a NAS box, when it should just be a file operation
0
 
LVL 2

Author Comment

by:maxalarie
ID: 39918128
We configured this as a storage in BE, and configured a backup-to-disk, this was never a choice we made to use NDMP.

I am suspecting by backup will fail anyway.
Running a test job fails without much details.
Will have to see tonight, as the debug tools doesn't give me much, while running the test.
0
 
LVL 2

Author Comment

by:maxalarie
ID: 39920443
Full backup was a success ! Thanks for your support experts !
0

Featured Post

Nothing ever in the clear!

This technical paper will help you implement VMware’s VM encryption as well as implement Veeam encryption which together will achieve the nothing ever in the clear goal. If a bad guy steals VMs, backups or traffic they get nothing.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

If you troubleshoot Outlook for clients, you may want to know a bit more about the OST file before doing your next job. IMAP can cause a lot of drama if removed in the accounts without backing up.
This article shows how to use a free utility called 'Parkdale' to easily test the performance and benchmark any Hard Drive(s) installed in your computer. We also look at RAM Disks and their speed comparisons.
how to add IIS SMTP to handle application/Scanner relays into office 365.
In this video, Percona Solutions Engineer Barrett Chambers discusses some of the basic syntax differences between MySQL and MongoDB. To learn more check out our webinar on MongoDB administration for MySQL DBA: https://www.percona.com/resources/we…

721 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question